OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Compiling Wxgtk & Pygtk Question, version numbers matter?
ZDevil
post Aug 30 2006, 03:11 AM
Post #1





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Hi, there,

As some may have noticed, the current wxgtk package only contains the libraries without the include headers and the wx-config in the SDK wrongly linked to the dir in sashz's own computer, while there is one very old build of wxwindows in a 5500 feed; and there is simply no pygtk package for pdax compiled so far [EDITED: this is WRONG. See the post #6 below tongue.gif ]. Some useful apps need them to build, such as gjots2 (depending on pygtk, gnome-python and pyorbit) and poEdit (depending on wxgtk/wxwidgets).
After some trials, I manage to compile (both cross and natively) a new and full-fledged version of wxgtk and pygtk, and am just thinking of putting them up here. smile.gif
Before I do that, I just wanna ask one stupid question: both wxgtk and pygtk show version numbers that seem to correspond to the GTK version numbers, e.g. pygtk 2.8 looks for gtk > 2.8. If that is the case, shall I go for wxgtk and pygtk versions matching exactly the current version of GTK in pdaX (= 2.6.2)? rolleyes.gif

Many thanks!

This post has been edited by ZDevil: Aug 30 2006, 06:45 AM
Go to the top of the page
 
+Quote Post
desertrat
post Aug 30 2006, 03:52 AM
Post #2





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



QUOTE(ZDevil @ Aug 30 2006, 11:11 AM)
Before I do that, I just wanna ask one stupid question: both wxgtk and pygtk show version numbers that seem to correspond to the GTK version numbers, e.g. pygtk 2.8 looks for gtk > 2.8. If that is the case, shall I go for wxgtk and pygtk versions matching exactly the current version of GTK in pdaX (= 2.6.2)?  rolleyes.gif

No idea, maybe take a look at how other distros name them?
Go to the top of the page
 
+Quote Post
ZDevil
post Aug 30 2006, 03:57 AM
Post #3





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(desertrat @ Aug 30 2006, 01:52 PM)
QUOTE(ZDevil @ Aug 30 2006, 11:11 AM)
Before I do that, I just wanna ask one stupid question: both wxgtk and pygtk show version numbers that seem to correspond to the GTK version numbers, e.g. pygtk 2.8 looks for gtk > 2.8. If that is the case, shall I go for wxgtk and pygtk versions matching exactly the current version of GTK in pdaX (= 2.6.2)?  rolleyes.gif

No idea, maybe take a look at how other distros name them?
*



Thanks. I have already checked out the docs in the sources and the official sites but i have yet to see a clue. Any hint would be much appreciated! rolleyes.gif
Go to the top of the page
 
+Quote Post
Chero
post Aug 30 2006, 05:42 AM
Post #4





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



I've seen debian packages depending on pygtk 2.6 and gtk+ 2.8, so my guess is it doesn't matter.

BTW : an old version of pygtk is in one of the (very) old feeds (but still usable).

Chero.
Go to the top of the page
 
+Quote Post
ZDevil
post Aug 30 2006, 05:57 AM
Post #5





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(Chero @ Aug 30 2006, 03:42 PM)
I've seen debian packages depending on pygtk 2.6 and gtk+ 2.8, so my guess is it doesn't matter.

BTW : an old version of pygtk is in one of the (very) old feeds (but still usable).

Chero.
*


Hey thanks for the hint, Chero!
Yet my question is whether a pygtk/wxgtk with a greater version number than gtk is usable with that version of gtk, e.g. pygtk 2.9 & gtk 2.6. Your example may not be a problem coz pygtk has got a lower version number than that of gtk.
Still my impression (illusion?) is that the version numbers of pygtk (and/or wxGTK/wxWidgets) seem to go up along with the version numbers of gtk. Is that true? rolleyes.gif
I ask this because I remember when trying to compiling pygtk 2.8 I got a GTK version checking error at configure time which complained about not high enough version of gtk+ (> 2.8).
The problem of that old package (wxWindows 2.5.1 - sidenote: wxWindows is the older name for wxWidgets) is that it doesn't seem to be updated enough for the current versions of some programs, such as poEdit. Plus I am not sure whether that package would create confusion with the current wxWidgets (2.6.1) package in here: http://mail.pdaxrom.org/contrib/1.1.0beta3...s-7x0-860/feed/ . Also wx-config and the headers are missing in the 2.6.1 package. As I mentioned the wx-config in the SDK only links to some path in sashz's computer. After make I have to remove wx-config and create a correct link before packaging and installing. smile.gif
(BTW actually I already got poEdit compiled and packaged based on my test package of wxGTK-2.6.3 and have been testing it for a couple of days. It seems kinda working. wink.gif )

Any more hints? Thanks in advance!
Go to the top of the page
 
+Quote Post
ZDevil
post Aug 30 2006, 06:43 AM
Post #6





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(Chero @ Aug 30 2006, 03:42 PM)
I've seen debian packages depending on pygtk 2.6 and gtk+ 2.8, so my guess is it doesn't matter.

BTW : an old version of pygtk is in one of the (very) old feeds (but still usable).

Chero.
*


Sorry Chero, you are right. There are pygtk packages in the Beta1 and Beta3 feeds.
Actually what I found missing there are the pkgconfig, pygtk, codegen and defs stuff, which show up in my trial builds. They are essential to build apps depending on pygtk. smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 01:35 AM