OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Mplayer, Libmad0 Problems, executable stacks?!?
STrRedWolf
post Aug 22 2006, 09:18 PM
Post #1





Group: Members
Posts: 36
Joined: 31-December 03
Member No.: 1,319



Zaurus SL-5500, OE latest stable. Every time I try to run Mplayer:

CODE
root@collie:~# mplayer
mplayer: error while loading shared libraries: libmad.so.0: cannot enable executable stack as shared object requires: Error 14
root@collie:~#


Any ideas? I've already removed this and all the dependencies, and then reinstalled it.
Go to the top of the page
 
+Quote Post
michael_barnes
post Aug 27 2006, 09:35 PM
Post #2





Group: Members
Posts: 3
Joined: 27-August 06
From: USA
Member No.: 11,005



I've had the same problem, actually. I'd be very interested in knowing how to fix it. mplayer worked with the gpe rom, but with the opie rom I get the same executable stack error. I'm using an SL-5600 with the latest stable release for the poodle (as of this post). thank you.
Go to the top of the page
 
+Quote Post
Da_Blitz
post Aug 30 2006, 05:27 AM
Post #3





Group: Members
Posts: 1,565
Joined: 7-April 05
From: Sydney, Australia
Member No.: 6,806



perhaps check to see if it was compiled with -fstack-protector i have had that cause stack problems before
Go to the top of the page
 
+Quote Post
michael_barnes
post Sep 1 2006, 10:21 PM
Post #4





Group: Members
Posts: 3
Joined: 27-August 06
From: USA
Member No.: 11,005



well, I didn't find anything in the makefile about that, and I was just about to try recompiling it from source when I decided to try the 2.6 kernel, and for whatever reason - that worked perfectly. so, STrRedWolf, I recommend you try the same thing, if you haven't already upgraded to the 2.6 kernel. I love mplayer. I run it on everything, and it was really sad when I couldn't get it working on my zaurus, but everything works nearly flawlessly. for some reason, I can only get sound when using headphones, but I honestly don't care. the internel speaker is a bit too quite for me anyway.
Go to the top of the page
 
+Quote Post
STrRedWolf
post Oct 29 2006, 02:18 PM
Post #5





Group: Members
Posts: 36
Joined: 31-December 03
Member No.: 1,319



QUOTE(michael_barnes @ Sep 1 2006, 10:21 PM)
well, I didn't find anything in the makefile about that, and I was just about to try recompiling it from source when I decided to try the 2.6 kernel, and for whatever reason - that worked perfectly. so, STrRedWolf, I recommend you try the same thing, if you haven't already upgraded to the 2.6 kernel. I love mplayer. I run it on everything, and it was really sad when I couldn't get it working on my zaurus, but everything works nearly flawlessly. for some reason, I can only get sound when using headphones, but I honestly don't care. the internel speaker is a bit too quite for me anyway.
*


Negative on 2.6 with the collie models. No sound basically kills mplayer right off, and no SD card kills me going 2.6 anyway. Ether mplayer is unhardened or I upgrade to the Cxx00 models.

Checked with the Hentges 3.5.4.1 collie ROM, with CardFS. Mplayer is still toast, same error.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th April 2014 - 09:43 PM