OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Usb Broken Sl5500 With Oz 3.5.2, Any ideas
post Jan 14 2005, 02:25 PM
Post #1

Group: Members
Posts: 17
Joined: 14-January 05
Member No.: 6,230

I am using a SL5500 with OZ 3.5.2 but I can't get my USB networking to work with Mandrake 10.1.

Using dmesg I see this error.. ??

usbdcore: usbdcore 0.1 035 2002-06-12 20:00 (dbg="")
net_fd 0.1 035 2002-06-12 20:00 (dbg="",alwaysup=0,OUT=64,IN=64)
vendorID: 4dd productID: 8004
sa1100_bi 0.2 035 2002-06-12 20:00 (dbg="")
bi_modinit: call udc_startup_events
bi_device_event: call udc_enable
bi_device_event: call udc_all_interrupts
usbdm: usbd_monitor 0.3 035 2002-06-12 20:00
monitor_request_irq: 23 44
monitor_request_irq: failed: -16
usbdm: request irq failed
monitor_connected: 1
monitor_hotplug: agent: usbd interface: monitor action: load
monitor_modinit: finished

Is the monitor_request_irq: failed: -16 indicating a problem ?

The enumeration phase fails. eg. cat /proc/usb-condition
Enumeration Fail

On the Mandrake side I get
usb 1-2: USB disconnect, address 18
usb 1-2: new full speed USB device using address 19

Therefore the cable is working but the product Id does not appear at the Mandrake end.

On previous ROMs, USB worked.

I have a wireless connection working on wlan0 so a non-working USB is not a problem. Also I have the FS running on my SD card so I can put the card in my Linux box and make changes easily to scripts etc.

Any ideas ? Is it possible to enable debug on any of the usb modules ?? I tried to unload and reload the usb modules but no change.

Go to the top of the page
+Quote Post
post Jan 15 2005, 10:38 AM
Post #2

Group: Members
Posts: 17
Joined: 14-January 05
Member No.: 6,230

I rebooted my Linux PC into Mandrake 9.1 and the Zaurus now connects via USB and I can use shh OK.

So the problem appears to be related with Mandrake 10.1 settings for USB.

Is anyone using Mandrake 10.1 ? How did you configure the USB settings ? Thanks.
Go to the top of the page
+Quote Post
post Jan 15 2005, 12:50 PM
Post #3

Group: Members
Posts: 95
Joined: 7-December 03
From: Berne, Switzerland
Member No.: 1,048

Actually pretty simple.

- modprobe usbnet (or insert it into /etc/modprobe.preload)
- copy the following scrip into the file /etc/hotplug/usb/usbnet t:






/sbin/ifconfig $zIface $zIfaceIP netmask up

/sbin/route add -host $zIP $zIface

iptables -t nat -F

iptables -t nat -A POSTROUTING -j SNAT -o eth0 --to $zHOST

echo 1 > /proc/sys/net/ipv4/ip_forward


- make sure iptables is installed
- plug Z into cradle that is attached to computer
- enter the address into /etc/hosts
- run aforementioned script
- ping zaurus
Go to the top of the page
+Quote Post
post Jan 15 2005, 02:47 PM
Post #4

Group: Members
Posts: 17
Joined: 14-January 05
Member No.: 6,230

Thanks for your reply. I think your solution is simpler !!

I got it working. The problem was that usbnet was not being loaded by hotplug. There was a line in usb.agent which was setting $MODPRODE to : Commented out the line out and now usbnet is loaded via hotplug.functions. $MODPRODE is defined in hotplug.functions but was being oerrirden by usb.agent.

I created a file /etc/hotplug/usb/Zaurus.usermap which contains the usbnet to product code mapping. Perhaps I am defining this is the wrong file ?
# Zaurus
usbnet 0x0003 0x04dd 0x8004 0x0000 0x0000 0x02 0x00 0x00 0xff 0x01 0x00 0x00000000

I also have ifcfg_usb0 in /etc/sysconfig/network-scripts which contains the IP address info. eg.


and in /etc/modules.conf
alias usb0 usbnet

So there appears to be multiple ways of setting up usb0.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 13th December 2017 - 04:54 AM