OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Firefox 0.9
CoreyC
post Jun 22 2004, 05:23 PM
Post #1





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



Newest version of firefox has been uploaded to the unstable feed.

Uninstall your old firefox before installing the new version. Don't worry about your bookmarks and stuff, they will get imported the first time you run the new version.

I used the gtk toolkit instead of gtk2, so there is no xft suppport in this package. Using the lighter gtk makes a difference while you are using the browser (easier scrolling, sub menus are faster), but it still takes just as long to fire the fox up.

Check out the new extension and theme managers. They allow you add pluggins and change themes easily. I've installed and used the google toolbar without any problems.

New in 0.9 (from the mozilla site):

# - Extension Manager
# - Theme Manager
# - Data Migration/Import
# - New Visual Theme
# - Better Bookmarks
# - Better Search

screenshot: firefox using the compact menu extension

Go to the top of the page
 
+Quote Post
caleb
post Jun 24 2004, 11:19 AM
Post #2





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



Thanks, works nicely for me except one problem (which is probably my fault)

I uninstalled 0.8 and installed 0.9 and now my nice normal looking fonts have disappeared, and have been replaced with some really ugly one, which I don't have the option to change (there is now only one choice in the list) ... Also, when running firefox from a console to check error messages i get lots of these:

Gdk-WARNING **: Missing charsets in FontSet creation

Gdk-WARNING **: ISO8859-1

Any ideas?
I have tried reinstalling the fonts package from the pdaxrom feed but that didn't do anything...
Go to the top of the page
 
+Quote Post
CoreyC
post Jun 24 2004, 05:38 PM
Post #3





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



Caleb,

Those nice looking fonts you had before were due to the xft/gtk2 support during the compile. Firefox will only compile with xft support if you use the gtk2 toolkit (unless there is a patch out there somewhere.. if there is and anybody can paste a link to it I will recompile).

I choose performance over looks. I found that using the gtk toolkit (instead of gtk2) made scrolling and loading pages much smoother. Do you think I should reconsider?

Thank you for the feedback,

Corey
Go to the top of the page
 
+Quote Post
caleb
post Jun 24 2004, 08:42 PM
Post #4





Group: Members
Posts: 9
Joined: 28-May 04
Member No.: 3,477



I would be happy just to have the font I see in your screenshot.. I have some barely readable, thick, almost cursive type of font. It is some font I've never seen before, very odd..

It's a really weird problem I guess =P

I like the performance though.
Go to the top of the page
 
+Quote Post
CoreyC
post Jun 25 2004, 03:32 AM
Post #5





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



Caleb,

Try increasing your text size (under the view menu).

The font I am using is the default, I've made no changes. Of course, it looks cleaner in that screenshot than it does on the zaurus.

If you are still not happy, type "about:config" in the firefox web address box and change some font settings.

Take a screenshot so I can see what's going on by typing this in the console...

xwd -display :0.0 -root -out screenshot.xwd

and email it to coreync *@* mchsi.com
Go to the top of the page
 
+Quote Post
tip
post Jun 25 2004, 05:59 PM
Post #6





Group: Members
Posts: 16
Joined: 6-April 04
Member No.: 2,707



I believe he is talking about the fonts below. I get the same thing.

Thanks for the great work on the ipk though.

Go to the top of the page
 
+Quote Post
CoreyC
post Jun 25 2004, 06:36 PM
Post #7





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



Wow.. that is ugly!

I just uninstalled the fonts package from the pdaxrom feed... fired firefox up and I see the same thing now. If you have the fonts installed to a SD card, they will not work. You must install them on your internal memory.

See this thread for a work around, if you must have these installed on /mnt/card
http://www.oesf.org/forums/inde...c=4549&hl=fonts

After reinstalling the fonts package the display is back to normal.

Here are my font settings:

Go to the top of the page
 
+Quote Post
tip
post Jun 25 2004, 08:51 PM
Post #8





Group: Members
Posts: 16
Joined: 6-April 04
Member No.: 2,707



CoreyC,

I didn't even have the font package installed. I installed it to / and restarted X and now the fonts look much better. It's amazing to have such a powerful browser on such a small device. It seems like the startup time for 0.9 is about half of the startup time for 0.8.

Thanks again for the build.
Go to the top of the page
 
+Quote Post
ScottYelich
post Jun 26 2004, 11:45 AM
Post #9





Group: Members
Posts: 992
Joined: 9-October 03
From: NYC
Member No.: 609



I don't care about load up time...well, to an extent :->

but how many seconds does ff.9 take to load up www.cnn.com?
is it 14 like the older ff? I lolve dillo, but they just have to add
support for tables and then it will be amazing.

Yes, I love the scrolling in dillo -- load up a large image like the overworld for ultima4 (u4), and keep it in dillo to scroll around so you can refer to it as
you're playing -- dillo is *fast*

Scott
Go to the top of the page
 
+Quote Post
CoreyC
post Jun 26 2004, 03:57 PM
Post #10





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



Scott: 7-9 seconds to load cnn.com I loaded it 3 times, got 9 the first time and 7-8 the second time.

I consider the page "loaded" once all of the images are displayed and the browser allows me the start scrolling.

Dillo: 3 seconds smile.gif
Konq: 30+ seconds. unreal. It almost has the page loaded, and then decided to reload it again.
Go to the top of the page
 
+Quote Post
Shishi
post Jul 3 2004, 08:19 AM
Post #11





Group: Members
Posts: 4
Joined: 3-July 04
Member No.: 3,897



Hi All,

Thanks for new build, it's visibly faster than previous one. wink.gif
I appreciate any ideas why the build based on gtk no longer displays japanese text.
Maybe I have to set the locale explicitly before starting it...

Cheers,
Shishi
Go to the top of the page
 
+Quote Post
CoreyC
post Jul 3 2004, 09:21 AM
Post #12





Group: Members
Posts: 288
Joined: 13-February 04
Member No.: 1,851



copy/pasted from another site:

Go to "View" > "Character coding" and choose "Customize" : click on each language you want (left) and click on "Add". Click "Ok" once done. Try surfing on asian pages again.

If Firefox isn't showing the proper characters (on a Japanese page), then go back to "View" > "Character coding" and choose "Auto Detect" : click on "Japanese" (if that's the one you use most).
Go to the top of the page
 
+Quote Post
Shishi
post Jul 5 2004, 07:40 AM
Post #13





Group: Members
Posts: 4
Joined: 3-July 04
Member No.: 3,897



Thanks for the answer CoreyC,

Seems like the problem was somewhat deeper.
Originally, I had to install japanese fonts eplicitly and I just put monafont.ttf file to /usr/X11R6/lib/X11/font/... and after restarting the X, everything just worked.

Seems like xft is a way smarter than old-style font support, so in absense of it I had to roll back to use old .pcf fonts, again http://monafont.sourceforge.net was a great help - after geting the files right and extending font path, everything worked.

But I still wonder if it's possible to use True Type fonts without xft and any additional packages...

Cheers
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 08:31 AM