OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Python 2.4 In Oz 3.5.3
jh
post Jun 2 2005, 01:48 PM
Post #1





Group: Members
Posts: 115
Joined: 20-November 03
Member No.: 968



Hi,

I'm writing an app for my C1k + OZ 3.5.3 with python and have stumbled across a few things that needed tweaks, and one thing I can't get past:

I'm using urllib which imports cookielib which imports logging which imports calendar which imports datetime (whew!) all of which are missing (other than urllib) from the python-2.4.1-manifest.inc for the netclient package.

Adding them to the package has been easy (patch is trivial but I can generate it if needed) except for datetime which is a compiled library. I noticed that none of the .so files that should be in lib-dynload are actually there. Checking the log reveals:

CODE
ccache arm-linux-gcc -march=armv5te -mtune=xscale -shared -L/data/openembedded/akita/tmp/staging/arm-linux/lib -Wl,-rpath-link,/data/openembedded\
/akita/tmp/staging/arm-linux/lib -Wl,-O1 -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I. -I/data/openembedded/akita/tmp/work/python-2.4.1-ml1/Pytho\
n-2.4/Include build/temp.linux-i686-2.4/data/openembedded/akita/tmp/work/python-2.4.1-ml1/Python-2.4/Modules/datetimemodule.o build/temp.linux-i6\
86-2.4/data/openembedded/akita/tmp/work/python-2.4.1-ml1/Python-2.4/Modules/timemodule.o -L/data/openembedded/akita/tmp/staging/arm-linux/lib -lm\
-o build/lib.linux-i686-2.4/datetime.so                                                                                                          
*** WARNING: renaming "datetime" since importing it failed: build/lib.linux-i686-2.4/datetime.so: ELF file OS ABI invalid                        


This is an up-to-date (r237) bitbake, latest pull from bk, using openzaurus-3.5.3 as the distro in my local.conf.

Thanks!

jason
Go to the top of the page
 
+Quote Post
Mickeyl
post Jun 3 2005, 02:18 AM
Post #2





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



That's just a packaging problem, not a build problem. I've checked in a fix for that:

http://openembedded.bkbits.net:8080/openem...l|ChangeSet@-1h

Could you give that a try?
Go to the top of the page
 
+Quote Post
jh
post Jun 3 2005, 07:20 AM
Post #3





Group: Members
Posts: 115
Joined: 20-November 03
Member No.: 968



QUOTE(Mickeyl @ Jun 3 2005, 02:18 AM)
That's just a packaging problem, not a build problem. I've checked in a fix for that:

http://openembedded.bkbits.net:8080/openem...l|ChangeSet@-1h

Could you give that a try?
*


That gets datetime and all the rest in there. One more tweak for cookielib:
CODE
${libdir}/python2.4/_LWPCookieJar.* ${libdir}/python2.4/_MozillaCookieJar.*


After that it looks great. Thanks!!

jason
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th August 2014 - 12:30 PM