OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Proxy Problems With Nokia 770, Anyone understand tcpdump output?
lardman
post Nov 20 2005, 07:56 AM
Post #1





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I've been using my shiny new Nokia 770 on my university's wifi network.

We have to use a proxy server for http, the config file for which is here: http://www.bath.ac.uk/proxy/proxy.config

My problem is this:

Initially I set the proxy manually to http://wwwcache.bath.ac.uk:3128/; with this in place, the web browser worked fine, but no internet-radio nor news reader.

I then decided to use the proxy.config file (linked above) after which the internet-radio also started to work; however there's still no sign of the news-reader doing anything.

Now the Nokia apps are a bit wierd - they show generic (useless) error messages and no output to stderr, so I'm trying to find the cause without any help from the apps themselves.

I've logged with tcpdump, the results of which are here: http://people.bath.ac.uk/enpsgp/Zaurus/temp/

The one which is interesting is news-reader3_auto-proxy.log which is using the proxy.config file, and still not working. For comparison with a working session (web-browser) see web-browser2_manual-proxy.log (manual proxy though).

Can anyone spot a problem in the output from the news-reader?

This is driving me mad! wink.gif

Thanks,


Si
Go to the top of the page
 
+Quote Post
lardman
post Nov 24 2005, 09:23 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I've narrowed it down.

When the web browser tries to use the proxy it works: (ethereal format log file here):
http://people.bath.ac.uk/enpsgp/Zaurus/tem...ual_all.web.log

But when the news reader tries, the DNS server isn't interested:
http://people.bath.ac.uk/enpsgp/Zaurus/tem....manual_all.log

I'm wondering if there's something about the news reader's packet which my DNS server doesn't like. If anyone has any ideas I'd be grateful to hear them,

Thanks,


Si
Go to the top of the page
 
+Quote Post
tombraider
post Nov 27 2005, 06:51 AM
Post #3





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



How do you like your new Nokia 770?
I'm debating between getting it or the Zaurus C1000.

Would love to hear your take on it.

QUOTE(lardman @ Nov 24 2005, 05:23 PM)
I've narrowed it down.

When the web browser tries to use the proxy it works: (ethereal format log file here):
http://people.bath.ac.uk/enpsgp/Zaurus/tem...ual_all.web.log

But when the news reader tries, the DNS server isn't interested:
http://people.bath.ac.uk/enpsgp/Zaurus/tem....manual_all.log

I'm wondering if there's something about the news reader's packet which my DNS server doesn't like. If anyone has any ideas I'd be grateful to hear them,

Thanks,


Si
*
Go to the top of the page
 
+Quote Post
lardman
post Nov 28 2005, 04:13 AM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Might be best to move this back to here: http://www.oesf.org/forums/index.php?showtopic=12823

Have a read, then ask away.


Si
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 07:11 PM