OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Angstrom 2007.12-r14 - No Wpa Connection, WPA with NetGear MA401RA
Mainframe-junkie
post Apr 6 2008, 05:40 AM
Post #1





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello friends,

i have installed the new stable image Angstrom-X11-2007.12-R14 from 1.April.
The first test showed an wrong script under /etc/network/if-pre-up.d/wpasupplicant (from Ubuntu, it fails with sed of busybox not knowing --quite) get called.
So i just linked wpa-supplicant to wpasupplicant.
When i try to connect to my WPA-WLAN with an NetGear MA-401RA (Firmware PRI v1.1.1, STA v1.8.2), it will get no connection.
The cards is ok, under simpad i can connect to an open WLAN.
My interfaces looks like
CODE
root@simpad:~$ cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback


# Wireless interfaces
#
#
iface wlan0 inet static
     address 192.168.2.7
     netmask 255.255.255.0
     network 192.168.2.0
     broadcast 192.168.2.255
     wpa-conf /etc/wpa_supplicant.conf
     wpa-driver hostap
#
#


and the content of wpa_supplicant.conf is

CODE
root@simpad:~$ cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
network={
    ssid="BlueZone"
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP
    psk="01234567890123"
    priority=1
}
network={
    ssid="carioca"
    key_mgmt=NONE
    priority=2
}


I can see my WLAN with iwlist scan :

CODE
wlan0     Scan completed :
          Cell 01 - Address: 00:04:0E:D4:F4:B1
                    ESSID:"BlueZone"
                    Mode:Master
                    Frequency:2.422 GHz (Channel 3)
                    Signal level=-68 dBm  Noise level=-89 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK


In /var/log/messages i only found :

CODE
....
Apr  6 13:54:14 simpad user.debug kernel: prism2: wlan0: operating mode changed 3 -> 2
Apr  6 13:54:14 simpad user.info kernel: NET: Registered protocol family 17
Apr  6 13:54:14 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 13:54:14 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 13:54:15 simpad user.notice root: Checking for WLAN association...
Apr  6 13:54:15 simpad user.notice root: Found association!
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 13:54:15 simpad user.debug kernel: wlan0: Trying to join BSSID 00:04:0e:d4:f4:b1
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus=6 (Association failed)
....


My router is an Fritz!Box and another embedded linux device, my iLiad (e-book from iRex) is working fine with WPA-WLAN.
I'm shure my psk is ok, because it contains only digits [0-9] like above ... wink.gif

Attached is an log of the session with output of various commands (iwconfig, ifconfig, iwscan, lsmod etc.) and more content of /var/log/messages

Did anyone run succsessfully WPA with Angstrom 2007.12 on simpad ?
Or any guesses what else to try/check/do ...???

Best regards and thanks to all which work on Angstrom for Simpad

Oliver

Attached File  Simpad_04.06.135001.txt ( 31.8K ) Number of downloads: 1

Edit : changed Topic description
Go to the top of the page
 
+Quote Post
mister_data
post Apr 6 2008, 06:48 AM
Post #2





Group: Members
Posts: 21
Joined: 1-March 06
From: Leipzig, Germany
Member No.: 9,257



QUOTE(Mainframe-junkie @ Apr 6 2008, 02:40 PM) *
Hello friends,

i have installed the new stable image Angstrom-X11-2007.12-R14 from 1.April.
The first test showed an wrong script under /etc/network/if-pre-up.d/wpasupplicant (from Ubuntu, it fails with sed of busybox not knowing --quite) get called.
So i just linked wpa-supplicant to wpasupplicant.
When i try to connect to my WPA-WLAN with an NetGear MA-401RA (Firmware PRI v1.1.1, STA v1.8.2), it will get no connection.
The cards is ok, under simpad i can connect to an open WLAN.
My interfaces looks like
CODE
root@simpad:~$ cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback


# Wireless interfaces
#
#
iface wlan0 inet static
     address 192.168.2.7
     netmask 255.255.255.0
     network 192.168.2.0
     broadcast 192.168.2.255
     wpa-conf /etc/wpa_supplicant.conf
     wpa-driver hostap
#
#


and the content of wpa_supplicant.conf is

CODE
root@simpad:~$ cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
network={
     ssid="BlueZone"
     key_mgmt=WPA-PSK
     pairwise=TKIP
     group=TKIP
     psk="01234567890123"
     priority=1
}
network={
    ssid="carioca"
    key_mgmt=NONE
    priority=2
}


I can see my WLAN with iwlist scan :

CODE
wlan0     Scan completed :
          Cell 01 - Address: 00:04:0E:D4:F4:B1
                    ESSID:"BlueZone"
                    Mode:Master
                    Frequency:2.422 GHz (Channel 3)
                    Signal level=-68 dBm  Noise level=-89 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK


In /var/log/messages i only found :

CODE
....
Apr  6 13:54:14 simpad user.debug kernel: prism2: wlan0: operating mode changed 3 -> 2
Apr  6 13:54:14 simpad user.info kernel: NET: Registered protocol family 17
Apr  6 13:54:14 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 13:54:14 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 13:54:15 simpad user.notice root: Checking for WLAN association...
Apr  6 13:54:15 simpad user.notice root: Found association!
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 13:54:15 simpad user.debug kernel: wlan0: Trying to join BSSID 00:04:0e:d4:f4:b1
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 13:54:15 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 13:54:15 simpad user.debug kernel: wifi0: LinkStatus=6 (Association failed)
....


My router is an Fritz!Box and another embedded linux device, my iLiad (e-book from iRex) is working fine with WPA-WLAN.
I'm shure my psk is ok, because it contains only digits [0-9] like above ... wink.gif

Attached is an log of the session with output of various commands (iwconfig, ifconfig, iwscan, lsmod etc.) and more content of /var/log/messages

Did anyone run succsessfully WPA with Angstrom 2007.12 on simpad ?
Or any guesses what else to try/check/do ...???

Best regards and thanks to all which work on Angstrom for Simpad

Oliver

Attached File  Simpad_04.06.135001.txt ( 31.8K ) Number of downloads: 1

Edit : changed Topic description


Hello Mainframe-junkie,

please try the following changes for your wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1

network={
ssid="BlueZone"
proto=WPA
pairwise=TKIP
group=TKIP
psk="01234567890123"
priority=1
}

Regards,
mrdata
Go to the top of the page
 
+Quote Post
Mainframe-junkie
post Apr 6 2008, 07:09 AM
Post #3





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello mrdata,

changed the wpa_supplicant.conf but the result remains the same .... sad.gif

CODE
Apr  6 17:03:42 simpad user.notice kernel: pccard: PCMCIA card inserted into slot 0
Apr  6 17:03:42 simpad user.notice kernel: pcmcia: registering new device pcmcia0.0
Apr  6 17:03:42 simpad user.debug kernel: DEV: registering device: ID = '0.0'
Apr  6 17:03:42 simpad user.debug kernel: PM: Adding info for pcmcia:0.0
Apr  6 17:03:42 simpad user.debug kernel: bus pcmcia: add device 0.0
Apr  6 17:03:42 simpad user.debug kernel: pcmcia: Matched Device 0.0 with Driver hostap_cs
Apr  6 17:03:42 simpad user.debug kernel: pcmcia: Probing driver hostap_cs with device 0.0
Apr  6 17:03:42 simpad user.debug kernel: hostap_cs: setting Vcc=33 (constant)
Apr  6 17:03:42 simpad user.debug kernel: Checking CFTABLE_ENTRY 0x01 (default 0x01)
Apr  6 17:03:42 simpad user.debug kernel: IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Apr  6 17:03:42 simpad user.debug kernel: io->flags = 0x0046, io.base=0x0000, len=64
Apr  6 17:03:42 simpad user.debug kernel: DEV: registering device: ID = 'wifi0'
Apr  6 17:03:42 simpad user.debug kernel: PM: Adding info for No Bus:wifi0
Apr  6 17:03:42 simpad user.info kernel: hostap_cs: Registered netdevice wifi0
Apr  6 17:03:42 simpad user.warn kernel: hostap_hw.c: INTERRUPT BEFORE DEVICE INIT!
Apr  6 17:03:42 simpad user.info kernel:
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 200 ms
Apr  6 17:03:43 simpad user.info kernel: wifi0: NIC: id=0x800c v1.0.0
Apr  6 17:03:43 simpad user.info kernel: wifi0: PRI: id=0x15 v1.1.1
Apr  6 17:03:43 simpad user.info kernel: wifi0: STA: id=0x1f v1.8.2
Apr  6 17:03:43 simpad user.debug kernel: DEV: registering device: ID = 'wlan0'
Apr  6 17:03:43 simpad user.debug kernel: PM: Adding info for No Bus:wlan0
Apr  6 17:03:43 simpad user.debug kernel: wifi0: registered netdevice wlan0
Apr  6 17:03:43 simpad user.debug kernel: bound device '0.0' to driver 'hostap_cs'
Apr  6 17:03:43 simpad user.debug kernel: pcmcia: Bound Device 0.0 to Driver hostap_cs
Apr  6 17:03:43 simpad user.debug kernel: prism2_download: dl_cmd=5 start_addr=0x003f0c01 num_areas=3
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 90 ms
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 30 ms
Apr  6 17:03:43 simpad user.info kernel: wifi0: NIC: id=0x800c v1.0.0
Apr  6 17:03:43 simpad user.info kernel: wifi0: PRI: id=0x15 v1.1.1
Apr  6 17:03:43 simpad user.info kernel: wifi0: STA: id=0x1f v1.7.4
Apr  6 17:03:46 simpad user.debug kernel: prism2: wlan0: operating mode changed 3 -> 2
Apr  6 17:03:46 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:46 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.notice root: Checking for WLAN association...
Apr  6 17:03:47 simpad user.notice root: Found association!
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wlan0: Trying to join BSSID 00:04:0e:d4:f4:b1
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=6 (Association failed)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:58 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:58 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:4


Best regards

Oliver
Go to the top of the page
 
+Quote Post
mister_data
post Apr 6 2008, 07:37 AM
Post #4





Group: Members
Posts: 21
Joined: 1-March 06
From: Leipzig, Germany
Member No.: 9,257



QUOTE(Mainframe-junkie @ Apr 6 2008, 04:09 PM) *
Hello mrdata,

changed the wpa_supplicant.conf but the result remains the same .... sad.gif

CODE
Apr  6 17:03:42 simpad user.notice kernel: pccard: PCMCIA card inserted into slot 0
Apr  6 17:03:42 simpad user.notice kernel: pcmcia: registering new device pcmcia0.0
Apr  6 17:03:42 simpad user.debug kernel: DEV: registering device: ID = '0.0'
Apr  6 17:03:42 simpad user.debug kernel: PM: Adding info for pcmcia:0.0
Apr  6 17:03:42 simpad user.debug kernel: bus pcmcia: add device 0.0
Apr  6 17:03:42 simpad user.debug kernel: pcmcia: Matched Device 0.0 with Driver hostap_cs
Apr  6 17:03:42 simpad user.debug kernel: pcmcia: Probing driver hostap_cs with device 0.0
Apr  6 17:03:42 simpad user.debug kernel: hostap_cs: setting Vcc=33 (constant)
Apr  6 17:03:42 simpad user.debug kernel: Checking CFTABLE_ENTRY 0x01 (default 0x01)
Apr  6 17:03:42 simpad user.debug kernel: IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
Apr  6 17:03:42 simpad user.debug kernel: io->flags = 0x0046, io.base=0x0000, len=64
Apr  6 17:03:42 simpad user.debug kernel: DEV: registering device: ID = 'wifi0'
Apr  6 17:03:42 simpad user.debug kernel: PM: Adding info for No Bus:wifi0
Apr  6 17:03:42 simpad user.info kernel: hostap_cs: Registered netdevice wifi0
Apr  6 17:03:42 simpad user.warn kernel: hostap_hw.c: INTERRUPT BEFORE DEVICE INIT!
Apr  6 17:03:42 simpad user.info kernel:
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 200 ms
Apr  6 17:03:43 simpad user.info kernel: wifi0: NIC: id=0x800c v1.0.0
Apr  6 17:03:43 simpad user.info kernel: wifi0: PRI: id=0x15 v1.1.1
Apr  6 17:03:43 simpad user.info kernel: wifi0: STA: id=0x1f v1.8.2
Apr  6 17:03:43 simpad user.debug kernel: DEV: registering device: ID = 'wlan0'
Apr  6 17:03:43 simpad user.debug kernel: PM: Adding info for No Bus:wlan0
Apr  6 17:03:43 simpad user.debug kernel: wifi0: registered netdevice wlan0
Apr  6 17:03:43 simpad user.debug kernel: bound device '0.0' to driver 'hostap_cs'
Apr  6 17:03:43 simpad user.debug kernel: pcmcia: Bound Device 0.0 to Driver hostap_cs
Apr  6 17:03:43 simpad user.debug kernel: prism2_download: dl_cmd=5 start_addr=0x003f0c01 num_areas=3
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 90 ms
Apr  6 17:03:43 simpad user.debug kernel: prism2_hw_init: initialized in 30 ms
Apr  6 17:03:43 simpad user.info kernel: wifi0: NIC: id=0x800c v1.0.0
Apr  6 17:03:43 simpad user.info kernel: wifi0: PRI: id=0x15 v1.1.1
Apr  6 17:03:43 simpad user.info kernel: wifi0: STA: id=0x1f v1.7.4
Apr  6 17:03:46 simpad user.debug kernel: prism2: wlan0: operating mode changed 3 -> 2
Apr  6 17:03:46 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:46 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.notice root: Checking for WLAN association...
Apr  6 17:03:47 simpad user.notice root: Found association!
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 17:03:47 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:47 simpad user.debug kernel: wlan0: Trying to join BSSID 00:04:0e:d4:f4:b1
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus=6 (Association failed)
Apr  6 17:03:47 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 17:03:58 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 17:03:58 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:4


Best regards

Oliver


Hi,

the only thing i can see is, that your STA: id=0x1f v1.8.2 is
overwritten with STA: id=0x1f v1.7.4.

Please copy /lib/firmware/rf010704.hex to other place and then delete this file in /lib/firmware/ .

Then this firmware-upload should go away.

Regards,
mrdata
Go to the top of the page
 
+Quote Post
Mainframe-junkie
post Apr 6 2008, 09:21 AM
Post #5





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello mrdata,

moved the file away, but still no connection :

CODE
Apr  6 19:14:59 simpad user.debug kernel: prism2_hw_init: initialized in 210 ms
Apr  6 19:14:59 simpad user.info kernel: wifi0: NIC: id=0x800c v1.0.0
Apr  6 19:14:59 simpad user.info kernel: wifi0: PRI: id=0x15 v1.1.1
Apr  6 19:14:59 simpad user.info kernel: wifi0: STA: id=0x1f v1.8.2
Apr  6 19:14:59 simpad user.debug kernel: DEV: registering device: ID = 'wlan0'
Apr  6 19:14:59 simpad user.debug kernel: PM: Adding info for No Bus:wlan0
Apr  6 19:14:59 simpad user.debug kernel: wifi0: registered netdevice wlan0
Apr  6 19:14:59 simpad user.debug kernel: bound device '0.0' to driver 'hostap_cs'
Apr  6 19:14:59 simpad user.debug kernel: pcmcia: Bound Device 0.0 to Driver hostap_cs
Apr  6 19:15:00 simpad user.notice root: Checking for WLAN association...
Apr  6 19:15:00 simpad user.notice root: Found association!
Apr  6 19:15:00 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 19:15:00 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 19:15:00 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 19:15:02 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:10 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:18 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:26 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:34 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:42 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:50 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:15:58 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:06 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:14 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:22 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:30 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:38 simpad user.debug kernel: Scan result translation succeeded (length=0)
Apr  6 19:16:39 simpad user.debug kernel: wifi0: Deauthenticate all stations
Apr  6 19:16:39 simpad daemon.info avahi-daemon[2702]: Interface wlan0.IPv4 no longer relevant for mDNS.
Apr  6 19:16:39 simpad daemon.info avahi-daemon[2702]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 19:16:39 simpad daemon.info avahi-daemon[2702]: Withdrawing address record for 192.168.2.7 on wlan0.
Apr  6 19:16:39 simpad user.debug kernel: wlan0: Preferred AP (SIOCSIWAP) is used only in Managed mode when host_roaming is enabled
Apr  6 19:16:55 simpad user.debug kernel: prism2: wlan0: operating mode changed 3 -> 2
Apr  6 19:16:55 simpad daemon.info avahi-daemon[2702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.7.
Apr  6 19:16:55 simpad daemon.info avahi-daemon[2702]: New relevant interface wlan0.IPv4 for mDNS.
Apr  6 19:16:55 simpad daemon.info avahi-daemon[2702]: Registering new address record for 192.168.2.7 on wlan0.IPv4.
Apr  6 19:16:55 simpad user.debug kernel: wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
Apr  6 19:16:55 simpad user.debug kernel:    retry_count=0 tx_rate=0 fc=0x0108 (Data::0 ToDS)
Apr  6 19:16:55 simpad user.debug kernel:    A1=00:09:5b:4c:32:a8 A2=00:09:5b:4c:32:a8 A3=01:00:5e:00:00:16 A4=00:00:00:00:00:00
Apr  6 19:16:55 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 19:16:55 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 19:16:55 simpad user.notice root: Checking for WLAN association...
Apr  6 19:16:55 simpad user.notice root: Found association!
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus=2 (Disconnected)
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus: BSSID=44:44:44:44:44:44
Apr  6 19:16:56 simpad user.debug kernel: wlan0: Trying to join BSSID 00:04:0e:d4:f4:b1
Apr  6 19:16:56 simpad user.debug kernel: wifi0: LinkStatus=6 (Association failed)


Best regards

Oliver
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 6 2008, 10:04 AM
Post #6





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



There's been some talk on the mailing list about WPA not working. It appears to be an issue with how the kernel is configured or something.

I don't know if this is said issue, but I thought I'd pass the info along.
Go to the top of the page
 
+Quote Post
Mainframe-junkie
post Apr 6 2008, 11:46 AM
Post #7





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Thanks Capn_Fish,

i found the thread about "wpa support broken ?".
It seems someone with bitbake-knowhow has to review the receipes and fix something.
Depency between ieee80211_crypt_tkip and arc4 module seems broken as Oliver Fels expained the problem.

I found the following line:

<7>ieee80211_crypt: registered algorithm 'NULL'

We have to wait for an fix of that and an new kernel .... rolleyes.gif

Best regards

Oliver
Go to the top of the page
 
+Quote Post
mr_nice
post Apr 6 2008, 01:28 PM
Post #8





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



QUOTE(Mainframe-junkie @ Apr 6 2008, 11:46 AM) *
<7>ieee80211_crypt: registered algorithm 'NULL'

We have to wait for an fix of that and an new kernel .... rolleyes.gif

Best regards

Oliver


Hi,
on my SIMpad wpa works perfect with siemens i-gate card and wpa_supplicant on Angstrom-r14. arc4 is at least not broken on my pad:

CODE
root@simpad:~$ lsmod                                
Module                  Size  Used by
michael_mic             2560  0
arc4                    1920  0
ecb                     3648  0
ieee80211_crypt_tkip    11552  0
hostap_cs              62616  1
hostap                113028  1 hostap_cs
ieee80211_crypt         6464  2 ieee80211_crypt_tkip,hostap
af_packet              24420  0
rfcomm                 43860  0
ircomm_tty             41224  0
ircomm                 24420  1 ircomm_tty
irda                  204172  2 ircomm_tty,ircomm
crc_ccitt               2016  1 irda
hidp                   20672  0
hid                    34852  1 hidp
l2cap                  26116  10 rfcomm,hidp
bluetooth              63812  5 rfcomm,hidp,l2cap
pcnet_cs               38864  0
8390                   10560  1 pcnet_cs


root@simpad:~$ pccardctl info  
PRODID_1="INTERSIL"
PRODID_2="I-GATE 11M PC Card / PC Card plus"
PRODID_3="Version 01.02"
PRODID_4=""
MANFID=0156,0002
FUNCID=6

//to avoide configure things I did it manualy this time.
root@simpad:~$ wpa_supplicant -c /etc/wpa_supplicant.conf  -i wlan0 &
Trying to associate with macadress (SSID='blabla' freq=2462 MHz)
Associated with macadress
WPA: Key negotiation completed with macadress [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to macadress completed (auth) [id=0 i]

root@simpad:~$ udhcpc  -i wlan0
udhcpc (v1.2.1) started
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with return code 1: Success
Sending discover...
Sending select for 192.168.1.102...
Lease of 192.168.1.102 obtained, lease time 86400
run-parts: /etc/udhcpc.d/00avahi-autoipd exited with return code 1: Success
adding dns 83.169.184.161
adding dns 83.169.184.225
root@simpad:~$ ping opensimpad.org
PING opensimpad.org (85.13.129.145): 56 data bytes
64 bytes from 85.13.129.145: icmp_seq=0 ttl=45 time=53.4 ms
64 bytes from 85.13.129.145: icmp_seq=1 ttl=45 time=54.2 ms

--- opensimpad.org ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 53.4/53.8/54.2 ms
root@simpad:~$


My wpa_supplicant.conf is like the one from mr data.
Are you using aes only on your router?
Go to the top of the page
 
+Quote Post
Mainframe-junkie
post Apr 6 2008, 01:56 PM
Post #9





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello mr_nice,

after insertion of my WLAN-Card an lsmod looks like this

CODE
root@simpad:~$ lsmod
Module                  Size  Used by
af_packet              24420  2
hostap_cs              62616  1
hostap                113028  1 hostap_cs
ieee80211_crypt         6464  1 hostap
rfcomm                 43860  0
ircomm_tty             41224  0
ircomm                 24420  1 ircomm_tty
irda                  204172  2 ircomm_tty,ircomm
crc_ccitt               2016  1 irda
hidp                   20672  0
hid                    34852  1 hidp
l2cap                  26116  10 rfcomm,hidp
bluetooth              63812  5 rfcomm,hidp,l2cap
root@simpad:~$


All the cypto modules exept of ieee80211_crypt missing ...
No better results even after loading the missing stuff via modprobe Attached File  Simpad_04.07.000242.txt ( 19.84K ) Number of downloads: 2

Best regards

Oliver
Go to the top of the page
 
+Quote Post
ofels
post Apr 6 2008, 11:14 PM
Post #10





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



QUOTE(Mainframe-junkie @ Apr 6 2008, 11:56 PM) *
All the cypto modules exept of v missing ...
No better results even after loading the missing stuff via modprobe Attached File  Simpad_04.07.000242.txt ( 19.84K ) Number of downloads: 2


Quoting from the attachment:

QUOTE
root@simpad:~$ lsmod
Module Size Used by
hostap_cs 62616 3
hostap 113028 1 hostap_cs
ieee80211_crypt_tkip 11552 0
ieee80211_crypt 6464 2 hostap,ieee80211_crypt_tkip
michael_mic 2560 0
arc4 1920 0


The correct modules are loaded however there is no dependency between ieee80211_crypt_tkip and the arc module (which iirc should be).
Which is highly suspect to the aforementioned missing arc4 kernel module dependency.
Try to use 2.6.23 instead to make it work.

Oliver
Go to the top of the page
 
+Quote Post
mr_nice
post Apr 8 2008, 06:41 AM
Post #11





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



Can you try to use the card on another device like a laptop with wpa_supplicant and a recent kernel?
best regards
mr nice
Go to the top of the page
 
+Quote Post
Mainframe-junkie
post Apr 9 2008, 07:45 AM
Post #12





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello mr_nice,

i took an Knoppix 5.3 (DVD from c't 06/2008) and tested it with an Dell Latitude D630 and an FSC Lifebook E7100.
Both don't recognized the MA-401 automatically ....
After modprobing hostap manually, both showed the same crypto-modules missing like my simpad sad.gif
I have to find an friend with an better supported laptop

best regards

Oliver
Go to the top of the page
 
+Quote Post
hafu
post May 26 2008, 08:38 AM
Post #13





Group: Members
Posts: 10
Joined: 26-May 08
Member No.: 21,834



I also have a Netgear MA401 and I can confirm that it does WPA with even a 2.4 kernel, namely the familiar 0.8.4 + this.
My next step is to get it working with Angstrom, too. Good to see that I'm not alone.

-hafu
Go to the top of the page
 
+Quote Post
mr_nice
post May 28 2008, 02:05 PM
Post #14





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



QUOTE(hafu @ May 26 2008, 08:38 AM) *
I also have a Netgear MA401 and I can confirm that it does WPA with even a 2.4 kernel, namely the familiar 0.8.4 + this.
My next step is to get it working with Angstrom, too. Good to see that I'm not alone.

-hafu


you need to figure out if you will be able to use this card on a laptop or something else with kernel > 2.6 .22. If it will work there please post it here else it is not only an angstrom based problem and a general hostap forum/list would be the better solution to renew support for your card.

best regards
mr nice
Go to the top of the page
 
+Quote Post
hafu
post Jun 4 2008, 04:59 AM
Post #15





Group: Members
Posts: 10
Joined: 26-May 08
Member No.: 21,834



I can confirm that Netgear MA401 is working with WPA in release r14 as well as r15.
My only problem was my outdated prism firmware. After updating it with the prism2_srec command it works very well.
-hafu

for reference:
CODE
root@simpad:~$ lsmod
Module Size Used by
michael_mic 2560 6
arc4 1920 6
ecb 3648 6
ieee80211_crypt_tkip 11552 0
af_packet 24420 4
hostap_cs 62616 3
hostap 113028 1 hostap_cs
ieee80211_crypt 6464 2 ieee80211_crypt_tkip,hostap
rfcomm 43860 0
ircomm_tty 41224 0
ircomm 24420 1 ircomm_tty
irda 204172 2 ircomm_tty,ircomm
crc_ccitt 2016 1 irda
hidp 20672 0
hid 34852 1 hidp
l2cap 26116 10 rfcomm,hidp
bluetooth 63812 5 rfcomm,hidp,l2cap
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 05:37 AM