OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Dgen, Does it work?
GenericAnimeBoy
post Apr 20 2005, 05:23 PM
Post #1





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



I want to play some Sonic on my Z. Trouble is that DGEN, the only emulator I know of for the Z, isn't working. It gives me a library error:
CODE
dgen: error while loading shared libraries: libstdc++-libc6.1-2.so.3: cannot open shared object file: No such file or directory


I've searched the forums and checked every thread listing this error (mostly talking about cacko rom or kismet on the 6000), and tried as best I can to implement the fixes reccommended in those. Still no emulator. Does this work for anyone else, or does anyone know how to get it working?
Go to the top of the page
 
+Quote Post
lardman
post Apr 21 2005, 01:20 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I think the error says it all.

You need to find and install the lib it's asking for.


Si
Go to the top of the page
 
+Quote Post
GenericAnimeBoy
post Apr 21 2005, 12:35 PM
Post #3





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



Trouble with that is that I can't find that library anywhere in the OZ feeds, and all my searching of ZUG and Google did me no good, as the only thread I could find about it was talking about Cacko.

I'd just like to know if anyone knows whether DGEN (or another Genesis emulator) works on OZ, or knows how to get it working on OZ.
Go to the top of the page
 
+Quote Post
lardman
post Apr 21 2005, 01:23 PM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Did you look in the dev and devel feeds? Do you have them set as src?

QUOTE
I'd just like to know if anyone knows whether DGEN (or another Genesis emulator) works on OZ, or knows how to get it working on OZ.


Basically you need the lib. It ought to be there. I'll have a look tomorrow.


Si
Go to the top of the page
 
+Quote Post
GenericAnimeBoy
post Apr 21 2005, 01:33 PM
Post #5





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



Unexpectedly, I found the link to the lib I needed from the DGEN entry on killefiz. However, now I get a symbol lookup error (not the usual one, though). I used makecompat on dgen--no luck.

The error, for reference, is
CODE
dgen:symbol lookup error: dgen: undefined symbol: __14QPEApplicationRiPPcQ212QApplication4Type


Maybe I need to makecompat that lib as well?

Nope. No Luck.
Go to the top of the page
 
+Quote Post
lardman
post Apr 21 2005, 02:31 PM
Post #6





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I'd just use the OZ version (to eliminate unresolved symbols errors) - it should be in there somewhere.

http://www.openzaurus.org/official/unstabl...4.3-r10_arm.ipk for example

Si
Go to the top of the page
 
+Quote Post
GenericAnimeBoy
post Apr 22 2005, 06:43 AM
Post #7





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



I don't think that's the same library, though. Or is it? My linux knowledge isn't very well-rounded, I'm afraid.
Go to the top of the page
 
+Quote Post
Cwiiis
post Apr 24 2005, 05:09 PM
Post #8





Group: Members
Posts: 60
Joined: 12-May 04
Member No.: 3,258



libstdc++6 is indeed what you want, installing packages intended for other distributions/roms/versions will *not* work - Uninstall the file you got from killefiz and install the file lardman indicated... Unfortunately, dgen doesn't seem to work though sad.gif (I was the one that added it to OE) If you find differently, do please say.
Go to the top of the page
 
+Quote Post
GenericAnimeBoy
post Apr 25 2005, 09:53 AM
Post #9





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



Yeah, I already have libstdc++6 installed (the OZ version), linking it as the missing library didn't resolve the error either. dgen doesn't seem to work with or without compat-libs. It's a pity.
Go to the top of the page
 
+Quote Post
lardman
post Apr 25 2005, 02:08 PM
Post #10





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



See if you can find the source, it may not be too difficult to add it to OE, then you'll cut out the compat libs.


Si
Go to the top of the page
 
+Quote Post
GenericAnimeBoy
post Apr 25 2005, 05:42 PM
Post #11





Group: Members
Posts: 36
Joined: 5-February 05
Member No.: 6,416



I found a source tarball of the latest SDL version of dgen (1.23). What do I do with it?
Go to the top of the page
 
+Quote Post
Cwiiis
post Apr 27 2005, 03:05 AM
Post #12





Group: Members
Posts: 60
Joined: 12-May 04
Member No.: 3,258



dgen 1.18 and 1.23 are already in OE, I included them myself. Your setup must be incorrect in some way, because I have tested both and they both load and run (but 1.23 segfaults loading roms (on both PC and Zaurus), and 1.18 seems to sit there doing nothing on loading a rom (on Zaurus, works fine on PC)).

I recommend you do something along the lines of:
ipkg-link umount <path>
ipkg remove libstdc++6 --force-depends
ipkg update
ipkg install -d <dest> libstdc++6 --force-overwrite
ipkg-link mount <path>

Replacing dest and path with the correct destination/path, assuming you didn't install to root.

Also, a tip to people wanting to add things to OE: Check that they aren't already there!
Go to the top of the page
 
+Quote Post
Cwiiis
post Apr 27 2005, 03:06 AM
Post #13





Group: Members
Posts: 60
Joined: 12-May 04
Member No.: 3,258



Argh, I've just realised you must be using a dgen from a non-OZ feed... If it isn't in the OZ feed already, please request it be built in the upgrades thread.
Go to the top of the page
 
+Quote Post
stupkid
post Apr 27 2005, 07:25 AM
Post #14





Group: Members
Posts: 578
Joined: 2-January 04
From: Texas USA
Member No.: 1,324



I wouldn't work too hard on getting dgen working as it is much too slow to be playable on the Zaurus in my experience. Perhaps if it were complied with softfloat. I would recommend using another Genesis emulator like SMS plus: http://ehe.s57.xrea.com/index.php?cmd=read...%20for%20Zaurus
Go to the top of the page
 
+Quote Post
lardman
post Apr 27 2005, 07:32 AM
Post #15





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
dgen 1.18 and 1.23 are already in OE, I included them myself.


If it's not in the feed at the moment, give hrw a shout in the 3.5.3 upgrades thread and ask him to add it - it will be compiled with soft-float.


Si
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th March 2015 - 09:20 PM