OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Bad Sd Card?, SD card just stopped working
jgrauman
post Dec 13 2005, 04:42 PM
Post #1





Group: Members
Posts: 59
Joined: 19-July 05
From: Los Angeles
Member No.: 7,631



I think my SD card just went bad... I have about 50 megs left on my SD card according to df, but whenever I try to write a file to it, it doesn't work. I just get 0 sized files. I can read the card ok, but no more writing. running dmesg I see a lot of:

pxa_sd_wait_id_response: response time out (cmd=01 MMC_STAT=0x2142)

Any more diagnostics I can run on the card, or other ideas? Thanks.

Josh

P.S. Its a cheap SD card...
Go to the top of the page
 
+Quote Post
Cresho
post Dec 13 2005, 06:09 PM
Post #2





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



pull out your files off that sd card. then format it to fat16. should work again.
Go to the top of the page
 
+Quote Post
jgrauman
post Dec 13 2005, 06:39 PM
Post #3





Group: Members
Posts: 59
Joined: 19-July 05
From: Los Angeles
Member No.: 7,631



QUOTE(Cresho @ Dec 13 2005, 06:09 PM)
pull out your files off that sd card.  then format it to fat16.  should work again.
*
Do I have to keep it fat16? or can I format back to ext2? Is this a hardware problem? What's going on?

Josh
Go to the top of the page
 
+Quote Post
Cresho
post Dec 13 2005, 07:43 PM
Post #4





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



you can do ext2. i expirience these problems once in a big while. i cant reproduce the problem but i fix it in this manner
Go to the top of the page
 
+Quote Post
ceffyl
post Dec 14 2005, 07:25 AM
Post #5





Group: Members
Posts: 87
Joined: 17-September 04
Member No.: 4,621



QUOTE(jgrauman @ Dec 14 2005, 12:42 AM)
I think my SD card just went bad... I have about 50 megs left on my SD card according to df, but whenever I try to write a file to it, it doesn't work. I just get 0 sized files. I can read the card ok, but no more writing. running dmesg I see a lot of:


A while ago my new 1 GB SD card quit working. I had used it in a desktop reader and then put it back into the Z's SD slot. I couldn't mount it, format it, or even get any of my computers to acknoweldge it.

Someone suggested using a digital camera to reformat the SD card. I don't know anyone with a digicam that uses SD, so I ended up going to CompUSA and using one of their display cameras to reformat the card. It worked great aftewrads.

I'm not suggesting that you try this as anything except a last-ditch effort to reclaim the card. It's very possible there is something completely different going on with your media than what happened with mine. I think the write process on the PC messed up the card in some manner.

Good luck.

Ceffyl
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th September 2014 - 01:27 PM