OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Zaurus Sl-3200 Issue With Openbsd39_arm.ipk
dda71
post Apr 12 2006, 12:47 AM
Post #1





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



Hello,

I'm experiencing a strange problem.

This happened to me 3 times during the last 3 days.

I'm using the latest snapshot!

After some while the zaurus can't boot anymore. You see the Openbsd boot loader but it can't find the kernel anymore. I have to boot into linux (typing "r").

The openbsd39_arm.ipk has to be uninstalled and reinstalled to be able to boot again.

Does someone have same the problem?
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 12 2006, 01:07 AM
Post #2





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(dda71 @ Apr 12 2006, 08:47 AM)
Hello,

I'm experiencing a strange problem.

This happened to me 3 times during the last 3 days.

I'm using the latest snapshot!

After some while the zaurus can't boot anymore. You see the Openbsd boot loader but it can't find the kernel anymore. I have to boot into linux (typing "r").

The openbsd39_arm.ipk has to be uninstalled and reinstalled to be able to boot again.

Does someone have same the problem?
*


No, not seen that but I am using my own initrd that allows me to use the whole drive for OpenBSD on my SL-C3000.

Could you tell me what the following commands show please..

fdisk wd0
disklabel wd0

-Andy
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 02:15 AM
Post #3





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



Sure, here it is:

fdisk wd0
0: 83 0 1 1 - 19 15 63 [ 63: 20097 ] Linux files*
1: 83 20 0 1 - 39 15 63 [ 20160: 20160 ] Linux files*
2: 0C 40 0 1 - 2120 8 8 [ 40320: 2097152 ] Win95 FAT32L
*3: A6 2121 0 1 - 11904 15 63 [ 2137968: 9862272 ] OpenBSD


disklabel wd0

# Inside MBR partition 3: type A6 start 2137968 size 9862272
# /dev/rwd0c:
type: ESDI
disk: ESDI/IDE disk
label: HMS360606D5CF00
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 16
sectors/cylinder: 1008
cylinders: 11905
total sectors: 12000556
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0 # microseconds
track-to-track seek: 0 # microseconds
drivedata: 0

16 partitions:
# size offset fstype [fsize bsize cpg]
a: 1024128 2137968 4.2BSD 2048 16384 328 # Cyl 2121 - 3136
b: 204624 3162096 swap # Cyl 3137 - 3339
c: 12000556 0 unused 0 0 # Cyl 0 - 11905*
d: 204624 3366720 4.2BSD 2048 16384 204 # Cyl 3340 - 3542
e: 409248 3571344 4.2BSD 2048 16384 328 # Cyl 3543 - 3948
f: 6291936 3980592 4.2BSD 2048 16384 328 # Cyl 3949 - 10190
g: 1727712 10272528 4.2BSD 2048 16384 328 # Cyl 10191 - 11904
i: 20097 63 ext2fs # Cyl 0*- 19
j: 20160 20160 ext2fs # Cyl 20 - 39
k: 2097152 40320 MSDOS # Cyl 40 - 2120*
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 12 2006, 02:28 AM
Post #4





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



looks ok, I'm presuming that wd0a is your boot disk? am I right?

and just checking, you haven't created an /etc/boot.conf have you (on the boot disk) ?
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 02:30 AM
Post #5





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



Yes, wd0a is the boot disk.
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 12 2006, 02:34 AM
Post #6





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



What is the exact error when it tries to boot?
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 02:54 AM
Post #7





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



QUOTE
and just checking, you haven't created an /etc/boot.conf have you (on the boot disk) ?

No I don't have a boot.conf.

actually it is compiling konqueror-embedded (for 3 hours now), so I can't reboot wink.gif

I'm sorry I can't remember the exact message, rolleyes.gif ; I was to lazzy to write it down ... as this problem happens at random interval, I will have to wait until it happens.

As far as I can remember the message was something like:
boot> can't find /bsd
boot> can't find /bsd.old
boot> can't find wd0a:/bsd
etc

It tried to find the kernel like described in "man 8 boot"
"By default, boot attempts to load the kernel executable /bsd. If that
fails, it will attempt to load /obsd and then /bsd.old. If it fails to
find any of these files, and no alternative kernel image has been speci-
fied, the system will be unable to boot."

I also tried to enter by hand
boot hd0a:/bsd
But it was not able to boot.

1) I then entered an "r" to boot into linux.
2) I uninstalled the openbsd39_arm.ipk
3) reinstalled it.
4) choosed reboot in qtopia
5) and now, it was able to re-boot openbsd
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 12 2006, 03:39 AM
Post #8





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



It may sound a silly question but when you were asked for the package sets during installation you didn't deselect bsd did you?... double check that the file bsd exists on the root of your boot drive.
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 04:03 AM
Post #9





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



QUOTE(iamasmith @ Apr 12 2006, 01:39 PM)
It may sound a silly question but when you were asked for the package sets during installation you didn't deselect bsd did you?... double check that the file bsd exists on the root of your boot drive.
*


biggrin.gif no of course not.

If I didn't install the /bsd kernel it would not have worked at all.

When I had the problem,
1) I booted into linux, launched the bsd.rd boot with the "openbsd install" icon.
2) I launched a shell (option 3, from install, upgrade or shell)
3) I manually mounted the old install via 'mount /dev/wd0a /mnt', and I could see the kernel and the entire installation I did, everything looked fine. I wanted to be sure everything was still there. I then umount /mnt and reboot into linux
4) uninstalled and reinstalled the openbsd39_arm.ipk package
5) openbsd boot was working again.
Go to the top of the page
 
+Quote Post
darkloran
post Apr 12 2006, 04:09 AM
Post #10





Group: Members
Posts: 92
Joined: 19-November 04
From: here or there.. it changes so often ;-)
Member No.: 5,525



QUOTE(dda71 @ Apr 12 2006, 10:54 AM)
boot> can't find /bsd
boot> can't find /bsd.old
boot> can't find wd0a:/bsd

i've experienced such a problem when CF memory card is inserted in CF slot and i'm doing a reboot.

doing a simple boot with CF mem inserted is OK (i mean when the system is completely halted like taking off power and battery).

loran
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 04:30 AM
Post #11





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



QUOTE(darkloran @ Apr 12 2006, 02:09 PM)
i've experienced such a problem when CF memory card is inserted in CF slot and i'm doing a reboot.


Actually I only use the zaurus harddrive, I don't have any other devices inserted/connected, no sd-card or xyz, not even an usb mouse.
Go to the top of the page
 
+Quote Post
iamasmith
post Apr 12 2006, 05:08 AM
Post #12





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



The only thing that I can think of at present is that for some reason is that the OpenBSD boot sequence may be kicking in sometime before Linux launches cardmgr. If cardmgr hasn't been run and the drive been initialised then the bootloader won't see the drive.

You could try modifying rc.zboot and adding the following line...

cardmgr -o

before the line that does insmod zbsdmod. This causes the cardmanager to load once, initialise the hardware and quit. This is all I use in my initrd for the 3000 to make sure that the drive is initialised. If you do this it shouldn't matter if you boot into Linux and a later script runs cardmgr in daemon mode.

This may be worth a try...

-Andy
Go to the top of the page
 
+Quote Post
dda71
post Apr 12 2006, 05:20 AM
Post #13





Group: Members
Posts: 14
Joined: 10-April 06
Member No.: 9,585



QUOTE(iamasmith @ Apr 12 2006, 03:08 PM)
You could try modifying rc.zboot and adding the following line...
cardmgr -o


Yes, I will give it a try and let you know if I still run into the same problem!
thanks!!!
Go to the top of the page
 
+Quote Post
coreilly
post May 20 2006, 12:33 PM
Post #14





Group: Members
Posts: 65
Joined: 10-November 05
Member No.: 8,517



QUOTE(dda71 @ Apr 12 2006, 09:20 AM)
QUOTE(iamasmith @ Apr 12 2006, 03:08 PM)
You could try modifying rc.zboot and adding the following line...
cardmgr -o


Yes, I will give it a try and let you know if I still run into the same problem!
thanks!!!
*



i have the same problem... and putting cardmgr -o into the rc.zboot doesn't seem to correct the error... any others ideas?? the error message is

open(hd0a:/etc/boot.conf): Invalid argument
boot>
booting hd0a:/bsd: openb hda0:.bsd: Invalid argument
failed(22), will try /obsd

open(hd0a:/etc/boot.conf): Invalid argument
boot>
booting hd0a:/bsd: openb hda0:.bsd: Invalid argument
failed(22), will try /bsd.old

open(hd0a:/etc/boot.conf): Invalid argument
boot>
booting hd0a:/bsd: openb hda0:.bsd: Invalid argument
failed(22), will try /bsd

I have gone into the install and down to the shell and made sure all the directories and the install went as planned.. the bsd kernel is there... the partition A6 is flagged with the * ... any other ideas?
Go to the top of the page
 
+Quote Post
iamasmith
post May 22 2006, 02:12 AM
Post #15





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



As previously mentioned, double check there is no CF media in the slot otherwise the internal hd will be enumerated as hd1/wd1
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 02:43 PM