OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Mounting Usb Dev On Sl6000l, I wanted to use my Creative Muvo
cippo
post Feb 5 2006, 08:33 AM
Post #1





Group: Members
Posts: 5
Joined: 5-February 06
From: Italy
Member No.: 9,079



hi there!
I own a usb mini type A adapter for my zaurus.
now I wanted to use my usb2.0 creative Muvo with it... after inserting the device anything sems ok.. (muvo brightens up) but I can not find the root of this device... i browsed the whole zaurus, but none.

do I have to mount it? which is the correct sintax?
thanks a lot!
Go to the top of the page
 
+Quote Post
eji
post Feb 5 2006, 11:07 AM
Post #2





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



I've had trouble getting my 6000 to see devices over 2GB.

Type this in the terminal:

mount -t vfat /dev/sda1/ mnt/usbstorage

... and to unmount:

umount /mnt/usbstorage
Go to the top of the page
 
+Quote Post
eji
post Feb 5 2006, 01:24 PM
Post #3





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



After I responded, I remembered correctly that I'd had some trouble mounting my camera -- not 2GB+ drives -- a while back, so I hunted around for more info on the OE forums and elsewhere.

First, there has to be a /dev/sda entry in etc/fstab. After I completely messed up my Z, I had reflashed the ROM to the "Grant clan" original and lost the /dev/sda1 entry. Which is why I was having problems (i.e., "no dev/sda1 in etc/fstab" errors) earlier.

There's a good tutorial here (text search for "usbstorage"), which also gives some quick automount modifications that will work on the 6000. I still can't mount my wife's iPod because I think it's HFS+ formatted. But my camera mounts automatically now.

Attached as "USBauto.zip" are the three files as I've modified them.

- Put "usb-storage" and "usb-storage.off" in etc/hotplug/usb/
- Replace your old fstab file (in etc/fstab -- rename or back it up first!) with this one.
- Then chmod both files as su: #chmod 755 /etc/hotplug/usb/usb-storage and #chmod 755 /etc/hotplug/usb/usb-storage.off

... now your Muvo should mount automatically. You should see it appear under the "Files" tab at the same level as SD and CF cards.

Please let me know if it works so I can rest easy or edit the files accordingly.
Attached File(s)
Attached File  USBauto.zip ( 911bytes ) Number of downloads: 116
 
Go to the top of the page
 
+Quote Post
cippo
post Feb 6 2006, 02:33 PM
Post #4





Group: Members
Posts: 5
Joined: 5-February 06
From: Italy
Member No.: 9,079



Hi!
I followed yor instructions and I'm finally enjoying my muvo on the zaurus! I find it very useful! So.. thank you very much for your help!

Now I'm gonna put the files you attached biggrin.gif
I'll let you know ...


----------EDIT: UPDATE!! ------------

It works very good on my Zaurus!!
auto mount in /mnt/usbstorage and icon in the tab!
auto umount as well!!

Great work! biggrin.gif

Asap I'll try with other devices..
I will let you know!

thanks a lot Eji! wink.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 07:10 PM