OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Xkpcomp, xkpcomp failed to compile in Beta1 for T
enlightened_j
post May 22 2006, 07:15 PM
Post #1





Group: Members
Posts: 18
Joined: 30-November 04
Member No.: 5,680



Hello,

I have been using pdaXrom on Zaurus 6000 for almost a year. Recently, I decided to spend some of my time trying to participate the development process of pdaXrom.

The first thing I decided to try is to build pdaXrom on my own. I found several how-to and posts on such topic. After following the instruction, I was able to get the toolchain build. I gladly moved along to building the actual Rom. However, I have been stuck with xkbcomp.

Specifically, the builder would die in directory linking all object files into "xkbcomp" in directory "/xc/programs/xkbcomp/cross". It printted out error message -lxkbfile is missing.

So I thought to myself, "this is easy, all I have to do is find the correct share object and modify the Makefile". After using the "file" command, it shows me that all object files are i386 files. So I tried to find the libxkbfile.so.... in the host system. But it's no where to be found!!

So here is my question:
1. Why is it trying to build the binary for i386 instead of arm architecture?
2. How do I get around it?

Thanks.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th November 2014 - 03:20 PM