OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Vi Problem
egw
post Feb 7 2005, 11:07 PM
Post #1





Group: Members
Posts: 17
Joined: 25-January 05
Member No.: 6,310



Hi,

I'm having an intermittent problem with vi (stock vi, stock c3000). Sometimes I can open and edit a file, but other times, I get an error


garbage() failed to read oldhdr??[More...]
Trouble writing header to tmp file


and the file doesn't load. If I quit and try to edit the file again, the error changes to


<filename> is busy.


Anyone know what this is all about?

Thanks,
Eric
Go to the top of the page
 
+Quote Post
jfv
post Feb 8 2005, 06:54 AM
Post #2





Group: Members
Posts: 438
Joined: 24-June 03
Member No.: 202



I've had something similar happen. I've noticed in particular that this happens the Zaurus suspends while a vi session is open. I don't know what the cause is. Rebooting solves the problem, but it would be nice to have a better solution. BTW this is on the C860. I've never had this problem with the 5000D.

Felipe
Go to the top of the page
 
+Quote Post
lardman
post Feb 8 2005, 07:58 AM
Post #3





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
If I quit and try to edit the file again, the error changes to


<filename> is busy.


If vi crashes, the lock-file it creates for the opened file (in /tmp I think) isn't removed, so it thinks the file is still open. To get rid of the message, delete the lock-file.

I've no idea what's causing the initial problem though.


Si
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th April 2014 - 04:39 PM