OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Ambicom Bluetooth, Problems with Internet access
case
post Jul 24 2006, 09:19 AM
Post #1





Group: Members
Posts: 35
Joined: 29-May 06
Member No.: 9,997



Hi,

I have successfully set up and paired my Z and a windows XP laptop. I used the Bluez Alpha drivers and the apps from the Cacko web site for PAN access. I can
successfully use the network application on the Z to join my XP laptop. I have internet connection sharing enabled on my laptop lan card. However, when I attempt to access a web site with Netfront it gives me a TCP error. I have set the IP address to one more than the last one. I also have set the DNS address to the laptops IP address. Any help would be appreciated.

thanks
Case
Go to the top of the page
 
+Quote Post
zmiq2
post Jul 24 2006, 11:46 AM
Post #2





Group: Members
Posts: 385
Joined: 3-December 03
Member No.: 1,038



you should also check your routing parameters.

at the console type

# route -n

to check whether or not packets are sent to the laptop to then go to the internet.

HTH
Go to the top of the page
 
+Quote Post
case
post Jul 24 2006, 03:57 PM
Post #3





Group: Members
Posts: 35
Joined: 29-May 06
Member No.: 9,997



Hi,

thanks,

I that didn't even occur to me.......
thanks..

case
Go to the top of the page
 
+Quote Post
case
post Jul 25 2006, 04:34 PM
Post #4





Group: Members
Posts: 35
Joined: 29-May 06
Member No.: 9,997



Ok,

I solved my problem.

I downloaded the following ipks:

http://my-zaurus.narod.ru/bluetooth.html

www.oesf.org/forums/index.php?act=Attach&type=post&id=279

The problem was a combination of IP settings both on the XP system and the C1000.

I do not believe you can share a wifi connection on XP. Atleast, I could not get Internet connection sharing to work with it. I set up sharing on my wired card on the XP machine. You may see a dialog for the internet connection sharing that allows you to choose which networks share the wired XP card. If you do select the bluetooth network. In my case it did not give me a choice.

I then went back to the Bluetooth network setting under network connections on the XP box. I set a fixed IP address of 192.168.129.1, subnet mask of 255.255.255.0. Then I went to the Zaurus network settings. Select new network PAN-TCP/IP. Go to IP settings and set IP address of 192.168.129.201, subnet mask 255.255.255.0. This is the key point in for me: gateway of 192.168.129.1 and first DNS of 192.168.129.1. Both of these should match whatever IP address you set for the XP Bluetooth network. Hit OK to get out of the network settings. Hit Connect. The globe in the tool bar should appear to be connecting. I was prompted to accept the connection the XP box. Fire up Netfront or you web browser of choice.....

..........Viola biggrin.gif .

Surfing away.

It is just as fast as my Wifi card in the same Zaurus. I was really suprised.

I hope that helps someone.

Case
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st July 2014 - 01:38 PM