OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> C1000, Sitecom Usb Hub, Fellowes Kb, Iogear Mouse, Quick review
Cagilaba
post Sep 28 2005, 01:21 PM
Post #1





Group: Members
Posts: 55
Joined: 16-August 05
From: Paris, France
Member No.: 7,872



Excited (like many here) by the idea of an ultra-portable laptop-style setup, I just invested in a few USB peripherals for my SL-C1000. I wanted to share my experience with these new toys. smile.gif Sorry in advance for the long post.... I hope this is of interest to someone! rolleyes.gif

The hardware
----------------
I ordered a Fellowes Stowaway USB keyboard from Chase & Company via eBay. Quick service and good communication (once I got over the hurdle of creating and "validating" my Paypal account). $24.95 + shipping to France = $37.90.

I went over to Surcouf, a big computer store, and bought a Sitecom USB Micro Hub (USB 1.1, 4 ports, 7.99 Euros) and an IOGEAR USB Optical Mini Mouse (14.90 Euros).

I had already installed the wonderful mouse driver found on the forum.

The result
------------
A pretty nice setup! The mouse and keyboard both work through this unpowered hub. cool.gif

Attached File  zaurus_c1000_usb_periphs.jpg ( 108.24K ) Number of downloads: 269


Issues I encountered
------------------------
Something weird I've noticed: I plug the mouse and keyboard into a hub, then there's a brief delay while they are recognized, then if I type in an app, the keyboard produces random characters that don't correspond to the keys I'm pressing, and the Zaurus suspends after a few moments. Then I wake it up again and the keyboard and mouse work fine. huh.gif

Key mappings of course correspond to the Zaurus keyboard and not the Stowaway. I'll have to figure out how to use the KeyHelper app... Is there any way to set up something like different profiles that would work with different keyboards? Also, the pipe character / backslash key on the Fellowes keyboard doesn't work... and somewhat annoyingly, the Shift + Space = pipe, the way Trisoft set up their keymappings -- so I keep typing pipes instead of spaces.

My battery power indicator went down as soon as I plugged in the two devices. I could tell it wouldn't last long at this rate -- almost as bad as wifi! And given that the battery indicator is pretty inaccurate, it makes me worried that my Zaurus will suddenly power down. Is it ok to run the Z on AC power for hours on end??

The IOGEAR mouse is really quite usable. But I find it pretty strange that the LED never turns off, which I assume sucks more power (on other optical mice I've seen, the LED turns off). Or maybe the LED only uses a tiny amount of power? This mouse shines red light out the top and back as well as the bottom, so I'm hoping there isn't more than one LED inside!

A couple of the ports on the Sitecom hub were a little tight...

Conclusion
------------

The Fellowes keyboard is the best portable kb solution I've seen so far. I'm amazed at how cheap it is compared to the price I paid a few years ago for a Stowaway KB for my Handspring Visor! The Fellowes cable is a bit annoying as it's long and gets in the way, but nothing serious. The mouse is fairly well constructed, and quite usable, but I wish it didn't light up so much.

All in all, I'm very happy with my little setup. smile.gif
Go to the top of the page
 
+Quote Post
cal
post Sep 29 2005, 02:28 AM
Post #2





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



Great setup, I think I might try to copy it.

I think the simplest way to handle the keyboard setup is by making two keymaps. A simple script can switch the two when you want. I can set you up with the script if you need. I don't have the keyboard so you will have to hack out a keymap.

Also don't worry about the mouse LED, they don't draw enough power to notice. I think you can light a few types up with a potato battery.
Go to the top of the page
 
+Quote Post
Cagilaba
post Sep 29 2005, 02:57 AM
Post #3





Group: Members
Posts: 55
Joined: 16-August 05
From: Paris, France
Member No.: 7,872



QUOTE(cal @ Sep 29 2005, 12:28 PM)
I can set you up with the script if you need.

Yes please!

QUOTE
Also don't worry about the mouse LED, they don't draw enough power to notice. I think you can light a few types up with a potato battery.

biggrin.gif

I'll get working on the keymap as soon as I have a bit of time...
Go to the top of the page
 
+Quote Post
DaveZ3000
post Oct 17 2005, 10:09 AM
Post #4





Group: Members
Posts: 2
Joined: 17-October 05
Member No.: 8,330



The Zaurus is a sweet machine but I am also having trouble getting the Fellowes USB folding keyboard to deliver the correct characters from the right side of the keyboard (and no, I don't think my used machine has ever met up with Trisoft). Has anyone else got a solution already worked out?
Go to the top of the page
 
+Quote Post
icruise
post Oct 17 2005, 11:53 AM
Post #5





Group: Members
Posts: 292
Joined: 24-June 05
Member No.: 7,447



Are you talking about the punctuation or all of the keys on the right of the keyboard?
Go to the top of the page
 
+Quote Post
DaveZ3000
post Oct 17 2005, 01:16 PM
Post #6





Group: Members
Posts: 2
Joined: 17-October 05
Member No.: 8,330



QUOTE(icruise @ Oct 17 2005, 03:53 PM)
Are you talking about the punctuation or all of the keys on the right of the keyboard?
*


Some of the keys on the right side (maybe 7 or 8) do not give anything (or could that perhaps mean something that is not "printable"...?). The rest of them give the wrong character... which we take to mean the problem is incorrect mapping of keyboard output to the "input" process on the Zaurus. We have tried a second Fellowes Stowaway USB keyboard with the same results. I believe we have the Sharp 1.1 rom. Thanks for your response.
Go to the top of the page
 
+Quote Post
icruise
post Oct 19 2005, 03:21 AM
Post #7





Group: Members
Posts: 292
Joined: 24-June 05
Member No.: 7,447



That's odd, because my Fellowes keyboard works fine, except for the fact that punctuation keys are off.
Go to the top of the page
 
+Quote Post
sleepy
post Oct 22 2005, 04:11 AM
Post #8





Group: Members
Posts: 33
Joined: 30-March 05
Member No.: 6,739



QUOTE(DaveZ3000 @ Oct 17 2005, 01:16 PM)
QUOTE(icruise @ Oct 17 2005, 03:53 PM)
Are you talking about the punctuation or all of the keys on the right of the keyboard?
*


Some of the keys on the right side (maybe 7 or 8) do not give anything (or could that perhaps mean something that is not "printable"...?). The rest of them give the wrong character... which we take to mean the problem is incorrect mapping of keyboard output to the "input" process on the Zaurus. We have tried a second Fellowes Stowaway USB keyboard with the same results. I believe we have the Sharp 1.1 rom. Thanks for your response.
*



I've got the exact same issue with a C1000 on Cacko 1.23beta. For example the "i" key doesn't seem to register as well as others on the right side. Are there, perhaps, mulitple versions of this keyboard? I could pick up another USB keyboard but I really like the feel and portability of the Fellowes.
Go to the top of the page
 
+Quote Post
mistermix
post Oct 24 2005, 06:56 AM
Post #9





Group: Members
Posts: 19
Joined: 28-July 05
Member No.: 7,723



I also have issues with the Fellowes keyboard - the right side doesn't work correctly. The only way to get it to work was to plug it into a Windows or Linux PC, which somehow initialized it, and then plug it into the Z. On the Z, the Num Loc and Caps Loc LEDs do not light up as they do when plugged into a "regular" PC.

Others have reported in other threads that their Fellowes keyboard works fine.

A shame, really, because the keyboard is otherwise excellent.
Go to the top of the page
 
+Quote Post
icruise
post Oct 24 2005, 07:07 AM
Post #10





Group: Members
Posts: 292
Joined: 24-June 05
Member No.: 7,447



There must be different revisions of the same keyboard. Either that, or a bad batch of them was released, but I think the former explanation is more likely.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 07:08 AM