OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

44 Pages V  « < 2 3 4 5 6 > »   
Reply to this topicStart new topic
> Htc Universal, ... running Debian EABI
ShiroiKuma
post Apr 17 2008, 02:54 AM
Post #46





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



OK, intermediate report, going quite well...

I've booted the Zdevil's clean and configured tarball, started x, obviously the display doesn't work. Will try to see if it's just the pointercal, copied one over from the OpenMoko image, which worked, so will try to see if it works with that.

Otherwise, it would be using another device for the input. If this is so, which one?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 17 2008, 03:08 AM
Post #47





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



Update, this doesn't solve it, so it's (probably logically) another device than on the Z. I've also noted no modules are loaded after starting.

datathief, do you have a base rootfs which maybe I should start from and disregard the Z rootfs, if that would be a better solution?
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 03:25 AM
Post #48





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ShiroiKuma @ Apr 17 2008, 10:54 AM) *
OK, intermediate report, going quite well...

I've booted the Zdevil's clean and configured tarball, started x, obviously the display doesn't work. Will try to see if it's just the pointercal, copied one over from the OpenMoko image, which worked, so will try to see if it works with that.

Otherwise, it would be using another device for the input. If this is so, which one?

I don't remember having difficulty getting X running, but it's been a while. Try setting TS_DEVICE=/dev/input/event0.
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 17 2008, 04:03 AM
Post #49





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(datathief @ Apr 17 2008, 12:25 PM) *
I don't remember having difficulty getting X running, but it's been a while. Try setting TS_DEVICE=/dev/input/event0.

Will try... You wouldn't remember which rootfs you used then, when you got started, would you?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 17 2008, 04:40 AM
Post #50





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(datathief @ Apr 17 2008, 12:25 PM) *
I don't remember having difficulty getting X running, but it's been a while. Try setting TS_DEVICE=/dev/input/event0.

This had no effect apparently, perhaps I'll try ts_calibrate before X, to see if it makes any difference.
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 05:11 AM
Post #51





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ShiroiKuma @ Apr 17 2008, 12:03 PM) *
You wouldn't remember which rootfs you used then, when you got started, would you?

I used debootstrap to build the rootfs, and the packages at http://yonggun.tistory.com/54 to get X working.
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 05:14 AM
Post #52





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ShiroiKuma @ Apr 17 2008, 12:40 PM) *
QUOTE(datathief @ Apr 17 2008, 12:25 PM) *
I don't remember having difficulty getting X running, but it's been a while. Try setting TS_DEVICE=/dev/input/event0.

This had no effect apparently, perhaps I'll try ts_calibrate before X, to see if it makes any difference.

Is there any helpful output from the X server? Can you start Xfbdev from the command line?
CODE
TS_DEVICE=/dev/input/event0 Xfbdev & pid=$!; sleep 10s; pkill $pid


EDIT: I think it's TSLIB_TSDEVICE, not TS_DEVICE. Oops.
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 05:25 AM
Post #53





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(datathief @ Apr 17 2008, 01:14 PM) *
QUOTE(ShiroiKuma @ Apr 17 2008, 12:40 PM) *
QUOTE(datathief @ Apr 17 2008, 12:25 PM) *
I don't remember having difficulty getting X running, but it's been a while. Try setting TS_DEVICE=/dev/input/event0.

This had no effect apparently, perhaps I'll try ts_calibrate before X, to see if it makes any difference.

Is there any helpful output from the X server? Can you start Xfbdev from the command line?
CODE
TS_DEVICE=/dev/input/event0 Xfbdev & pid=$!; sleep 10s; pkill $pid


Hang on... I've taken a look in the packages from http://yonggun.tistory.com/54 and found where the touchscreen device is configured. This may not apply to the packages you're using, but anyway...
  • Edit /etc/profile.d/tslib.sh, and change /dev/input/ts0 to /dev/input/event0
  • Log out or reboot
  • Start X smile.gif
I think event0 is correct - if I do cat -v /dev/input/event0, I get output when I touch the screen.
Go to the top of the page
 
+Quote Post
desertrat
post Apr 17 2008, 06:44 AM
Post #54





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



QUOTE(datathief @ Apr 16 2008, 09:13 PM) *
The SD card slot is occupied when running Linux (there's no way to install to the internal flash yet).
Does it do SDHC?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 17 2008, 07:04 AM
Post #55





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(datathief @ Apr 17 2008, 02:25 PM) *
[*]Edit /etc/profile.d/tslib.sh, and change /dev/input/ts0 to /dev/input/event0
[*]Log out or reboot
[*]Start X smile.gif
[/list]I think event0 is correct - if I do cat -v /dev/input/event0, I get output when I touch the screen.

Allright, didn't get as far as tslib.sh, but I copied /etc/ts.conf from the OpenMoko rootfs and then could run ts_calibrate and now the touchscreen works in X.

Now I'm trying to start X as a normal user, not as root.

When I run from a normal account created, I keep getting
CODE
$ startx
X: cannot stat /etc/X11/X (No such file or directory), aborting.
xinit: Server error.


So far haven't been able to fix this. Am searching on the web for pointers, but other than saying dpkg-reconfigure xorg or whatever not much. Any hints?
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 08:06 AM
Post #56





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



QUOTE(ShiroiKuma @ Apr 17 2008, 03:04 PM) *
CODE
$ startx
X: cannot stat /etc/X11/X (No such file or directory), aborting.
xinit: Server error.


So far haven't been able to fix this. Am searching on the web for pointers, but other than saying dpkg-reconfigure xorg or whatever not much. Any hints?

Try making a link to Xfbdev:
CODE
ln -s `which Xfbdev` /etc/X11/X
Go to the top of the page
 
+Quote Post
datathief
post Apr 17 2008, 08:21 AM
Post #57





Group: Members
Posts: 206
Joined: 21-January 08
Member No.: 21,231



FYI, I've fixed a bug in htcunid (it crashed if the phone was suspended while GPRS was in use), and uploaded a proper htcunid.deb. I'll try to put together a deb of the other stuff (keymap, sound, and keyboard and power hacks).
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 17 2008, 12:17 PM
Post #58





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(datathief @ Apr 17 2008, 05:06 PM) *
Try making a link to Xfbdev:
CODE
ln -s `which Xfbdev` /etc/X11/X

I kept thinking why it would require a symlink that root doesn't require when starting X. Of course, the answer is simple. Since the simple user didn't have the same path definitions as rot etc. So I copied over .profile and .xserverrc from /root directory.

However now there is again something that beats me. I get:
CODE
$ startx


Fatal server error:
LinuxInit: Server must be suid root

giving up.


And this though
CODE
# chmod u+s `which X`
went through with no problem.

What the? Currently cannot move on this.
Go to the top of the page
 
+Quote Post
ZDevil
post Apr 18 2008, 12:03 AM
Post #59





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



So ShiroiKuma did you manage to get X running as root?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Apr 18 2008, 02:32 AM
Post #60





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(ZDevil @ Apr 18 2008, 09:03 AM) *
So ShiroiKuma did you manage to get X running as root?

As root it runs no prob.

But I'd like to get it to run as a regular user. Now, the problem seems to be centered around /usr/bin/Xfbdev

If I suid it, then even trying to start X as root gives me the above error that Server has to be suid... What the...?

If I chmod it 755 again, then as root I can start and run no prob, sudo startx starts it, but the touchscreen doesn't work, starting as regular user gives me the above error?

I'm just about to check your thread on the clean configured tarball. Did you encounter problems there creating and running as normal user? Or did nobody do that? Doesn't seem smart to me to run the environment as root.
Go to the top of the page
 
+Quote Post

44 Pages V  « < 2 3 4 5 6 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th November 2014 - 08:27 PM