OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

9 Pages V  < 1 2 3 4 5 > »   
Reply to this topicStart new topic
> X/qt Preconfigured With Apps, running off cramfs images
ArchiMark
post Apr 24 2006, 11:10 AM
Post #31





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Did what you suggested, Meanie...uninstalled 'xqt-gtk-jumbo' first using uninstaller then installed pdaXqtrom using your new files and script.

Here's what I got in console:

CODE
bash-2.05$ su
# ./pdaXqtrom-install.sh
X/Qt super jumbo installer - version 0.3.6
automounter is not installed.
it is recommended to install automounter or something similar
The system has 7 loop devices.
There are 3 cramfs/squashfs images.
...checking for pdaXqtrom-base.cramfs
pdaXqtrom-base.cramfs not found.
...installing pdaXqtrom-base to /hdd3
Warning: ambiguous entry for pdaXqtrom-base.squashfs found in /etc/fstab
pdaXqtrom 1.1.0 - beta 0.7.5
Installing pdaXqtrom-base on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying .directory to /opt/QtPalmtop/apps/XQt/.directory
...copying .order to /opt/QtPalmtop/apps/XQt/.order
...copying Xqt.desktop to /opt/QtPalmtop/apps/XQt/Xqt.desktop
...copying startx.desktop to /opt/QtPalmtop/apps/XQt/startx.desktop
...copying icons files to /opt/QtPalmtop/pics144
...copying Xqt.png to /opt/QtPalmtop/pics144/Xqt.png
...copying startx.png to /opt/QtPalmtop/pics144/startx.png
...copying xsplash.png to /opt/QtPalmtop/pics144/xsplash.png
...copying xtab.png to /opt/QtPalmtop/pics144/xtab.png
...copying xterm.png to /opt/QtPalmtop/pics144/xterm.png
...linking files to /opt/QtPalmtop/help/html
...linking files to /opt/QtPalmtop/share/locale/ja/LC_MESSAGES
...linking files to /opt/QtPalmtop/share/themes
...linking files to /opt/QtPalmtop/share
...linking files to /opt/QtPalmtop/etc
...linking files to /opt/QtPalmtop/bin
...linking files to /opt/QtPalmtop/lib/X11
...linking files to /opt/QtPalmtop/lib/gconv
...linking files to /opt/QtPalmtop/lib/glib-2.0
...linking files to /opt/QtPalmtop/lib/gtk-2.0
...linking files to /opt/QtPalmtop/lib/locale
...linking files to /opt/QtPalmtop/lib/pango
...linking files to /opt/QtPalmtop/lib
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/lib
...linking files to /usr/local/share
...copying config files to /etc/X11
...copying app-defaults to /etc/X11/app-defaults
...copying defaultwm to /etc/X11/defaultwm
...copying kb to /etc/X11/kb
...copying proxymngr to /etc/X11/proxymngr
...copying xinit to /etc/X11/xinit
...copying xserver to /etc/X11/xserver
...copying config files to /etc/bonobo-activation
...copying bonobo-activation-config.xml to /etc/bonobo-activation/bonobo-activation-config.xml
...copying config files to /etc/fonts
...copying fonts.conf to /etc/fonts/fonts.conf
...copying fonts.dtd to /etc/fonts/fonts.dtd
...copying local.conf to /etc/fonts/local.conf
...copying config files to /etc/gconf
...copying 2 to /etc/gconf/2
...copying gconf.xml.defaults to /etc/gconf/gconf.xml.defaults
...copying gconf.xml.mandatory to /etc/gconf/gconf.xml.mandatory
...copying schemas to /etc/gconf/schemas
...copying config files to /etc/gnome-vfs-2.0
...copying modules to /etc/gnome-vfs-2.0/modules
...copying config files to /etc/gtk-2.0
...copying config files to /etc/imlib
...copying im_palette-small.pal to /etc/imlib/im_palette-small.pal
...copying im_palette-tiny.pal to /etc/imlib/im_palette-tiny.pal
...copying im_palette.pal to /etc/imlib/im_palette.pal
...copying imrc to /etc/imlib/imrc
...copying config files to /etc/pango
...copying pangox.aliases to /etc/pango/pangox.aliases
...copying config files to /etc/sound
...copying events to /etc/sound/events
...linking X server and config
...copying xmodmaprc to /etc/X11/kb
...copying user config files to /home/zaurus
...copying .gtkrc to /home/zaurus/.gtkrc
...copying .gtkrc-2.0 to /home/zaurus/.gtkrc-2.0
...loading libraries
...generating config files
gtk-query-immodules-2.0: error while loading shared libraries: libXrandr.so.2: cannot load shared object file: No such file or directory
pdaXqtrom-base configured.
...checking for pdaXqtrom-apps.cramfs
pdaXqtrom-apps.cramfs not found.
...installing pdaXqtrom-apps to /hdd3
Warning: ambiguous entry for pdaXqtrom-apps.squashfs found in /etc/fstab
mount: Mounting /hdd3/pdaXqtrom-apps.squashfs on /mnt/pdaXqtrom-apps failed: Invalid argument
...checking for zgcc2-95-2.cramfs
zgcc2-95-2.cramfs not found.
...installing zgcc2-95-2 to /hdd3
Warning: ambiguous entry for zgcc2-95-2.squashfs found in /etc/fstab
mount: Mounting /hdd3/zgcc2-95-2.squashfs on /mnt/zgcc failed: Invalid argument
X/Qt installed and configured (if found).
#      


One weird thing is that I checked to make sure and I do have automounter installed!

Any suggestions??

Thanks,

Mark

QUOTE(Meanie @ Apr 23 2006, 11:56 PM)
QUOTE(ArchiMark @ Apr 24 2006, 03:24 AM)
Hi Meanie,

Want to try out your new pdaXqtrom...but don't want to mess things up...  rolleyes.gif

So since I already have X/Qt/Debian installed using your cramfs images on my /hdd3, what should I do before installing??

Should I uninstall X/Qt first? and Debian too??

If so, what's best way to uninstall??

Thanks,

Mark


you should have a xqt-gtk-jumbo item in your uninstall list. just uninstall it and then install pdaXqtrom, or if you have the cramfs version of xqt-gtk-jumbo installed, then you can also just install pdaXqtrom and it will just overrride xqt-gtk-jumbo links. you can easily switch between pdaXqtrom and xqt-gtk-jumbo by just re-running their setup scripts. if yo installed the ipk, then you should uninstall it. pocketworkstation is currently being ignored by the pdaXqtrom. well, it calls debrunner to launch pocketworkstation, but debrunner doesn't exist yet smile.gif i will add that later...
*

Go to the top of the page
 
+Quote Post
xamindar
post Apr 24 2006, 01:12 PM
Post #32





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



QUOTE(Meanie @ Apr 24 2006, 05:19 AM)
QUOTE(xamindar @ Apr 24 2006, 06:46 PM)
bummer.  it appears that the new cramfs jumbo package has messed up my wget.  I hope it hasn't messed up anything else.
CODE
$ wget http://radnimax.com/misc/screenshot1.jpg
--01:42:06--  http://radnimax.com/misc/screenshot1.jpg
          => `screenshot1.jpg'
Resolving radnimax.com... 24.4.222.188
wget: error while loading shared libraries: wget: undefined symbol: __umodsi3
$        


Wget is required by shoutcast player and now it can't get any playlists.

Anyone know a fix for this?
*


hm.. what version of wget are you using? maybe try a newer version.
try this link http://zaurus.daemons.gr/menaie/feed/
*



The version I have is 1.10.2

I'll try the one on that feed next chance I get. I currently do not have a wget package listed in my install list so it must be the one that came with cacko/sharp rom.
Go to the top of the page
 
+Quote Post
xamindar
post Apr 24 2006, 01:14 PM
Post #33





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Hey ArchiMark, after you uninstalled the previous version did you remimber to remove the mounts from your fstab and reboot?
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 24 2006, 02:20 PM
Post #34





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Ummmmm......no........

rolleyes.gif

So I'll do that and try again, right???......

Thanks, xamindar!

Mark
QUOTE(xamindar @ Apr 24 2006, 02:14 PM)
Hey ArchiMark, after you uninstalled the previous version did you remimber to remove the mounts from your fstab and reboot?
*
Go to the top of the page
 
+Quote Post
Meanie
post Apr 24 2006, 05:54 PM
Post #35





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(freebird @ Apr 25 2006, 03:03 AM)
Hi MEANIE
here are some reports after testing on my c860

gqview and xpdf sizing is ok

but abiword and stardict doesn't work
here is what i get when trying to launch abiword
CODE
$xlauncher abiword
launching abiword - please wait a moment...
(process:405): Gdk-WARNING **: locale not supported by C library
(abiword:405): Gtk-WARNING **: locale not supported by C library.
            Using the fallback 'C' locale.
(abiword:405):GdkPixbuf-WARNING **: Error loading XPM image loader: image type 'xpm' is not supported
(abiword:405):Gtk-CRITICAL **: gtk_icon_set_new_from_pixbuf: assertion 'pixbuf !=NULL' failed
(abiword:405):Gtk-CRITICAL **: gtk_icon_factory_add: assertion 'icon_set != NULL' failed
(abiword:405):Gtk-CRITICAL **: gtk_icon_set_unref: assertion 'icon_set != NULL' failed

and here is what i get when trying to launch stardict
CODE
$xlauncher stardict
launching stardict - please wait a moment...
(sardict:428): Gtk-WARNING **: locale not supported by C library
            Using the fallback 'C' locale.

(sardict:428): Gdk-WARNING **: locale not supported by C library

(gnome_segv:431):Gtk-WARNING **: locale not supported by C library
            Using the fallback 'C' locale.
(gnome_segv:431):Gdk-WARNING **: locale not supported by C library

then a message box is opened with this text THE APPLICATION "stardict" has quit unexpectedly.
choose restart application or close


cheers
freebird
*


oh, he C locale problem again. That one is easy to fix.

Add

CODE
export LC_ALL=C
export LANGUAGE=C

into /home/zaurus/.profile

if the file does not exist, create a new one

QUOTE
# source /home/zaurus/.profile


to apply the setting or quit the console and start it again.

also, remove /etc/X11 directory and rerun pdaXqtrom-base-setup
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 24 2006, 06:25 PM
Post #36





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Well...just tried what you suggested, xamindar, but I'm still getting error messages during install....
Deleted about 5-6 mounts in my fstab and then rebooted before trying to reinstall again....

CODE
bash-2.05$ su
# cd /hdd3
# ls
debroot                  pdaXqtrom-base.squashfs  usr                      xqt-install.sh
home                     pdaXqtrom-install.sh     xqt-apps.cramfs          zgcc2-95-2.squashfs
install.sh               pocketworkstation        xqt-cleanup
pdaXqtrom-apps.squashfs  swapfile                 xqt-gtk-jumbo.cramfs
# ./pdaXqtrom-install.sh
X/Qt super jumbo installer - version 0.3.6
automounter is not installed.
it is recommended to install automounter or something similar
The system has 7 loop devices.
There are 3 cramfs/squashfs images.
...checking for pdaXqtrom-base.cramfs
pdaXqtrom-base.cramfs not found.
...installing pdaXqtrom-base to /hdd3
Warning: ambiguous entry for pdaXqtrom-base.squashfs found in /etc/fstab
pdaXqtrom 1.1.0 - beta 0.7.5
Installing pdaXqtrom-base on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying icons files to /opt/QtPalmtop/pics144
...linking files to /opt/QtPalmtop/help/html
...linking files to /opt/QtPalmtop/share/locale/ja/LC_MESSAGES
...linking files to /opt/QtPalmtop/share/themes
...linking files to /opt/QtPalmtop/share
...linking files to /opt/QtPalmtop/etc
...linking files to /opt/QtPalmtop/bin
...linking files to /opt/QtPalmtop/lib/X11
...linking files to /opt/QtPalmtop/lib/gconv
...linking files to /opt/QtPalmtop/lib/glib-2.0
...linking files to /opt/QtPalmtop/lib/gtk-2.0
...linking files to /opt/QtPalmtop/lib/locale
...linking files to /opt/QtPalmtop/lib/pango
...linking files to /opt/QtPalmtop/lib
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/lib
...linking files to /usr/local/share
...copying config files to /etc/X11
...copying config files to /etc/bonobo-activation
...copying config files to /etc/fonts
...copying config files to /etc/gconf
...copying config files to /etc/gnome-vfs-2.0
...copying config files to /etc/gtk-2.0
...copying config files to /etc/imlib
...copying config files to /etc/pango
...copying config files to /etc/sound
...linking X server and config
...copying user config files to /home/zaurus
...loading libraries
...generating config files
pdaXqtrom-base configured.
...checking for pdaXqtrom-apps.cramfs
pdaXqtrom-apps.cramfs not found.
...installing pdaXqtrom-apps to /hdd3
Warning: ambiguous entry for pdaXqtrom-apps.squashfs found in /etc/fstab
pdaXqtApps - beta 0.7.5
Installing pdaXqtApps on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying abiword.desktop to /opt/QtPalmtop/apps/XQt/abiword.desktop
...copying dillo.desktop to /opt/QtPalmtop/apps/XQt/dillo.desktop
...copying firefox.desktop to /opt/QtPalmtop/apps/XQt/firefox.desktop
...copying galculator.desktop to /opt/QtPalmtop/apps/XQt/galculator.desktop
...copying gimp.desktop to /opt/QtPalmtop/apps/XQt/gimp.desktop
...copying scite.desktop to /opt/QtPalmtop/apps/XQt/scite.desktop
...copying stardict.desktop to /opt/QtPalmtop/apps/XQt/stardict.desktop
...copying sylpheed.desktop to /opt/QtPalmtop/apps/XQt/sylpheed.desktop
...copying thunderbird.desktop to /opt/QtPalmtop/apps/XQt/thunderbird.desktop
...copying xarchiver.desktop to /opt/QtPalmtop/apps/XQt/xarchiver.desktop
...copying xchat.desktop to /opt/QtPalmtop/apps/XQt/xchat.desktop
...copying xpdf.desktop to /opt/QtPalmtop/apps/XQt/xpdf.desktop
...copying icons files to /opt/QtPalmtop/pics144
...copying abiword.png to /opt/QtPalmtop/pics144/abiword.png
...copying dillo.png to /opt/QtPalmtop/pics144/dillo.png
...copying ethereal.png to /opt/QtPalmtop/pics144/ethereal.png
...copying firefox.png to /opt/QtPalmtop/pics144/firefox.png
...copying galculator.png to /opt/QtPalmtop/pics144/galculator.png
...copying gimp.png to /opt/QtPalmtop/pics144/gimp.png
...copying linux_debian.png to /opt/QtPalmtop/pics144/linux_debian.png
...copying minimo.png to /opt/QtPalmtop/pics144/minimo.png
...copying openoffice.png to /opt/QtPalmtop/pics144/openoffice.png
...copying scite.png to /opt/QtPalmtop/pics144/scite.png
...copying stardict.png to /opt/QtPalmtop/pics144/stardict.png
...copying sylpheed.png to /opt/QtPalmtop/pics144/sylpheed.png
...copying thunderbird.png to /opt/QtPalmtop/pics144/thunderbird.png
...copying xarchiver.png to /opt/QtPalmtop/pics144/xarchiver.png
...copying xchat.png to /opt/QtPalmtop/pics144/xchat.png
...copying xpdf.png to /opt/QtPalmtop/pics144/xpdf.png
...linking files to /opt/QtPalmtop/bin
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/share
...copying config files to /etc/gconf
...copying config files to /etc/gimp
...copying 2.0 to /etc/gimp/2.0
...copying config files to /etc/tuxpaint
...copying tuxpaint.conf to /etc/tuxpaint/tuxpaint.conf
...linking X server and config
...copying user config files to /home/zaurus
...copying .dillo to /home/zaurus/.dillo
...copying .gimp-2.3 to /home/zaurus/.gimp-2.3
...copying .xmms to /home/zaurus/.xmms
...copying .xpdfrc to /home/zaurus/.xpdfrc
...loading libraries
...generating config files
pdaXqtApps configured.
...checking for zgcc2-95-2.cramfs
zgcc2-95-2.cramfs not found.
...installing zgcc2-95-2 to /hdd3
Warning: ambiguous entry for zgcc2-95-2.squashfs found in /etc/fstab
X/Qt installed and configured (if found).
# xlauncher pdaxrom
error: please su with - or run as zaurus user
# exit
bash-2.05$ xlauncher pdaxrom
warning: sudo not found!
enabling swap /hdd3/swapfile
swapon: swapon: Operation not permitted
starting X and pdaxrom - please wait a moment...
bash-2.05$      


Any suggestions???

Thanks,

Mark

QUOTE(xamindar @ Apr 24 2006, 02:14 PM)
Hey ArchiMark, after you uninstalled the previous version did you remimber to remove the mounts from your fstab and reboot?
*
Go to the top of the page
 
+Quote Post
xamindar
post Apr 24 2006, 06:30 PM
Post #37





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Well, I installed the version of wget from your feed meanie (same version as the one I had) and it works now. Thanks!
Go to the top of the page
 
+Quote Post
Meanie
post Apr 24 2006, 07:34 PM
Post #38





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



well archimark, your installation looks ok.
the ambiguous entries in /etc/fstab could be a problem for automounter to correctly mount the squashfs images for you, but you can manually remount the images yourself after a reboot.
you probably have an older version of automounter which is not detected. try installing a newer version of automounter, ie 0.4.7
http://www.users.on.net/~hluc/myZaurus/stuff/
the cramfs warnings are ok because you are using the squashfs images instead.
the swap error is also ok. it just means the zaurus user could not enable swap for you because you dont have sudo installed. just enable swap manually yourself as root.

now the option pdaxrom doesn't exist, just xlauncher will do smile.gif

I will fix the installer script a bit to make it more obvious.
Go to the top of the page
 
+Quote Post
Cresho
post Apr 24 2006, 07:52 PM
Post #39





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



QUOTE(Meanie @ Apr 24 2006, 07:34 PM)
well archimark, your installation looks ok.
the ambiguous entries in /etc/fstab could be a problem for automounter to correctly mount the squashfs images for you, but  you can manually remount the images yourself after a reboot.
you probably have an older version of automounter which is not detected. try installing a newer version of automounter, ie 0.4.7
http://www.users.on.net/~hluc/myZaurus/stuff/
the cramfs warnings are ok because you are using the squashfs images instead.
the swap error is also ok. it just means the zaurus user could not enable swap for you because you dont have sudo installed. just enable swap manually yourself as root.

now the option pdaxrom doesn't exist, just xlauncher will do smile.gif

I will fix the installer script a bit to make it more obvious.
*



YEY! waiting for the next one.
Go to the top of the page
 
+Quote Post
Meanie
post Apr 24 2006, 08:48 PM
Post #40





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



pdaXqtrom install script fixed. try again and all should be fine now (hopefully)
sudo is only needed to enable the swap for you automatically so it is not really required. just enable swap yourself smile.gif
Go to the top of the page
 
+Quote Post
xamindar
post Apr 24 2006, 10:44 PM
Post #41





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Slightly off topic: When you enable swap, and use it heavily, does your wifi card ever get kind of stuck? For example, I can remove the card and the wifi applet will stay in the tray and the zaurus doesn't even know it was removed. I can put it back in and still no change, except the connection LED will stay on. In this state I am not able to connect or reset the card and I have to reboot to fix it. It only happens when I have swap enabled on the hard disk.

On topic: How do I go about adding gaim and grisbi to pdaxqtrom(the only two programs I want this for and they aren't there)? Is it the same way I did it on the previous one? I can't just install them because I only have 15MB of /home left.

EDIT:: i just tried ssh and got the same error that i got with wget. dang, any ideas? i dont have the room to reinstall all my console programs.
Go to the top of the page
 
+Quote Post
Meanie
post Apr 25 2006, 02:16 AM
Post #42





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(xamindar @ Apr 25 2006, 04:44 PM)
Slightly off topic:  When you enable swap, and use it heavily, does your wifi card ever get kind of stuck?  For example, I can remove the card and the wifi applet will stay in the tray and the zaurus doesn't even know it was removed.  I can put it back in and still no change, except the connection LED will stay on.  In this state I am not able to connect or reset the card and I have to reboot to fix it.  It only happens when I have swap enabled on the hard disk.

On topic:  How do I go about adding gaim and grisbi to pdaxqtrom(the only two programs I want this for and they aren't there)?  Is it the same way I did it on the previous one?  I can't just install them because I only have 15MB of /home left.

EDIT::  i just tried ssh and got the same error that i got with wget.  dang, any ideas?  i dont have the room to reinstall all my console programs.
*


well ok, just relink the libfloat.so.1 file from the rom image to /opt/QtPalmtop/lib/libfloat.so.1

eg on the c3100

CODE
ln -sf /usr/QtPalmtop.rom/lib/libfloat.so.1 /opt/QtPalmtop/lib/libfloat.so.1


please report all problems, even if you find a workaround so that it can be all included in the next update.

btw, gaim and grisbi were purposely left out because there are newer versions available which I was planning to compile, but I can put the older version on in the interim.

ok, i just did some investigation, all Cacko users will have the libfloat problem, while Sharp ROM users will be fine smile.gif
I will have to write something smart in the installer for the Cacko users to leave their libfloat alone....

This post has been edited by Meanie: Apr 25 2006, 02:29 AM
Go to the top of the page
 
+Quote Post
Cresho
post Apr 25 2006, 02:31 AM
Post #43





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



QUOTE(xamindar @ Apr 24 2006, 10:44 PM)
Slightly off topic:  When you enable swap, and use it heavily, does your wifi card ever get kind of stuck?  For example, I can remove the card and the wifi applet will stay in the tray and the zaurus doesn't even know it was removed.  I can put it back in and still no change, except the connection LED will stay on.  In this state I am not able to connect or reset the card and I have to reboot to fix it.  It only happens when I have swap enabled on the hard disk.

On topic:  How do I go about adding gaim and grisbi to pdaxqtrom(the only two programs I want this for and they aren't there)?  Is it the same way I did it on the previous one?  I can't just install them because I only have 15MB of /home left.

EDIT::  i just tried ssh and got the same error that i got with wget.  dang, any ideas?  i dont have the room to reinstall all my console programs.
*


eject the wifi from the icon at the taskbar. then pull wifi out.
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 25 2006, 07:23 AM
Post #44





Group: Members
Posts: 1,026
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Meanie, thanks for your help...

A. Automounter

Weird thing is that I checked and I had the latest version of your automounter installed. But just to make sure I uninstalled it and reinstalled it....

B. /etc/fstab

Deleted some entries in fstab before trying to install again.

C. pdaXqtrom Install

CODE
./pdaXqtrom-install.sh
X/Qt super jumbo installer - version 0.3.6.1
automounter is installed.
stopping loop devices...
old version of automounter detected, please update
The system has 7 loop devices.
There are 3 cramfs/squashfs images.
...purging /etc/X11
...checking for pdaXqtrom-base
...installing pdaXqtrom-base to /hdd3
Can't find /hdd3/pdaXqtrom-base.squashfs in /etc/fstab
...checking for pdaXqtrom-apps
...installing pdaXqtrom-apps to /hdd3
pdaXqtApps - beta 0.7.5
Installing pdaXqtApps on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying axyftp.desktop to /opt/QtPalmtop/apps/XQt/axyftp.desktop
...copying bluefish.desktop to /opt/QtPalmtop/apps/XQt/bluefish.desktop
...copying dia.desktop to /opt/QtPalmtop/apps/XQt/dia.desktop
...copying firefox.desktop to /opt/QtPalmtop/apps/XQt/firefox.desktop
...copying gnumeric.desktop to /opt/QtPalmtop/apps/XQt/gnumeric.desktop
...copying gqview.desktop to /opt/QtPalmtop/apps/XQt/gqview.desktop
...copying nedit.desktop to /opt/QtPalmtop/apps/XQt/nedit.desktop
...copying thunderbird.desktop to /opt/QtPalmtop/apps/XQt/thunderbird.desktop
...copying xmms.desktop to /opt/QtPalmtop/apps/XQt/xmms.desktop
...copying icons files to /opt/QtPalmtop/pics144
...copying axyftp.png to /opt/QtPalmtop/pics144/axyftp.png
...copying bluefish.png to /opt/QtPalmtop/pics144/bluefish.png
...copying bochs.png to /opt/QtPalmtop/pics144/bochs.png
...copying dia.png to /opt/QtPalmtop/pics144/dia.png
...copying firefox.png to /opt/QtPalmtop/pics144/firefox.png
...copying flfm.png to /opt/QtPalmtop/pics144/flfm.png
...copying fltdj.png to /opt/QtPalmtop/pics144/fltdj.png
...copying gnumeric.png to /opt/QtPalmtop/pics144/gnumeric.png
...copying gqview.png to /opt/QtPalmtop/pics144/gqview.png
...copying grisbi.png to /opt/QtPalmtop/pics144/grisbi.png
...copying nedit.png to /opt/QtPalmtop/pics144/nedit.png
...copying thunderbird.png to /opt/QtPalmtop/pics144/thunderbird.png
...copying vnc.png to /opt/QtPalmtop/pics144/vnc.png
...copying xmms.png to /opt/QtPalmtop/pics144/xmms.png
...linking files to /opt/QtPalmtop/bin
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/share
...copying config files to /etc/gconf
...copying config files to /etc/gimp
...copying config files to /etc/tuxpaint
...linking X server and config
/mnt/pdaXqtrom-apps/pdaXqtApps-setup: cannot create /etc/X11/defaultwm: directory nonexistent
...checking for zgcc2-95-2
...installing zgcc2-95-2 to /hdd3
configuring zgcc...
...zgcc is configured at /mnt/zgcc
...linking /mnt/zgcc/lib/libc.so.6 to /usr/lib/libc.so
...linking /mnt/zgcc/lib/libc_nonshared.a to /usr/lib/libc_nonshared.a
...linking /mnt/zgcc/lib/libopcodes-2.9.5.0.31.so to /opt/QtPalmtop/lib/libopcodes-2.9.5.0.31.so
...linking /mnt/zgcc/lib/libbfd-2.9.5.0.31.so to /opt/QtPalmtop/lib/libbfd-2.9.5.0.31.so
...linking /mnt/zgcc/include/Qtopia to /opt/QtPalmtop/include
...linking /mnt/zgcc/include/Qtopia to /opt/QtPalmtop/sharp/include
...linking /mnt/zgcc/bin/moc to /opt/QtPalmtop/bin/moc
...linking /mnt/zgcc/bin/uic to /opt/QtPalmtop/bin/uic
...linking /mnt/zgcc/perl/bin/perl to /usr/bin/perl
...linking /mnt/zgcc/perl/bin/perl to /usr/local/bin/perl
...linking /mnt/zgcc/perl/bin/find2perl to /usr/bin/find2perl
...linking /mnt/zgcc/perl/bin/perl-5.6 to /usr/bin/perl-5.6
...linking /mnt/zgcc/perl/bin/perl5.6.1 to /usr/bin/perl5.6.1
...linking /mnt/zgcc/perl/bin/perlbug to /usr/bin/perlbug
...linking /mnt/zgcc/perl/bin/perlcc to /usr/bin/perlcc
...linking /mnt/zgcc/perl/bin/perldoc to /usr/bin/perldoc
...linking /mnt/zgcc/perl/bin/pl2pm to /usr/bin/pl2pm
...linking /mnt/zgcc/perl/bin/pod2html to /usr/bin/pod2html
...linking /mnt/zgcc/perl/bin/pod2latex to /usr/bin/pod2latex
...linking /mnt/zgcc/perl/bin/pod2text to /usr/bin/pod2text
...linking /mnt/zgcc/perl/bin/pod2usage to /usr/bin/pod2usage
...linking /mnt/zgcc/perl/bin/podchecker to /usr/bin/podchecker
...linking /mnt/zgcc/perl/bin/podselect to /usr/bin/podselect
...linking /mnt/zgcc/perl/bin/pstruct to /usr/bin/pstruct
...linking /mnt/zgcc/perl/bin/rename to /usr/bin/rename
...linking /mnt/zgcc/perl/bin/s2p to /usr/bin/s2p
...linking /mnt/zgcc/perl/bin/splain to /usr/bin/splain
...linking /mnt/zgcc/perl/bin/xmlcatalog to /usr/bin/xmlcatalog
...linking /mnt/zgcc/perl/bin/xmllint to /usr/bin/xmllint
...linking /mnt/zgcc/perl/lib/libperl.so.5.6 to /usr/lib/libperl.so.5.6
...linking /mnt/zgcc/perl/lib/libperl.so.5.6.1 to /usr/lib/libperl.so.5.6.1
...linking /mnt/zgcc/perl/lib/libxmlparse.so to /usr/lib/libxmlparse.so
...linking /mnt/zgcc/perl/lib/perl to /usr/lib/perl
...linking /mnt/zgcc/perl/lib/perl to /usr/local/lib/perl
...linking /mnt/zgcc/perl/local/site_perl to /usr/local/lib/site_perl
...linking /mnt/zgcc/perl/share/perl to /usr/share/perl
...linking /mnt/zgcc/perl/share/perl to /usr/local/share/perl

X/Qt installed and configured (if found).
use xlauncher or the StartX icon to start it.

# xlauncher
xlauncher: not found


When I tried installing by tapping on the 'StartX' icon I got the error message:

"Unable to find this application 'startx-wrapper'. Please confirm the installed media."

I do see that there's still error messages shown during install process....

Any suggestions??

blink.gif

Thanks,

Mark



QUOTE(Meanie @ Apr 24 2006, 08:34 PM)
well archimark, your installation looks ok.
the ambiguous entries in /etc/fstab could be a problem for automounter to correctly mount the squashfs images for you, but  you can manually remount the images yourself after a reboot.
you probably have an older version of automounter which is not detected. try installing a newer version of automounter, ie 0.4.7
http://www.users.on.net/~hluc/myZaurus/stuff/
the cramfs warnings are ok because you are using the squashfs images instead.
the swap error is also ok. it just means the zaurus user could not enable swap for you because you dont have sudo installed. just enable swap manually yourself as root.

now the option pdaxrom doesn't exist, just xlauncher will do smile.gif

I will fix the installer script a bit to make it more obvious.
*
Go to the top of the page
 
+Quote Post
Meanie
post Apr 25 2006, 02:14 PM
Post #45





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



it seems like pdaXqtrom-base didn't get setup this time sad.gif
did it get mounted? can you manually run pdaXqtrom-base-setup?
Go to the top of the page
 
+Quote Post

9 Pages V  < 1 2 3 4 5 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th November 2014 - 11:26 AM