OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Gnomesword Errors, won't load after install
alee16
post Dec 30 2006, 09:24 AM
Post #1





Group: Members
Posts: 113
Joined: 30-May 06
Member No.: 10,009



It displays:
gnomesword2: error while loading shared libraries: libdbus-1.so.3: cannot open shared object file: No such file or directory

Does anyone know what is missing?

I have libdbus installed. If anyone knows where the package that's missing is, please let me know.

Thanks
Go to the top of the page
 
+Quote Post
Antikx
post Dec 30 2006, 10:39 AM
Post #2





Group: Members
Posts: 1,156
Joined: 5-January 05
From: Winnipeg, Manitoba
Member No.: 6,127



Do an:
CODE
ls -la

in your /lib directory
it might have a slightly different name. if so, then you can try making a symlink.

Hope that helps.

QUOTE(alee16 @ Dec 30 2006, 11:24 AM)
It displays:
gnomesword2: error while loading shared libraries: libdbus-1.so.3: cannot open shared object file: No such file or directory

Does anyone know what is missing?

I have libdbus installed.  If anyone knows where the package that's missing is, please let me know.

Thanks
*
Go to the top of the page
 
+Quote Post
alee16
post Dec 30 2006, 07:35 PM
Post #3





Group: Members
Posts: 113
Joined: 30-May 06
Member No.: 10,009



QUOTE(Antikx @ Dec 30 2006, 02:39 PM)
Do an:
CODE
ls -la

in your /lib directory
it might have a slightly different name. if so, then you can try making a symlink.

Hope that helps.

QUOTE(alee16 @ Dec 30 2006, 11:24 AM)
It displays:
gnomesword2: error while loading shared libraries: libdbus-1.so.3: cannot open shared object file: No such file or directory

Does anyone know what is missing?

I have libdbus installed.  If anyone knows where the package that's missing is, please let me know.

Thanks
*

*




The missing file isn't in the /lib directory. I tried the ls -la, but it didn't help. Thanks for the suggestion, though. Any other ideas?

Edit: I found a file in /usr/lib called libdbus-glib-1.so.2 and symbolicly linked it to the missing file. Gnomesword then attempts a start, crashing with the message:
gtkhtml-ERROR **: gconf error: No D-BUS daemon running
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th November 2014 - 09:12 PM