OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> USB lockups when using Zaurus?
ganoe
post May 20 2004, 08:55 AM
Post #1





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



I seem to have fairly consistent problems with the USB locking up on my Mac. It used to happen infrequently on my Mac no matter what I had plugged in (usually coming out of suspend/sleep on the Mac), but the Mac OS X 10.3.3 update seemed to fix that. Now, it only seems to happen when I have my Zaurus plugged into it.

I'm using the driver here:
http://www.lucid-cake.net/osx_zaurus_usb/index_en.html

Has anyone else experienced this?

If there was even just a simple way to reset the USB bus when it happened, I wouldn't mind that much, but it's not. I'll plug and unplug cables, kill the power for and repower my hub, etc. Eventually, meaning after about an hour, it usually comes back.
Go to the top of the page
 
+Quote Post
ganoe
post May 20 2004, 09:04 AM
Post #2





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



Oh, and I am AFAIK using the 0.2.5 version of the driver.
Go to the top of the page
 
+Quote Post
freizugheit
post May 22 2004, 09:30 AM
Post #3





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



I have been using the USB driver for the past 1 year.
It might be due to weak USB port. Are you using a USB hub? I do not have problem with the docing station via a USB hub.
Go to the top of the page
 
+Quote Post
dhns
post May 23 2004, 04:56 AM
Post #4





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



I also experience that issue - using an USB docking station and a Powerbook. It appears if either the Mac or the Zaurus goes to sleep. After awaking the USB connection might be lost. Usually, undocking and redocking the Zaurus and somethimes switching Airport off&on again reestablishes the connections. Sometimes (especially if both are sent to sleep the same time) everything is ok after awaking.

When looking into the network configs, it seems not to be the USB driver itself but the TCP/IP mapping over USB which seems to get lost.

I have informed Andreas Junghans about that.

And just once I had a "Kernel Panic" while undocking the Zaurus during a game running under Classic emulation.

So I assume there is still a subtle bug in the driver.

-- hns
Go to the top of the page
 
+Quote Post
ganoe
post May 25 2004, 03:45 PM
Post #5





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



Well, everything on my USB bus locks up. I'm not sure if that was what you were experiencing. I haven't had a lot of time to look into it, but after some conversation with the author and looking at the system logs, I'm wondering if it has something to do with my Cisco VPN client (that I use for wireless) latching onto the network adapter for my Zaurus. It seems to want to attach itself all my network interfaces when they come up/down.
Go to the top of the page
 
+Quote Post
ganoe
post May 26 2004, 11:03 AM
Post #6





Group: Members
Posts: 65
Joined: 31-January 04
Member No.: 1,607



Did it again today. This time I turned my Zaurus off while attached and now I'm mouse-less for a while. sad.gif

Is there a specific procedure I should be following to turn my Zaurus on/off while attached to my Mac to prevent this? Is there any way for me to manually reset the USB bus on the Mac without rebooting?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st September 2014 - 01:05 PM