OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> libSDL apps, tried but there are problems, Tag you application on here
iamasmith
post Oct 6 2004, 12:46 PM
Post #1





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Hi, thought I should start this thread after compiling supertux and finding that it's way too heavy on both memory and processor to run on Qtopia.

I'm suggesting that you tag your apps on here that you have already tried and had problems with. Maybe if it's not a critical lack of power type issue then someone can help out.

Actually if we could get this pinned then we could use it as a reference to what's been tried and doesn't work... I'm sure someone has tried supertux before !

So, next posting starts the thread...
Go to the top of the page
 
+Quote Post
iamasmith
post Oct 6 2004, 12:48 PM
Post #2





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Supertux, compiled on desktop, tested with zports libSDL and libSDL_mixer + gnurou libSDL_image.

Starts, seems to run but basically locks up the whole Z, very slow, very memory hungry. Almost immediately Qtopia pops up with a message saying that the application is running slowly and should it be killed.

Tested on SL-C860 with Cacko 1.21b
Go to the top of the page
 
+Quote Post
_Psycho
post Oct 7 2004, 04:17 AM
Post #3





Group: Members
Posts: 114
Joined: 7-December 03
Member No.: 1,057



You probably have to force it to run in 320x240, i doubt anygame will run that smooth in 640x480 without any ati drivers optimisation. (that nobody have).

Especially if its a fast moving game smile.gif
Go to the top of the page
 
+Quote Post
Ashitaka
post Oct 10 2004, 05:25 PM
Post #4





Group: Members
Posts: 58
Joined: 7-June 04
From: Tokyo
Member No.: 3,599



Right. I have a small and simple SDL demo, but it runs only between 5 and 10 fps on my 760, mostly because it is in 640x480 I guess...
Go to the top of the page
 
+Quote Post
dwagelaar
post Jan 13 2005, 12:09 PM
Post #5





Group: Members
Posts: 46
Joined: 26-July 04
From: Brussels, Belgium
Member No.: 4,106



QUOTE(iamasmith @ Oct 6 2004, 09:48 PM)
Supertux, compiled on desktop, tested with zports libSDL and libSDL_mixer + gnurou libSDL_image.

Starts, seems to run but basically locks up the whole Z, very slow, very memory hungry. Almost immediately Qtopia pops up with a message saying that the application is running slowly and should it be killed.

Tested on SL-C860 with Cacko 1.21b

There were several issues with SuperTux 0.1.2, which caused it not to run properly on a zaurus SL-C860. Most important was a memory leak in the lisp_reader and second was the fact that it used a lot of floating point arithmetic (ARM has not floating point unit). I managed to fix these issues and now have the game running at around 12 fps and 40 MB memory usage.

Check this mailing list archive and this post for more information.

Cheers,
Dennis

P.S. SuperTux only runs in 640x480, so no scaling down...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 01:56 AM