OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Compact Flash Card Applet, CF card Applet for the SL-C3n00
DaveL
post Nov 4 2010, 02:12 AM
Post #1





Group: Members
Posts: 13
Joined: 16-June 08
From: Wolverhampton, UK
Member No.: 21,925



Hi

Not sure whether anyone will be interested but I have written a CF card applet which is designed to replace the original Sharp cardmon and netmon applets.

It mounts data cards (obviously) but also controls serial (modem) cards.

It has 2 additional optional modules which allow SMS (texts) and Voice.

I am using it on a SL-C3100 running the Sharp ROM with an Audiovox RTM-8000 card, which is the only setup I have tested it on.

You can read more about it, starting at http://humbug.me.uk/zaurus/hbzcard.README.FIRST.htm

DaveL
Go to the top of the page
 
+Quote Post
rlubikey
post Nov 9 2010, 06:49 AM
Post #2





Group: Members
Posts: 10
Joined: 11-May 10
From: England
Member No.: 71,717



DaveL - very interested in this as I stopped using my RTM-8000 card due to the clunky mount/unmount of the Sharp applet - and card sticks out too far to be left in! Yes, I know your app's written around SL-C3100 but thought I'd give it a spin on my SL-C860 anyway. Here's what happened:-

Installs but gives a repeated error about (USB??? - not quick enough to read) - reboots as expected.

"L" in taskbar.

L becomes M as it recognises my CF memory (actually an Olympus XD adaptor) - Photo app. can see photos OK.

Doesn't seem to notice when my Trendnet Ethernet card is inserted. L remains L :(

Sees my Audiovox card and briefly shows M, followed by hourglass while amber LED flashes as it tries to ... (find network???) Problem could well be an expired/out-of-date SIM card or my laziness not setting up network in /etc/ppp/peers & options.

Uninstall gives possibly similar error as install but reboots fine. Cards recognised (did there used to be a memory icon? - can't remember)

Cheers anyway!

Richard
Go to the top of the page
 
+Quote Post
DaveL
post Nov 9 2010, 08:38 AM
Post #3





Group: Members
Posts: 13
Joined: 16-June 08
From: Wolverhampton, UK
Member No.: 21,925



Richard

Thanks very much for the update - I was hoping for some feedback.

On the SL-C3100, the install does not cause a reboot - just a reload of the applets?
If you could install manually and capture the stdout and stderr and send it me that would be good.
Or did you mean the messages are during reboot?

At least you got the "L" in taskbar - that's something. ;-)

Did you mean becomes D (not M) with the memory card? Data/memory cards should give D and prompt for a mount.

I had completely overlooked Ethernet cards. :-(
I am looking to add them, but unfortunately I do not have one to test it.

As for the Audiovox card, the /etc/ppp network does not matter at this point, and it is supposed to wait for a signal but time out after ~20 seconds and 'eject' the card if there isn't one (icon back to 'L'). I tried mine without a SIM card at all, and that's what happpened.

I don't believe install/uninstall should affect anything but netmon and cardmon (and those should be back as they were).

Would you be interested in having a version with debug logging and sending me the output - I might be able to sort something.
Fully understand if you do not want to spend time on this.

DaveL
Go to the top of the page
 
+Quote Post
rlubikey
post Nov 10 2010, 03:27 AM
Post #4





Group: Members
Posts: 10
Joined: 11-May 10
From: England
Member No.: 71,717



DaveL

Sorry, the one crucial piece of information I missed is that I'm running Cacko 1.23 but I had assumed it would be similar enough to Sharp that it was worth a go.

Install stdout and stderr capture (had to learn how to do this!!!):-
CODE
Unpacking hbzcard...Done.
Configuring hbzcard...Display size = 480x640
Done.


Similarly, uninstall:-
CODE
ipkg_remove: Removing hbzcard...
Display size = 480x640
Done.


So the screen full of repeated output must be to do with reboot. Just looked again and it's a screen full of modprobes then a line or 2 or 3 of something different at the bottom. Interestingly, ipkg remove *doesn't* force a reboot (although the centre of screen cursor briefly appears) whereas "Remove Software" program still does (similar screenful of modprobes, etc.)

Yes, my memory card gives D, not M - poor short-term memory - also can't remember if Cacko gave a taskbar icon for inserted cards. They seem to mount automatically.

I'm happy to try a debug version and send you the output. Please don't feel obliged if you don't want to open a new can of Cacko-flavoured worms!!!! But if you do, put a "secret" file on your web site and PM the location to me.

Cheers,

Richard
Go to the top of the page
 
+Quote Post
DaveL
post Dec 29 2010, 05:31 AM
Post #5





Group: Members
Posts: 13
Joined: 16-June 08
From: Wolverhampton, UK
Member No.: 21,925



There is now a version 2 of this applet which supports the Sharp Network services. Consequently it now does support Ethernet-type cards and services. Also you do not need to set up a dialup PPP service manually (I just prefer to). It has been tested on the SL-C3100 (Borzoi), mainly running the Sharp ROM, and to a lesser extent using Cacko. The cards used for testing (apart from normal data/memory CF cards) were an Audiovox RTM-8000(P) GSM/GPRS modem, a TRENDnet TE-CF100 Fast Ethernet Adaptor, a Netgear MA701 802.11b Wireless, and a "Blue Monkey" Bluetooth.

The original link to read more about is still valid.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 04:48 AM