OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Fedora Core 3 And Usb Networking, Need hotplug and masquerading help
fir
post Dec 7 2004, 05:27 AM
Post #1





Group: Members
Posts: 32
Joined: 20-November 04
Member No.: 5,540



I'm tryiong to get a C860 w/Cacko networked via my Fedora Core three box. The good news is that USB networking is enabled by default. If I plug in the Z, ifup the interface, and add a route, then I have connectivity between the two machines.

I'd like to have hotplug bring up the interface and add the route automatically. I've googled for instructions, and found some, but I haven't fouind any that work with FC3. Simply adding a /etc/hotplug/usbdnet file doesn't do anything - it is ignored.

Likewise the iptables scripts I have seen to enable masquerading for the Z have not worked for me. The one I tried actually stopped my FC3 box from communicating with anything.

Any help with either of the above issues will be gratefully received.

Frank.
Go to the top of the page
 
+Quote Post
nberger
post Dec 7 2004, 11:23 AM
Post #2





Group: Members
Posts: 4
Joined: 6-December 04
Member No.: 5,804



In FC3 for some reason the name of the USB module is 'usbnet', not 'usbdnet', so you should change the name of your script to 'usbnet' . Also make sure the script is executable by everybody. (chmod a+x usbnet). It's working for me with this setup so let me know if it doesn't...

Cheers,
- Nicolas
Go to the top of the page
 
+Quote Post
raybert
post Dec 7 2004, 01:54 PM
Post #3





Group: Members
Posts: 233
Joined: 2-December 03
From: Boston, MA
Member No.: 1,029



I just upgraded to FC3 from RH9. I didn't need to change anything, my Z (C860) continued working just as before.

To get my C860 working on RH9 I had to do the following:
  • Patch the kernel: I had to patch the module usbnet.c. It already had Zaurus support built in but it didn't recognize the C860's product ID. I believe the new kernel already has this support.
  • Blacklist CDCEther by adding CDCEther to the end of /etc/hotplug/blacklist. (I also added acm to the blacklist, but I don't think it was really necessary.)
  • Create a networking script in /etc/sysconfig/network-scripts called ifcfg-usb0. The contents were:
CODE
DEVICE=usb0
IPADDR=192.168.22.1
NETMASK=255.255.255.0
NETWORK=192.168.22.0
BROADCAST=192.168.22.255
BOOTPROTO=static
NOZEROCONF=yes

(Note that the 22's should be changed to match your Z's address.)

I *think* that's all I did. When I plug my Z in it is automatically set-up and I can immediately get to it via the network.

Good luck.

~ray
Go to the top of the page
 
+Quote Post
pjf02536
post Dec 7 2004, 05:45 PM
Post #4





Group: Members
Posts: 1
Joined: 24-March 04
Member No.: 2,482



ON FC3 all I needed to do was blacklist the CDCEther then bring up usbnet

rmmod CDCEther
( acm not needed to be blacklisted, as My cell phone needs this )
modprobe usbnet

then pop in the Z .....

-Pete F
Go to the top of the page
 
+Quote Post
fir
post Dec 8 2004, 05:28 AM
Post #5





Group: Members
Posts: 32
Joined: 20-November 04
Member No.: 5,540



Thanks everyone! I now have the hotplug working so I can just plug in the Z and be connected. Great. smile.gif

I'm still in the dark about getting the FC3 box to route for the zaurus, so that it has connectivity to more than just the host. Any tips there?

Frank.
Go to the top of the page
 
+Quote Post
otzenpunk
post Dec 13 2004, 09:36 AM
Post #6





Group: Members
Posts: 8
Joined: 22-October 04
Member No.: 5,157



Don't know anything about your network situation, but maybe your workstation, where you plug your zaurus into, is itself behind a router, so you have to add another route on the router?

For example you have the following configuration:
Inet <--> Router (192.168.1.1) <--> (192.168.1.2) Workstation (192.168.129.1) <--> (192.168.129.201) Zaurus

Then you have to add the following route on the router (linux syntax):
route add -net 192.168.129.0 netmask 255.255.255.0 gw 192.168.1.2

The gateway of your Zaurus stays as is. (Should be 192.168.129.1, in the example.)

Additionally, you don't need any masquerading on your workstation, if your router already does the masquerading.
Go to the top of the page
 
+Quote Post
otzenpunk
post Dec 13 2004, 10:25 AM
Post #7





Group: Members
Posts: 8
Joined: 22-October 04
Member No.: 5,157



Just forgot:

Of course you have to turn IP forwarding on on your workstation, like this:
echo 1 > /proc/sys/net/ipv4/ip_forward
Go to the top of the page
 
+Quote Post
fir
post Dec 13 2004, 10:29 AM
Post #8





Group: Members
Posts: 32
Joined: 20-November 04
Member No.: 5,540



Yes, that would work where I have control of the router, however I am often in environments where I do not. I'm sure I can figure out the masquerading when I find the time to sit down and read about it and play a little. I probably would have done that this past weekend if I hadn't run into trouble installing Fedora Core 3 on a couple machines with Adaptec 2410SA SATA RAID controllers. Worked before, doesn't work now; very frustrating (but not on topic here).

Frank.
Go to the top of the page
 
+Quote Post
otzenpunk
post Dec 13 2004, 05:37 PM
Post #9





Group: Members
Posts: 8
Joined: 22-October 04
Member No.: 5,157



Good luck.
I hope you already know this?
Go to the top of the page
 
+Quote Post
fir
post Dec 14 2004, 04:59 AM
Post #10





Group: Members
Posts: 32
Joined: 20-November 04
Member No.: 5,540



QUOTE(otzenpunk @ Dec 14 2004, 01:37 AM)
Good luck.
I hope you already know this?

One of the things I need to figure out is where things have changed. The scripts I have found in various HOWTO documents for the Zaurus to enable NAT have only runied connectivity for the host. I am guessing this is because they were written for something a little earlier than I am using (Fedora Core 3, Kernel 2.6.9)

Frank
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 05:09 PM