OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Mounting Zaurus On Linux Using Smbmount
jeffbarish
post Mar 19 2005, 08:30 AM
Post #1





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



I would like to mount my Zaurus on my linux desktop. I use the command

mount -t smbfs //192.168.129.201/home/zaurus /mnt/zaurus

and get the message

Error connecting to 192.168.129.201 (Connection refused)
6225: Connection to 192.168.129.201 failed
SMB connection failed

I suspect that I have to modify a file on the Zaurus identifying my linux desktop so that the smb server knows to permit the mount, but I can't find such a file. I found /home/root/usr/lib/samba/smb.conf, but I don't see anything relevant in there.
Go to the top of the page
 
+Quote Post
craigtyson
post Mar 19 2005, 10:09 AM
Post #2





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



I get this same when doing this not logged in as root.

Use SU first and see what happens

Also what ROM and interface are you using?
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 19 2005, 10:25 AM
Post #3





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



I was logged in as root.

I am using the standard Sharp ROM. I am connecting over usbnet.

I just tried

mount -t smbfs //192.168.129.201/home/zaurus /mnt/zaurus -o username=root

That command produces

Anonymous login successful
6780: tree connect failed: ERRSRV - ERRinvnetname (Invalid network name in tree connect.)
SMB connection failed
Go to the top of the page
 
+Quote Post
craigtyson
post Mar 19 2005, 10:32 AM
Post #4





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



Can you dump your Zs SMB.CONF in the post. also your Zs /etc/inetd.conf

Might just be a line in either needs un-reming.
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 19 2005, 11:42 AM
Post #5





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



Both files are in their default state. Here is smb.conf:

[global]
# workgroup is either a domain name or a workgroup name
workgroup = WORKGROUP
log file = /dev/null
#
# encrypt passwords is required for Win98, NT and Windows 2000
#
encrypt passwords = yes

coding system = utf8
client code page = 932
force create mode = 0755
strict sync = yes
sync always = yes

interfaces = usbd0
# wins support = yes
bind interfaces only = yes
[system]
comment = System Folder
path = /root/samba
read only = no
browseable = no
guest ok = yes
force user = root
[home]
comment = for User Data
path = /home/samba
short preserve case = no
read only = no
guest ok = yes
force user = zaurus

And here is inetd.conf:

#
# inetd.conf This file describes the services that will be available
# through the INETD TCP/IP super server. To re-configure
# the running INETD process, edit this file, then send the
# INETD process a SIGHUP signal.
#
# Version: @(#)/etc/inetd.conf 3.10 05/27/93
#
# Authors: Original taken from BSD UNIX 4.3/TAHOE.
# Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
#
# Modified for Debian Linux by Ian A. Murdock <imurdock@shell.portal.com>
#
# Modified for RHS Linux by Marc Ewing <marc@redhat.com>
#
# Further modified by Olaf Kirch <okir@caldera.com> for Caldera Open Linux
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
# Echo, discard, daytime, and chargen are used primarily for testing.
#
# To re-read this file after changes, just do a 'killall -HUP inetd'
#
# Note: builtin UDP services now silently drop packets from ports < 512.
#echo stream tcp nowait root internal
#echo dgram udp wait root internal
#discard stream tcp nowait root internal
#discard dgram udp wait root internal
#daytime stream tcp nowait root internal
#daytime dgram udp wait root internal
#chargen stream tcp nowait root internal
#chargen dgram udp wait root internal
#time stream tcp nowait root internal
#time dgram udp wait root internal
#
# These are standard services.
#
### With tcpd (TCP Wrapper) ###
#ftp stream tcp nowait root /usr/sbin/tcpd in.ftpd -l -a
#telnet stream tcp nowait root /usr/sbin/tcpd in.telnetd
### Without tcpd (TCP Wrapper) ###
#ftp stream tcp nowait root /usr/sbin/in.ftpd -l -a
#telnet stream tcp nowait root /usr/sbin/in.telnetd

#
# Mail and news
#
# Do not uncomment either unless you *really* know what you are doing.
# Both are started as standalone daemons from the /etc/rc.d scripts.
#smtp stream tcp nowait root /usr/bin/smtpd smtpd
#nntp stream tcp nowait root /usr/sbin/tcpd in.nntpd

#
# Shell, login, exec and talk are BSD protocols.
#
#shell stream tcp nowait root /usr/sbin/tcpd in.rshd
#login stream tcp nowait root /usr/sbin/tcpd in.rlogind
#exec stream tcp nowait root /usr/sbin/tcpd in.rexecd
#talk dgram udp wait nobody.tty /usr/sbin/tcpd in.talkd
#ntalk dgram udp wait nobody.tty /usr/sbin/tcpd in.ntalkd
#dtalk stream tcp wait nobody.tty /usr/sbin/tcpd in.dtalkd

#
# Pop and imap mail services et al
#
#pop2 stream tcp nowait root /usr/sbin/tcpd ipop2d
#pop3 stream tcp nowait root /usr/sbin/tcpd ipop3d
#imap stream tcp nowait root /usr/sbin/tcpd imapd
#
# The Internet UUCP service.
#
#uucp stream tcp nowait uucp /usr/sbin/tcpd /usr/sbin/uucico -l
#
# Tftp service is provided primarily for booting. Most sites
# run this only on machines acting as "boot servers." Do not uncomment
# this unless you *need* it.
#
#tftp dgram udp wait root /usr/sbin/tcpd in.tftpd
#bootps dgram udp wait root /usr/sbin/tcpd bootpd
#
# This is for the finger service
#
#finger stream tcp nowait root /usr/sbin/tcpd in.fingerd
#
# Finger, systat and netstat give out user information which may be
# valuable to potential "system crackers." Many sites choose to disable
# some or all of these services to improve security.
#
#systat stream tcp nowait nobody /usr/sbin/tcpd /bin/ps -auwwx
#netstat stream tcp nowait nobody /usr/sbin/tcpd /bin/netstat --inet
#
# Authentication
#
#auth stream tcp nowait root /usr/sbin/tcpd in.identd
#
# End of inetd.conf
ftp stream tcp nowait root /usr/sbin/ftpd -a
Go to the top of the page
 
+Quote Post
craigtyson
post Mar 19 2005, 12:26 PM
Post #6





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



smb.conf looks more or less the same as mine although my inetd.conf has

# samba
netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
netbios-ns dgram udp wait root /usr/sbin/tcpd /usr/sbin/nmbd

in it which I thought was to allow windoze to connect but might also effect smb. Can you mount from the Z to you PC ?
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 19 2005, 12:44 PM
Post #7





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



Sticking those lines into my inetd.conf had no effect. I am not able to mount my desktop system on the Zaurus. In fact, I am not able even to ping the desktop system (network unreachable).
Go to the top of the page
 
+Quote Post
craigtyson
post Mar 19 2005, 12:50 PM
Post #8





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



Do you have any firewall services running on your PC ?
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 19 2005, 01:34 PM
Post #9





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



No.
Go to the top of the page
 
+Quote Post
craigtyson
post Mar 19 2005, 01:59 PM
Post #10





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



Can you ping your Z from the PC?
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 19 2005, 04:08 PM
Post #11





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



Yes. Also ftp and VNC.
Go to the top of the page
 
+Quote Post
Tehas
post Mar 20 2005, 07:25 AM
Post #12





Group: Members
Posts: 157
Joined: 6-November 03
From: Harrisburg PA
Member No.: 867



Check your log files in /var/smb to see if the messages help you.

I had a problem mounting my SL6000 to my XP box at work. The error that I was getting was that the name for my Zaurus' name in my /etc/hosts file. When browsing over USB, the XP box is 192.168.129.1 and the Zaurus is 92.168.129.201 so I had to add an entry in /etc/hosts to mapped the 201 IP to my Zaurus's name.
Go to the top of the page
 
+Quote Post
iamasmith
post Mar 20 2005, 08:01 AM
Post #13





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(craigtyson @ Mar 19 2005, 08:26 PM)
smb.conf looks more or less the same as mine although my inetd.conf has

# samba
netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
netbios-ns dgram udp wait root /usr/sbin/tcpd /usr/sbin/nmbd

in it which I thought was to allow windoze to connect but might also effect smb.  Can you mount from the Z to you PC ?
*


The seperation between the parameters on these lines MUST be via TAB and not whitespace.

You must then either reboot your Z or from su..

killall -HUP inetd

this causes the inetd superserver to reload the file.

If you find that inetd has completely stopped then it's probably due to a misformatting in the file. Check for TABS and not whitespace between the parameters.

PS I'm assuming that this is over a USB network. If not then you need to make sure the interface (on the Z) is listed on the interfaces line in /usr/lib/samba/smb.conf otherwise Samba will refuse the connection.

Oh yes and you can see the shares on the server prior to mounting with...

smbclient -L servername

- Andy
Go to the top of the page
 
+Quote Post
jeffbarish
post Mar 20 2005, 07:56 PM
Post #14





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



I may be confused in some cases about which platform your suggestions apply to. I checked /var/log/samba/log.smbd on the desktop system (the client) and /var/smb/log.smb on the Zaurus (the server). They are both empty. I already have an entry in /etc/hosts on the client for the Zaurus. It permits me to ping the Zaurus. I tried making an entry in /etc/hosts on the Zaurus for the client, but that change had no effect.

I tried entering the two lines about netbios-ssn and netbios-ns using tabs instead of whitespace. I then issued the killall command. I was still unable to mount the Zaurus. I tried running the smbclient command on the Zaurus (the server), but there is no smbclient command on the Zaurus. And yes, I am connecting over usbnet. I tried changing the line in smb.conf to "interfaces = usb0" (rather than usbd0), but that change had no effect. Yes, inetd is running.

The error message is back to connection refused even though I am still specifying root as the user.

I appreciate all the suggestions. I hope that there will be others as I am stymied.
Go to the top of the page
 
+Quote Post
iamasmith
post Mar 21 2005, 12:20 AM
Post #15





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(jeffbarish @ Mar 21 2005, 03:56 AM)
....
I tried entering the two lines about netbios-ssn and netbios-ns using tabs instead of whitespace.  I then issued the killall command.  I was still unable to mount the Zaurus.  I tried running the smbclient command on the Zaurus (the server), but there is no smbclient command on the Zaurus.  And yes, I am connecting over usbnet.  I tried changing the line in smb.conf to "interfaces = usb0" (rather than usbd0), but that change had no effect.  Yes, inetd is running.
....
*


OK firstly change the usb0 back to usbd0 that wasn't a typo as is important.

ps -ef | grep inetd

Does that acually return that inetd is running or just show the ps command?

If inetd is not running then there is still a formatting problem on the inetd.conf

smbclient -L is a Linux desktop command... try using that to list the shares on the Z.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th July 2014 - 10:40 PM