OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Some Problems With Beta3, xpdf, gemz, sonata
Sam Hell
post Apr 27 2007, 01:17 PM
Post #1





Group: Members
Posts: 68
Joined: 7-January 05
From: Germany, Fürstenwalde near Berlin
Member No.: 6,147



Hi there, i got everything running fine under pdaxrom Beta 3 on my C1000, only
a few things give me a headache.

1. xpdf (optimized version from the "new packages"-thread):
i cant use any of the shortcuts like "o" (for get the "Open File"-Window)
(so i cant use it)

in xterm he lists the following:
CODE
Error: No display font for ´Courier´
Error: No display font for...


where can i get all these lost display-fonts? is there a feed i missed?


2. gemz (from the "new packages"-thread):
if i try to start it, it closes immediately and says in xterm:
CODE
The font has not been loaded!


(i installed every font i could find in the beta3-feed (even the webfonts), still not functioning)

3. Sonata (from the "new packages"-thread):
i only got the following error-message:
CODE
Traceback (most recent call last):
 File "usr/bin/sonata", line 28, in ?
   import sonata
 File "usr/lib/phyton2.4/site-packages/sonata.py", line 32, in ?
   import urllib, urllib2
 File "usr/lib/phyton2.4/urllib2.py", line 90, in ?
Import Error: No module named base64




if you got some hints, anything would be fine smile.gif

Thx in advance, and gn8.
Nico
Go to the top of the page
 
+Quote Post
kkazakov13
post Apr 27 2007, 11:31 PM
Post #2





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



Well, for Sonata to work, you need to upgrade almost everything smile.gif besides this, I've just fixed sonata-python-modules to include base64 at least.

But you will need python-fcntl, python-crypto, pygtk, my gtk ( which i now recompile ), pycairo, my cairo, my pango, my freetype, my glib2, pygobject - all from my feed ( http://z.drun.net/packages/ ). Beware that my gtk is a bit broken currently.

Also I don't take responsibility if something does not work afterwards for you - you know - backup first smile.gif. I'm currently making an upgrade-all system for b3 ... which upgrades (hopefully without any problems afterwards) your beta3 with the latest core packages.
Go to the top of the page
 
+Quote Post
Sam Hell
post Apr 28 2007, 03:30 AM
Post #3





Group: Members
Posts: 68
Joined: 7-January 05
From: Germany, Fürstenwalde near Berlin
Member No.: 6,147



ok, thx for the fast answer!

i got all of the packages from your feed, except python-fcntl and pyhton-crypto, i
found them on another beta3-feed..


Since my Beta3 is pretty unstable anyway, i dont think i could broke
anything more, but thx for the warning. wink.gif

For an example, at my beta3 i can´t do a clean reboot without having the cf-card
taken out. If i forget it, i can´t mount the cf-card. (mount: special device /dev/hda1
does not exist)


I will try a new and clean install if i get anything running that i wanted to.
So far i just keep tracking every step including backing up every file i need.


EDIT: Ok, Sonata isnt running at last, so i deinstalled everything again and recover
with clean python & gtk-files. dateandtime.py etc are not starting anymore, so there
has to be an error somewhere, i hope i can overcome with the old gtk & phyton-files.
Anyway, xfce4 is now up and running. smile.gif

Edit2: i kept Sonata (hope dies last wink.gif ), and after a clean install of the last versions
of gtk, gtk2 and pygtk i have all system tools running again.
Now Sonata starts with only 1 (!) error-message, it says it requires "pygtk 2.6.0 or newer" to run. mmmhh... i think ill go outside, take a cup of coffee in the beautiful sunshine over Berlin City, and investigate this further... i need a mp3-player with albumcovers on my Z, thats why i dont give up on sonata i guess wink.gif
Go to the top of the page
 
+Quote Post
desertrat
post Apr 28 2007, 05:31 AM
Post #4





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



QUOTE(kkazakov13 @ Apr 28 2007, 07:31 AM)
I'm currently making an upgrade-all system for b3 ... which upgrades (hopefully without any problems afterwards) your beta3 with the latest core packages.
Are you planning on working with Meanie and friends to make a unified update to beta3? It would make sense to pool together the various efforts - if you're already doing so then my apologies smile.gif
Go to the top of the page
 
+Quote Post
Sam Hell
post Apr 28 2007, 01:27 PM
Post #5





Group: Members
Posts: 68
Joined: 7-January 05
From: Germany, Fürstenwalde near Berlin
Member No.: 6,147



the problem with sonata is still there, i found out that if you use
xfce4 you get another one on top of that. wink.gif

So sonata-problem is paused for me until the release of the new files.
My skills in linux overall arent good enough to get the problems
solved by myself, sadly.


but now i found some new problems i investigate today/tonight: xfe and xffm
dont run under my xfce4-installation. xfe needs a "libFOX-1.4.so.0" i
cannot find in any feed, and xffm searches for the "libxfcegui4.so.3" i
didnt find either... sad.gif

Anyway, i have the whole sunday to get everything running, bit by bit. wink.gif

So Good Fight, good Night !
Go to the top of the page
 
+Quote Post
zeigerpuppy
post May 2 2007, 06:04 AM
Post #6





Group: Members
Posts: 109
Joined: 23-December 05
Member No.: 8,778



just a note, the sonata compatible gtk seems to break xpdf
Go to the top of the page
 
+Quote Post
Chero
post May 2 2007, 08:01 AM
Post #7





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



QUOTE(Sam Hell @ Apr 28 2007, 10:27 PM)
the problem with sonata is still there, i found out that if you use
xfce4 you get another one on top of that. wink.gif

So sonata-problem is paused for me until the release of the new files.
My skills in linux overall arent good enough to get the problems
solved by myself, sadly.


but now i found some new problems i investigate today/tonight: xfe and xffm
dont run under my xfce4-installation. xfe needs a "libFOX-1.4.so.0" i
cannot find in any feed, and xffm searches for the "libxfcegui4.so.3" i
didnt find either... sad.gif

Anyway, i have the whole sunday to get everything running, bit by bit. wink.gif

So Good Fight, good Night !
*


About xfce4 : try packages over here : http://wasp.drun.net/zaurus/xfce-4.4/
(it's not a feed, download and install them)

xfe has no relation to xfce. You need to look for "fox" or "libfox" - xfe has a dedicated thread as well as an announcement in the announcement thread. Anyway, who needs xfe when you have thunar running in xfce ?? wink.gif
xffm is the "old" xfce4 filemanager, it runs slow on the Z. I'm not sure there is still an ipk with libxfcegui4.so.3 floating around. I guess your best bet is to check which libxfcegui4.so.x you have in /usr/lib (probably libxfcegui4.so.4.1.0) and then to "ln -s libxfcegui4.so.4.1.0 libxfcegui4.so.3". You could also stick to thunar instead.

Chero.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 04:11 PM