OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Zaurus "Computer Name"
dougeeebear
post Aug 11 2004, 05:08 AM
Post #1





Group: Members
Posts: 551
Joined: 8-July 04
From: Mid-South, USA
Member No.: 3,959



I have a laptop with wi-fi access to my wireless router. I gave it a computer name of "Doug" so I would know if any one else gains access to my wireless system.

My SL-5500 also has a wi-fi card installed, but the only thing I can get to show up on my router is "unknown" when I access it from my Zaurus.

I have tried everything I can think of to change the computer name of my zaurus, but all I get is "unknown".

I would really like to name my zaurus so I have a good handle on access to my router.

Any help on this would be greatly appreciated.

Thanks, Doug
Go to the top of the page
 
+Quote Post
CoreDump
post Aug 11 2004, 11:27 AM
Post #2





Group: Members
Posts: 715
Joined: 25-July 04
From: .de
Member No.: 4,094



OZ 3.2 and earlier didn't send the hostname while asking for an IP via DHCP.

Does

killall udhcpc ; udhcpc -i wlan0 -h openzaurus

work for you?
Go to the top of the page
 
+Quote Post
dougeeebear
post Aug 11 2004, 01:28 PM
Post #3





Group: Members
Posts: 551
Joined: 8-July 04
From: Mid-South, USA
Member No.: 3,959



No, that did not work. I tried it and rec'd the following message:

killall: udhcpc: no process killed
bash: udhcpc: command not found

I don't have openzaurus, I am running sharp standard rom 3.13 on SL-5500

Sorry, I should have specified what I am running.

Thanks, Doug
Go to the top of the page
 
+Quote Post
doseas
post Aug 11 2004, 02:05 PM
Post #4





Group: Members
Posts: 207
Joined: 7-July 03
From: Thousand Oaks, CA
Member No.: 9



QUOTE(dougeeebear @ Aug 11 2004, 06:08 AM)
I have a laptop with wi-fi access to my wireless router. I gave it a computer name of "Doug" so I would know if any one else gains access to my wireless system.

My SL-5500 also has a wi-fi card installed, but the only thing I can get to show up on my router is "unknown" when I access it from my Zaurus.

I have tried everything I can think of to change the computer name of my zaurus, but all I get is "unknown".

I would really like to name my zaurus so I have a good handle on access to my router.

I'm not sure if this will resolve the issue on your router or not. However, if you want the name of your Zaurus to show up on your PC, you need to add it to the hosts file, which is in C:\WINNT\system32\drivers\etc\hosts on Windows. For example, the line in my hosts file looks like:
192.168.129.201 zaurus

To give a name to the Zaurus, you use the "hostname" command like this:
/bin/hostname zaurus

However, that association doesn't survive reboots. To make the hostname assignment permanent, I added the above line to my /etc/rc.d/rc.local file, so it gets executed shortly after booting.

Aside: the best way to prevent other people from getting access to your router is to turn on MAC address control. That way, only WiFi cards that you specify can associate with your router.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 10th July 2014 - 07:20 AM