OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Opie-feed Gcc Compile Woes!, Help needed to set variables to compile.
snowfarthing
post Jun 19 2006, 11:33 AM
Post #1





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



I'm currently trying to compile teTeX on my 5500 Zaurus (with OpenZaurus 3.5.4 installed) using the gcc files available from the Opie feed: g++ 3.4.4-r5, g++-sympinks, g++-rc 0.1.9-r1, g77 and etc, gcc and etc, and gcov. I've followed everything according to the teTeX INSTALL instructions, and when I try compiling, I get:

CODE
loading cache ./config.cache
checking whether make sets ${MAKE}... no
checking for gcc... arm-linux-gcc                                        # or whatever I set CC to be
checking whether the C compiler (arm-linux-gcc -O -g) works... no
configure:  error:  installation or configuration problem:  C compiler cannot create executables.

I've tried setting CC to gcc, cc, arm-linux-gcc, and g++, and I get the same results every time.

When I tried an even more basic program, hello.cpp, I received the following:

CODE
root@collie:  /media/card/.../tetex-src-3.0 # gcc -O -g hello.cpp
hello.cpp: 1: 22: iostream.h:  No such file or directory
hello.cpp:  In function `int main()':
hello.cpp:  5:  error: `cout' undeclared (first use of this function)
hello.cpp:  5:  error:  (Each undeclared identifier is reported only once for each function it appears in.)
hello.cpp:  8:  2:  no newline at end of file

Since I get similar results when I try to compile hello.c, I'm certain that I need to set variables for certain paths; unfortunately, I have no idea what those varialbes would be, or what paths I need to set! What do I need to do in order to compile things successfully?
Go to the top of the page
 
+Quote Post
koen
post Jun 19 2006, 12:00 PM
Post #2





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(snowfarthing @ Jun 19 2006, 07:33 PM)
CODE
hello.cpp: 1: 22: iostream.h:  No such file or directory

*


You need to install the -dev package that has iostream.h
Go to the top of the page
 
+Quote Post
snowfarthing
post Jun 20 2006, 06:32 AM
Post #3





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



This will certainly help! I've already begun looking for the correct file, except that there are a lot of *-dev files.

Is there any way to figure out which file should have the headers I'm looking for?
Go to the top of the page
 
+Quote Post
pgas
post Jun 20 2006, 06:41 AM
Post #4





Group: Members
Posts: 1,099
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



I guess the minimum would be:
libc6-dev
and
binutils (and binutils-symlinks )
Go to the top of the page
 
+Quote Post
snowfarthing
post Jun 21 2006, 05:54 AM
Post #5





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



I appreciate the information. Unfortunately, I haven't been able to download the things, since I can't network my Zaurus, and I can't manually download anything while EWI is down. Arrrgh!

I hope I can attempt these soon.
Go to the top of the page
 
+Quote Post
asm-nai
post Jun 21 2006, 06:32 AM
Post #6





Group: Members
Posts: 29
Joined: 30-June 05
Member No.: 7,497



QUOTE(snowfarthing @ Jun 21 2006, 10:54 PM)
I appreciate the information.  Unfortunately, I haven't been able to download the things, since I can't network my Zaurus, and I can't manually download anything while EWI is down.  Arrrgh!

I hope I can attempt these soon.
*


my feed

There might be insufficient ipk.
Go to the top of the page
 
+Quote Post
snowfarthing
post Jun 22 2006, 05:40 PM
Post #7





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



Unfortunately, they don't work, since they use armv5 format. I've been using the regular format (which, as far as I've been able to discern, is armv4, but that's almost an unspoken discussion). I don't know why there's a difference, but when I've noticed the two, I always went with the "regular" files, and they've worked just fine on my SL5500 Zaurus.

I've had a difficult time finding out the difference between the two; I have the impression it's either a hardware difference (5x00 etc vs 3x00, maybe) or just a new way to compile things. Perhaps I'll start a new thread on it someday. In the meantime, I'm still stuck waiting for Ewi to get back online!
Go to the top of the page
 
+Quote Post
Hrw
post Jun 23 2006, 01:24 AM
Post #8





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



pxa2xx machines are arm5, sa11xx are arm4. arm5 machines can run arm4 code but not vice versa.

thats why OZ feeds are built as "arm"
Go to the top of the page
 
+Quote Post
Meanie
post Jun 23 2006, 02:44 AM
Post #9





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Hrw @ Jun 23 2006, 07:24 PM)
pxa2xx machines are arm5, sa11xx are arm4. arm5 machines can run arm4 code but not vice versa.

thats why OZ feeds are built as "arm"
*


so if I want my apps to run really really fast, then I will have to rebuild the whole feed for arm5 with xscale and immxt optimisation enabled right? how long does it take roughly to build the whole feed with say a PII with 512MB RAM (provided I manage to find a spare box and install linux plus OE on it)?
Go to the top of the page
 
+Quote Post
Hrw
post Jun 23 2006, 04:08 AM
Post #10





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



3-4 weeks or more
Go to the top of the page
 
+Quote Post
Meanie
post Jun 23 2006, 04:31 AM
Post #11





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Hrw @ Jun 23 2006, 10:08 PM)
3-4 weeks or more
*


oh man, i better get a dual cpu amd64 then with 2GB ram....
Go to the top of the page
 
+Quote Post
Hrw
post Jun 23 2006, 05:52 AM
Post #12





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



Have spare one? biggrin.gif
Go to the top of the page
 
+Quote Post
Meanie
post Jun 23 2006, 07:29 AM
Post #13





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Hrw @ Jun 23 2006, 11:52 PM)
Have spare one? biggrin.gif
*


I'll see if my boss will buy me one first, then I will check about a spare smile.gif
Go to the top of the page
 
+Quote Post
snowfarthing
post Jun 28 2006, 05:51 PM
Post #14





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



Just yesterday I got a laptop (Pentium, 48 Meg, not much else) that I'd like to put DSL Linux on. I was unsuccessful because of floppy drive problems; nonetheless, I realized that I'd rather put Opie on it biggrin.gif

To get back on topic, I was finally able to download the above files and install them on my Zaurus. (The feed is finally working again! I really wish I could set up my Zaurus on a network; unfortunately that isn't an option for me right now sad.gif .) I'd like to note that libc6-dev needed the following dependencies:

linux-libc-headers-dev
glibc-extras-nss
libthread-db1
.

For good measure I also installed libsdtc++-dev.

Now hello.cpp gives a lot of errors when I try to compile! So many, I decided to attach them rather than list them here.

I wonder if I need more gcc options to get it to work. I haven't yet tried compiling anything, though, so I don't yet know if I have everything I need. (I think I will also need make).

Ironically, I discovered yesterday that tetex is in the feed. I'll be trying to download those and install them. Even so, I still would like to be able to compile things! In particular, I'd like to install Macaulay 2, and YACAS, and perhaps KSEG (except that KSEG relies too much on regular Qt).

(As you can probably guess, I'm a mathematician. Unfortunately for me, I'm a mathematician who thinks that a Zaurus with a Targus keyboard is the perfect size for a laptop, if only it could run everything.)
Go to the top of the page
 
+Quote Post
snowfarthing
post Jun 28 2006, 05:53 PM
Post #15





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



Oops! The attachment didn't stick. Here it is.
Attached File(s)
Attached File  hello.cpp_error.txt ( 76.21K ) Number of downloads: 56
 
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 06:23 PM