OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  « < 2 3 4  
Reply to this topicStart new topic
> Opera 7.55 Seg Fault, Seg fault when loading images.
kombi
post Sep 5 2005, 06:13 AM
Post #46





Group: Members
Posts: 6
Joined: 4-September 05
Member No.: 8,035



QUOTE(Greg2 @ Sep 5 2005, 05:37 AM)
QUOTE(kombi @ Sep 4 2005, 09:48 PM)
I installed opera into my SD card and got linking errors, but i get the same error while trying to run. I am new to installing OZ and maybe I am missing something.  How do I first fix the linking errors trying to install apps to my SD card.  And what would be the command for makecompat if I installed to my SD card? What does makecompat do anyway?

Have you formatted your SD-card with ext2 so you can install and symlink apps on it? If not please do... if you need any help the instructions are in the how-to section of OESF:
http://www.oesf.org/index.php?title=Step-b...ing_for_newbies

If your not using the Hentges Rom you will need to install the sharp-compat-libs_xxxx.ipk from the 3.5.3 opie feed then follow the instructions in this thread:
http://www.oesf.org/forums/index.php?showtopic=14311

The sharp-compat-libs will allow opera to be used with the current OZ builds. You can use them with the libraries icon in the settings tab or the makecompat command. For more info please search makecompat and compat-libs on the boards.

Greg
*




Thanks for the info. Now I have everything installed to run Opera and I linked it using the sharp libs but I am getting:

Opera 7.55 was terminated due to signal code SIGSEGV

Any ideas?
Go to the top of the page
 
+Quote Post
Greg2
post Sep 5 2005, 06:18 AM
Post #47





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(kombi @ Sep 5 2005, 10:13 AM)
Thanks for the info. Now I have everything installed to run Opera and I linked it using the sharp libs but I am getting:

Opera 7.55 was terminated due to signal code SIGSEGV

Any ideas?

Start it from the command line in your terminal and post the output.

Greg
Go to the top of the page
 
+Quote Post
kombi
post Sep 5 2005, 06:19 AM
Post #48





Group: Members
Posts: 6
Joined: 4-September 05
Member No.: 8,035



If i run from console I get:

opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
opera: Could not find "ini/standard_voice.ini"
opera: Could not find "ini/standard_mouse.ini"
opera: Could not find "ini/standard_keyboard.ini"
Segmentation fault
Go to the top of the page
 
+Quote Post
Greg2
post Sep 5 2005, 07:24 AM
Post #49





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(kombi @ Sep 5 2005, 10:19 AM)
If i run from console I get:

opera:  Could not find "ini/standard_voice.ini"
opera:  Could not find "ini/standard_mouse.ini"
opera:  Could not find "ini/standard_keyboard.ini"
opera:  Could not find "ini/standard_voice.ini"
opera:  Could not find "ini/standard_mouse.ini"
opera:  Could not find "ini/standard_keyboard.ini"
Segmentation fault
*

What model Z are you using? Are you installing to /media/card or /media/card/packages?

Your missing a symlink or 2... make sure you have symlinked:
/opt/QtPalmtop/opera 'to'
/media/card/opt/QtPalmtop/opera 'and'
/opt/QtPalmtop/opera/.opera/opera.ini 'to'
/media/card/opt/QtPalmtop/opera/.opera/opera.ini

Greg
Go to the top of the page
 
+Quote Post
kombi
post Sep 5 2005, 04:27 PM
Post #50





Group: Members
Posts: 6
Joined: 4-September 05
Member No.: 8,035



QUOTE(Greg2 @ Sep 5 2005, 07:24 AM)
QUOTE(kombi @ Sep 5 2005, 10:19 AM)
If i run from console I get:

opera:  Could not find "ini/standard_voice.ini"
opera:  Could not find "ini/standard_mouse.ini"
opera:  Could not find "ini/standard_keyboard.ini"
opera:  Could not find "ini/standard_voice.ini"
opera:  Could not find "ini/standard_mouse.ini"
opera:  Could not find "ini/standard_keyboard.ini"
Segmentation fault
*

What model Z are you using? Are you installing to /media/card or /media/card/packages?

Your missing a symlink or 2... make sure you have symlinked:
/opt/QtPalmtop/opera 'to'
/media/card/opt/QtPalmtop/opera 'and'
/opt/QtPalmtop/opera/.opera/opera.ini 'to'
/media/card/opt/QtPalmtop/opera/.opera/opera.ini

Greg
*



I am using a Zaurus 5500, I am using the Packing Manager to do the install and i tell it to install on the SD card.
Go to the top of the page
 
+Quote Post
Greg2
post Sep 6 2005, 06:36 AM
Post #51





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(kombi @ Sep 5 2005, 08:27 PM)
I am using the Packing Manager to do the install and i tell it to install on the SD card.

That is not in the instructions I linked you to... they clearly say open a terminal and use the command line.

However since you have already installed it with the Package manager you can try from the terminal:
CODE
ipkg-link mount /media/card

That should link everthing... then restart opie and try it out.

Please note that the Opera 7.55 ipk in 'this' thread was made to be installed in a specific location with a specific set of commands from the terminal unless you modify the postinst script.

Greg
Go to the top of the page
 
+Quote Post
russman
post Sep 6 2005, 06:56 AM
Post #52





Group: Members
Posts: 12
Joined: 25-August 05
Member No.: 7,941



QUOTE(kombi @ Sep 6 2005, 01:27 AM)
I am using a Zaurus 5500, I am using the Packing Manager to do the install and i tell it to install on the SD card.


Perhaps you need to link not to /media/card/... but to /media/card/packages/...
I have got this problem on my Z and needed to relink all stuff manually.
Go to the top of the page
 
+Quote Post
kombi
post Sep 6 2005, 10:16 AM
Post #53





Group: Members
Posts: 6
Joined: 4-September 05
Member No.: 8,035



root@kombi:~# ipkg-link mount /media/card
*** Command: mount
ls: /media/card/usr/lib/ipkg/info/*.list: No such file or directory
*** Done.
Go to the top of the page
 
+Quote Post
Greg2
post Sep 6 2005, 11:45 AM
Post #54





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(kombi @ Sep 6 2005, 02:16 PM)
root@kombi:~# ipkg-link mount /media/card
*** Command: mount
ls: /media/card/usr/lib/ipkg/info/*.list: No such file or directory
*** Done.
*

OK... that means you are installing to /media/card/packages
So do:
CODE
ipkg-link mount /media/card/packages

Please note as I have said before that the postinst script in this ipk was made to install to /media/card so you will have to check your symlinks if you have anymore problems.

As an alternative you could search the forums for an ipk that someone has modified (iirc) to install to /media/card/packages

Greg
Go to the top of the page
 
+Quote Post
Ferron
post Oct 23 2005, 03:03 PM
Post #55





Group: Members
Posts: 3
Joined: 21-October 04
Member No.: 5,135



Hi,

i know i am renewing this older thread but think its worth doing it.

I reactivated my zaurus and i tried to get some info on what is going wrong with opera on OZ and sl5500.

My setup :

Zaurus SL-5500G
Openzaurus 3.5.3
+ collie upgrades ( 3.5.3/feed/upgrades/collie )
+ upgrades ( 3.5.3/feed/upgrades/ )
+ kernel kernel_2.4.18-rmk7-pxa3-embedix-r21_collie (hrw built kernel)


Opera specific things:

used
sharp-compat-libs_0.5-r2_arm.ipk , opera_7.55.6079_arm.ipk

done the things described in this thread (updating javamates list now) :


(0. fresh installed OZ as said before)

(1. ext2 on sd card, see sd card ext2 formatting )

1. installed the compat libs on sd
CODE
ipkg -d sd install sharp-compat-libs_0.5-r2_arm.ipk
ipkg-link add sharp-compat-libs


2. installed opera on sd
CODE
ipkg -d sd install opera_7.55.6079_arm.ipk
ipkg-link add opera


3. link .opera to roots home
CODE
ln -s /mnt/card/opt/QtPalmtop/opera/.opera /home/root/.opera


(4. edit .desktop -- skipped this, still useful )

5. edited /mnt/card/opt/QtPalmtop/opera/.opera/opera.ini and changed cache entries to the Large settings

6. checked the symlinks
CODE
/opt/QtPalmtop/opera --> /media/card/opt/QtPalmtop/opera

and

/opt/QtPalmtop/opera/.opera/opera.ini --> /media/card/opt/QtPalmtop/opera/.opera/opera.ini



7. ipkg-link (note the ../packages for 3.5.3 oz rom)
CODE
ipkg-link mount /media/card/packages


8. linked missing symlink to /media/card/packages/opt/QtPalmtop/opera/ini/standard_mouse.ini in /opt/QtPalmtop/opera/ini/
CODE
ln -s /media/card/packages/opt/QtPalmtop/opera/ini/standard_mouse.ini  /opt/QtPalmtop/opera/ini/


9. makecompat
CODE
makecompat /opt/QtPalmtop/bin/opera


10. run /opt/QtPalmtop/opera in console (to be sure the right one ist runned, the compat linked one, )
CODE
cd /opt/QtPalmtop/opera
./opera



and getting:
window looking almost like an opera pops up, closes and :
CODE
Segmentation fault


so if you do everything here you still have a problem, if anyone knows what the real problem is reply please , i have done my best to get rid of the small errors.


thx,

Ferron
Go to the top of the page
 
+Quote Post
russman
post Oct 23 2005, 11:29 PM
Post #56





Group: Members
Posts: 12
Joined: 25-August 05
Member No.: 7,941



I am not sure, but last time I have been reinstalling opera the symlink /usr/share/opera gave me a hard time. Check there it points to.

Good luck!
Go to the top of the page
 
+Quote Post
Ferron
post Oct 24 2005, 02:29 PM
Post #57





Group: Members
Posts: 3
Joined: 21-October 04
Member No.: 5,135



Hi,

i did a find / -name opera and i would ask you if you can do the same to check if all folders and links are similar

/opt/QtPalmtop/bin/opera
/opt/QtPalmtop/opera
/opt/QtPalmtop/opera/opera
/opt/QtPalmtop.compat/bin/opera
/opt/QtPalmtop.compat/opera
/usr/share/opera
/media/card/packages/opt/QtPalmtop/bin/opera
/media/card/packages/opt/QtPalmtop/opera
/media/card/packages/opt/QtPalmtop/opera/opera
/media/card/opt/QtPalmtop/opera
/media/card/opt/QtPalmtop/opera/opera

thx for help,

Ferron
Go to the top of the page
 
+Quote Post

4 Pages V  « < 2 3 4
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 10:19 PM