OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Java On The C3000
totsubo
post Feb 22 2005, 03:12 AM
Post #1





Group: Members
Posts: 60
Joined: 12-February 05
Member No.: 6,461



How can I install Java on my SL-C3000?

Specifically I downloaded an application (J-Flash) that is a kanji flashcard program in a .jar file. It seems that java is not installedby default on the C3000 and I can find an ipk for java.

Jc
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Meanie
post Nov 9 2005, 03:13 PM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
Go to the top of the page
 
+Quote Post
smuelas
post Nov 11 2005, 05:17 PM
Post #3





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



Hi Meanie,
I've seen your impressive pages on Zaurus. You have done a lot of things!!
You seem to be the first one to have run java1.3.1 on Z. I've tried a lot of times but always finished with the problem of NOT finding this "famous" libstdc++-libc6.2-2.so.3 that java1.3 asks for. I have seen on your pages that you offer an ipq package with this library, but when I've tried to download it... no way: a negative answer about a broken link or something similar.
Would it be possible for you to put somewhere this library to let us download it?
Thanks a lot for all your excellent work.
smuelas




QUOTE(Meanie @ Nov 9 2005, 11:13 PM)
I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
*
Go to the top of the page
 
+Quote Post
Meanie
post Nov 11 2005, 08:52 PM
Post #4





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(smuelas @ Nov 12 2005, 11:17 AM)
Hi Meanie,
I've seen your impressive pages on Zaurus. You have done a lot of things!!
You seem to be the first one to have run java1.3.1 on Z. I've tried a lot of times but always finished with the problem of NOT finding this "famous"  libstdc++-libc6.2-2.so.3 that java1.3 asks for. I have seen on your pages that you offer an ipq package with this library, but when I've tried to download it... no way: a negative answer about a broken link or something similar.
Would it be possible for you to put somewhere this library to let us download it?
Thanks a lot for all your excellent work.
smuelas




QUOTE(Meanie @ Nov 9 2005, 11:13 PM)
I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
*

*




Thank you for your kind words. I did yet another typo in the links on my page. The correct link is http://www.users.on.net/~hluc/myZaurus/stu...6_1.2.2_arm.zip
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st July 2014 - 05:34 AM