OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Perl Error, Receiving "setting locale failed" error
cweaver87
post Mar 1 2005, 01:51 PM
Post #1





Group: Members
Posts: 1
Joined: 23-February 05
Member No.: 6,522



blink.gif I have recently installed Perl on my Zaurus 6000L and find that when I execute a script as root there are no problems but when I attempt to run scripts as “zaurus” I receive the following error:

perl -v perl: warning: setting locale failed.
perl: warning: please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en"
are supported and installed on your system. perl: warning: falling back to the standard locale ("C").

This is perl, v5.6.1 built for arm-linux


A check on Google revealed this to be a common error but all of the solutions presented don’t seem to translate into viable ones for the Zaurus. Any help or advice would be most welcome.
Go to the top of the page
 
+Quote Post
Pyrates
post Mar 2 2005, 01:23 AM
Post #2





Group: Members
Posts: 198
Joined: 17-January 04
Member No.: 1,475



QUOTE(cweaver87 @ Mar 1 2005, 01:51 PM)
blink.gif I have recently installed Perl on my Zaurus 6000L and find that when I execute a script as root there are no problems but when I attempt to run scripts as “zaurus” I receive the following error:

perl -v perl: warning: setting locale failed.
perl: warning: please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en"
      are supported and installed on your system. perl: warning: falling back to the standard locale ("C").

This is perl, v5.6.1 built for arm-linux


A check on Google revealed this to be a common error but all of the solutions presented don’t seem to translate into viable ones for the Zaurus.  Any help or advice would be most welcome.
*


From
this post in the gentoo forums I gather that this is a problem with compiling glibc (I also saw another post mentioning that recompiling glibc solved the problem). What ROM are you using? You probably should ask the developers of it for help...

Cheers
Philipp
Go to the top of the page
 
+Quote Post
doseas
post Mar 2 2005, 10:56 PM
Post #3





Group: Members
Posts: 207
Joined: 7-July 03
From: Thousand Oaks, CA
Member No.: 9



Add the following to your .bashrc or .profile file:
CODE
LANGUAGE="en"
LC_ALL="C"
LANG="en"

export LANGUAGE LC_ALL LANG
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 03:27 PM