OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Cacko FAQ and Bugz Database are available
stupkid
post Feb 7 2005, 12:45 PM
Post #1





Group: Members
Posts: 578
Joined: 2-January 04
From: Texas USA
Member No.: 1,324



Does running "sudo modprobe usb-storage" do anything for you? I see that the scsi modules and the usb-storage module is there. So all the necessary kernel modules should be there.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
mrente07
post Feb 8 2005, 11:22 AM
Post #2





Group: Members
Posts: 14
Joined: 11-October 04
From: Switzerland
Member No.: 4,954



QUOTE(stupkid @ Feb 7 2005, 08:45 PM)
Does running "sudo modprobe usb-storage" do anything for you?
*

I tried this running and controlled with "lsmod" the modules were loaded. Now I got following messages after inserting the USB stick:
... hub.c: USB new device connect on bus1/1, assigned device number 3
... WARNING: USB Mass Storage data integrity not assured
... USB Mass Storage device found at 3
... /etc/hotplug/usb.agent: Setup for USB product ea0/2168/200

But I got no connection. Then I reflash my zaurus with V1.22 and tried again but without any improvements. Tomorrow I will check the hardware with the cacko V1.21 (to see, if there are no defects). Simultaneous I will compare the system messages and loaded modules (of V1.21) with the information of V1.22. Thanks till then ...
Go to the top of the page
 
+Quote Post
mrente07
post Feb 9 2005, 11:21 AM
Post #3





Group: Members
Posts: 14
Joined: 11-October 04
From: Switzerland
Member No.: 4,954



QUOTE(mrente07 @ Feb 8 2005, 07:22 PM)
Tomorrow I will check the hardware with the cacko V1.21 (to see, if there are no defects). Simultaneous I will compare the system messages and loaded modules (of V1.21) with the information of V1.22. Thanks till then ...
*

Now I have done my checks. With cacko V1.21 the CFU USB card and the memory sticks work fine. With V1.22 I haven't got any connections. Then I compared the loaded modules and found out, that "sd_mod" isn't loaded as default. I used "modprobe" to load "sd_mod" and "usb-storage". After it I saw the connection signal of the memory sticks but I have no mount entry.

So I believe something is missing (maybe at "usb.distmap") to load all necessary modules and to create the mount. At my linux PC I have no file named "usb.distmap" (it is SuSE 9.2). Have anybody an idea, which entries in which file(s) are necessary to use my USB sticks (like vend/prod 0xea0/0x2168)?

Thanks a lot for any helps ...
Go to the top of the page
 
+Quote Post
mrente07
post Feb 10 2005, 08:48 AM
Post #4





Group: Members
Posts: 14
Joined: 11-October 04
From: Switzerland
Member No.: 4,954



Okay, after a long search I found the entry for my USB memory which has to add into "usb.distmap". After adding I got no automatical connection, despite reboot.

I have to enter following commands to get a connection:
1. modprobe sd_mod (only once, but again after reboot)
2. modprove usb-storage (only once, but again after reboot)
3. mount -f auto /dev/sda1 /mnt/usb ("/mnt/usb" should be exists)

Then I can work with the USB memory so long the zaurus is ON. After this I have to umount and to mount again. I hope this could help to give me any hint how I can realise a "plug + play" connection. Regards
Go to the top of the page
 
+Quote Post
maslovsky
post Mar 2 2005, 09:07 AM
Post #5





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



Thanks a lot to stupkid for setting it up and configuring. Also thanks to Laze for maintaining DNS redirections for us smile.gif

Here is it:

http://cacko.biz/cacko/bugs/

The user interface is currently under construction - we'll be updating titles, logos, etc. in the nesrest time.
Go to the top of the page
 
+Quote Post

Posts in this topic
maslovsky   Cacko FAQ and Bugz Database are available   Mar 2 2005, 09:07 AM
maslovsky   Based on 1.22 ROM thread, I've set up initial ...   Jan 5 2005, 08:15 AM
mrente07   Thanks a lot for the really nice ROM. I used the ...   Feb 5 2005, 07:53 AM
maslovsky   QUOTE(mrente07 @ Feb 5 2005, 06:53 PM)Thanks ...   Feb 6 2005, 02:01 AM
mrente07   QUOTE(maslovsky @ Feb 6 2005, 10:01 AM)Do you...   Feb 6 2005, 02:36 AM
maslovsky   QUOTE(mrente07 @ Feb 6 2005, 01:36 PM)QUOTE(m...   Feb 7 2005, 04:48 AM
mrente07   QUOTE(maslovsky @ Feb 7 2005, 12:48 PM)Try to...   Feb 7 2005, 10:23 AM
Lutz-W.   QUOTE(maslovsky @ Feb 7 2005, 12:48 PM)Try to...   Feb 7 2005, 12:31 PM
ev1l   here is the bugDB might be a good idea to put ncu...   Jan 5 2005, 07:16 PM
maslovsky   This FAQ is far from being complete. I just wanted...   Jan 6 2005, 04:12 AM
_Psycho   Its quite good if you ask me   Jan 6 2005, 05:57 AM
ev1l   QUOTE(maslovsky @ Jan 6 2005, 04:12 AM)This F...   Jan 6 2005, 03:04 PM
\Kritikal\   I noticed the page was slow to load as well as hav...   Jan 13 2005, 07:18 AM
stupkid   Does running "sudo modprobe usb-storage...   Feb 7 2005, 12:45 PM
Lutz-W.   QUOTE(stupkid @ Feb 7 2005, 10:45 PM)"su...   Feb 7 2005, 01:16 PM
mrente07   QUOTE(stupkid @ Feb 7 2005, 08:45 PM)Does run...   Feb 8 2005, 11:22 AM
mrente07   QUOTE(mrente07 @ Feb 8 2005, 07:22 PM)Tomorro...   Feb 9 2005, 11:21 AM
mrente07   Okay, after a long search I found the entry for my...   Feb 10 2005, 08:48 AM
maslovsky   Looks like your USB stick don't have an enry i...   Feb 7 2005, 01:38 PM
maslovsky   You need to double-check that you've entered e...   Feb 12 2005, 02:54 PM
mrente07   QUOTE(maslovsky @ Feb 12 2005, 10:54 PM)What ...   Feb 13 2005, 01:44 AM
maslovsky   Try adding that line into /etc/hotplug/usb.handmap...   Feb 13 2005, 05:25 AM
mrente07   QUOTE(maslovsky @ Feb 13 2005, 01:25 PM)Try a...   Feb 13 2005, 10:04 AM
maslovsky   QUOTE(mrente07 @ Feb 13 2005, 09:04 PM)QUOTE(...   Feb 13 2005, 11:24 AM
ev1l   it might be an idea to put the FAQ, bugbreporting,...   Mar 9 2005, 08:09 PM
maslovsky   QUOTE(ev1l @ Mar 10 2005, 07:09 AM)it might b...   Mar 9 2005, 08:20 PM
ev1l   So, what about actually moving the info   Mar 14 2005, 07:44 AM
maslovsky   QUOTE(ev1l @ Mar 14 2005, 06:44 PM)So, what a...   Mar 14 2005, 09:42 AM
ev1l   QUOTE(maslovsky @ Mar 14 2005, 09:42 AM)OK, m...   Mar 14 2005, 11:04 AM
maslovsky   QUOTE(ev1l @ Mar 14 2005, 10:04 PM)QUOTE(masl...   Mar 15 2005, 02:54 AM
ev1l   QUOTE(maslovsky @ Mar 15 2005, 02:54 AM)Yes, ...   Mar 15 2005, 06:11 PM
ev1l   Are we supposed to report package troubles as well...   Jun 15 2005, 04:39 PM
craigtyson   I have a similar query with advanced file manager ...   Jun 16 2005, 12:52 AM
Sy Ali   1.23 was released a while ago. Will the FAQ be up...   Jun 24 2006, 10:22 AM


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 03:31 AM