OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Bison Install Problem, for native compilation
post Mar 24 2005, 12:42 AM
Post #1

Group: Members
Posts: 37
Joined: 15-March 05
From: Toulouse / France
Member No.: 6,643

Finaly I managed to have zgcc working on Z sl-5500 with OZ-3.5.2 and OPIE-1.2 for native compilation of MapServer. It seems that I solved all libraries dependencies (freetype, libpng, libjpeg, gd); the "./configure" command ends ok. But the "make" command fails with :
... . .
yacc -p msyy -d omapparser.c mapparser.y
make: yacc: Command not found
make: *** [mapparser.c] Error 127

Yacc seems related to Bison. I don't understand wether I have bison installed or not :
#ipkg info bison
Package: bison
Version: 1:1.35-3
Depends: libc6 (>= 2.2.4-')
Status: install prefer,user not-installed <---- what does that mean ? ?
ARchitecture: arm

I dl "bison_1.35-3_arm.ipk" but when I try to install it, I get :
#ipkg install /mnt/cf/ms/bison_1.35-3_arm.ipk
Installing bison (1:1.35-3) to sd...
sh: /tmp/ipkg-ey3VZY/bison-PbK06y/preinst: not found
preinst script returned status 127
Aborting installation of bison
An error has occured, return value: 1.

Each time I retry to install bison, it doens't find the preinst in another /tmp/ipkg-xxxx directory.
I looked in /tmp but there is no directory like that, and if I create one, then when I retry to install bison, the name it looks for has changed.

Is Bison that difficult to install ? It seems strange. I'm geting closer and closer to my aim but now, I'm stuck with this "little" thing. Any suggestion for me to install Bison ?

btw: I think I have bison-dev ok :
#ipkg info bison-dev
Package: bison-dev
Version: 1.875-r0
Status: install user installed
Architecture: arm
Installed-Time: 11116542551
but it doesn't seem enough for the make.

Go to the top of the page
+Quote Post
Start new topic
post Apr 6 2007, 06:13 PM
Post #2

Group: Members
Posts: 327
Joined: 28-February 06
From: South East of South Australia
Member No.: 9,251

linking ./intl/libgettext.h to intl//libintl.h
ln: intl/libintl.h: Operation not permitted
configure: error: can not link intl/libintl.h to ./intl/libgettext.h

i had a very sililiar error when trying to build "Tar", which was solved by do the compiling on my SD (ext) rather than CF (fat) ...
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th May 2018 - 09:34 PM