OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Installing App In Qtopia
jeffbarish
post Apr 8 2005, 06:02 PM
Post #1





Group: Members
Posts: 25
Joined: 24-November 04
Member No.: 5,604



I found some information here about how to install an application in Qtopia, but I can't get it to work. It's possible that I misinterpreted some of the directions that I found, so I thought that perhaps someone could point to my error if I carefully describe what I did.

1. I put my app (myapp.py) in /home/QtPalmtop/bin (which is in my path).

2. I made myapp.py executable. The first line is

#! /usr/bin/env python

The line that calls QPEApplication is:

app = QPEApplication(['myapp.py'])

I do:

from qtpe import QPEApplication

3. I created a file in /home/QtPalmtop/apps/Applications called myapp.desktop. It contains the lines

[Desktop Entry]
Comment=What my program does
Exec=myapp.py
Type=Application
Name=MyApp

4. I rebooted

An icon appears on the Applications page. When I click on it, it changes to the clicked icon and I see an hourglass. Then the hourglass disappears and my app does not run. I presume that it crashed. When I run it from a command prompt (by typing myapp.py), it runs fine. I hope that someone can see what I did wrong -- or can at least suggest a diagnostic procedure. For example, does Qtopia log error messages somewhere? Is there a way to capture error messages emitted during program startup? Thanks.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 02:04 AM