OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Note: Task Failed: Fetch Failed: Quilt, do_fetch fails all the time
noha
post Apr 12 2005, 12:55 AM
Post #1





Group: Members
Posts: 2
Joined: 11-April 05
Member No.: 6,851



I started yesterday to install openembedded according to the Wiki::GettingStarted.

When I try to build anything with bitbake it doesn't succeed. If I try to build nano I get the following:
(using bitbake -D -D -D nano)

NOTE: fetch http://www.treke.net/oe/source/quilt_savan...ER_0_39_.tar.gz
DEBUG: Fetch: checking for module directory
NOTE: Fetch cvs://anoncvs:@savannah.nongnu.org/cvsroot/quilt;method=ext;rsh=ssh;module=quilt;tag=VER_0_39
DEBUG: mkdirhier(/home/slug/sources/cvs/quilt-native)
DEBUG: created /home/slug/sources/cvs/quilt-native
DEBUG: Running CVS_RSH="ssh" /usr/bin/env cvs -d:ext:anoncvs@savannah.nongnu.org:/cvsroot/quilt co -r VER_0_39 quilt
NOTE: Task failed: Fetch failed: quilt
NOTE: package quilt-native-0.39-r0: task do_fetch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of nano failed

It don'tt know where the problem could be. Invoking the command

CVS_RSH="ssh" /usr/bin/env cvs -d:ext:anoncvs@savannah.nongnu.org:/cvsroot/quilt co -r VER_0_39 quilt

succeeds. Afterward I can retry building bitbake -D -D -D nano. Then I get the following.

NOTE: fetch http://www.treke.net/oe/source/quilt_savan...ER_0_39_.tar.gz
DEBUG: Fetch: checking for module directory
NOTE: Update cvs://anoncvs:@savannah.nongnu.org/cvsroot/quilt;method=ext;rsh=ssh;module=quilt;tag=VER_0_39
NOTE: Task failed: Fetch failed: quilt
NOTE: package quilt-native-0.39-r0: task do_fetch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of nano failed

It doesn't depend on the package I try to build. I assume that it isn't the cvs task which fails. As I am knew to openembedded I have no idea what is going wrong. Is there chance to debug even more?


I am using an up to date gentoo ~x86 system.

thanks,

Norbert
Go to the top of the page
 
+Quote Post
spongeman66
post Aug 30 2005, 07:48 PM
Post #2





Group: Members
Posts: 3
Joined: 8-August 05
Member No.: 7,816



I seem to be having exactly the same problem.
Anybody have any suggestions?

I also have a fresh copy of Gentoo...

Thanks!
Sponge
Go to the top of the page
 
+Quote Post
lardman
post Aug 31 2005, 01:18 AM
Post #3





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Quilt is a patch manager iirc, it's required by OE (so will be downloaded & built much like the toolchain is).

Not sure why you can't get it atm, but perhaps the server is busy?


Si
Go to the top of the page
 
+Quote Post
Mickeyl
post Aug 31 2005, 02:20 AM
Post #4





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
Go to the top of the page
 
+Quote Post
koen
post Aug 31 2005, 02:34 AM
Post #5





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(Mickeyl @ Aug 31 2005, 10:20 AM)
FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
*


I'd appreciate someone looking in to this problem instead of using nondefault hacks (enabling patcher)

/me also hints at http://bugs.openembedded.org
Go to the top of the page
 
+Quote Post
spongeman66
post Sep 1 2005, 08:20 AM
Post #6





Group: Members
Posts: 3
Joined: 8-August 05
Member No.: 7,816



QUOTE(Mickeyl @ Aug 31 2005, 05:20 AM)
FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
*


I tried this inside the firewall where I work, and I now get a similar problem retrieving patcher...
It may be a firewall issue, or more likely, I have something setup wrong....
I will try from home soon...

Is there any specific setup I need for BitBake? It 'says' it completes the download, but complains about null.
Here is the original Quilt failure (outside the firewall):
CODE
OE Build Configuration:
TARGET_ARCH   = "arm"
TARGET_OS     = "linux"
MACHINE       = "collie"
DISTRO        = "openzaurus"
TARGET_FPU    = "soft"

DEBUG: providers for update-modules are: ['update-modules']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/update-modules/update-modules_1.0.bb to satisfy update-modules
NOTE: current path: update-modules (update-modules)
NOTE: dependencies for update-modules are: ipkg-utils-native quilt-native virtual/arm-linux-gcc virtual/libc
DEBUG: providers for ipkg-utils-native are: ['ipkg-utils-native']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/ipkg-utils/ipkg-utils-native_1.6cvs.bb to satisfy
ipkg-utils-native
NOTE: current path: update-modules (update-modules) -> ipkg-utils-native (ipkg-utils-native)
NOTE: dependencies for ipkg-utils-native are: quilt-native
DEBUG: providers for quilt-native are: ['quilt-native']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/quilt/quilt-native_0.39.bb to satisfy quilt-native
NOTE: current path: update-modules (update-modules) -> ipkg-utils-native (ipkg-utils-native) -> quilt-native
(quilt-native)
NOTE: dependencies for quilt-native are:
NOTE: package quilt-native-0.39: started
DEBUG: Executing task do_fetch
DEBUG: update_data()
NOTE: package quilt-native-0.39-r0: task do_fetch: started
DEBUG: update_data()
DEBUG: BUG init called with None as data object!!!
NOTE: package quilt-native-0.39-r0: task do_fetch: completed
DEBUG: Executing task do_unpack
DEBUG: update_data()
NOTE: package quilt-native-0.39-r0: task do_unpack: started
DEBUG: update_data()
NOTE: Unpacking /zaurus/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz to /var/tmp/oetmp/work/quilt-native-0.39-r0/
tar: /zaurus/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
NOTE: Task failed:
NOTE: package quilt-native-0.39-r0: task do_unpack: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of update-modules failed


Thanks for your time!
Sponge
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th April 2014 - 05:27 PM