OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3 >  
Reply to this topicStart new topic
> Icewm Or Other Wm? & Themes Mgmt
Meanie
post May 2 2005, 08:15 AM
Post #16





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ArchiMark @ May 3 2005, 12:08 AM)
Meanie,

Took a good look at your website. Has lots of great info!

Going to install X/Qt/Debian per your instructions...

However, can't find one of the files you have in your list. Can you tell me where you
found it?

It's the 'glib_1.2.10-0v13_arm.ipk' file.

Thanks!

Mark
*


It's in http://sourceforge.jp/projects/xqt
Go to the top of the page
 
+Quote Post
ArchiMark
post May 2 2005, 08:47 AM
Post #17





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks meanie, but I looked there already. Maybe my eyes are bad, but what I see when I go to the download page is actually the 'glib-additional_1.2.10-2_arm.ipk' file not the 'glib_1.2.10-0v13_arm.ipk' file.

Meanwhile, would like to clarify two more things in your install instructions, please...

1) You mention that you can use the 'xqt-debian-scripts_0.1_arm.ipk' file. Do you install this AND the other 'xqt-startup-scripts_0.0.3_all.ipk' file too. Or just one of them? I do want to install Debian...

2) At the end of your modifications to the '.xinitrc' file, you show:

CODE
else
rxvt &
fi


Did you mean to delete the line 'blackbox' after 'rxvt &' ?? If not, does it still go after the line 'rxvt &' and then 'fi' ??

Thanks for your help!

Just don't want to mess things up.... rolleyes.gif

Mark

QUOTE(Meanie @ May 2 2005, 08:15 AM)
Go to the top of the page
 
+Quote Post
Meanie
post May 2 2005, 05:34 PM
Post #18





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ArchiMark @ May 3 2005, 02:47 AM)
Thanks meanie, but I looked there already. Maybe my eyes are bad, but what I see when I go to the download page is actually the 'glib-additional_1.2.10-2_arm.ipk' file not the  'glib_1.2.10-0v13_arm.ipk' file.

Meanwhile, would like to clarify two more things in your install instructions, please...

1) You mention that you can use the 'xqt-debian-scripts_0.1_arm.ipk' file. Do you install this AND the other 'xqt-startup-scripts_0.0.3_all.ipk' file too. Or just one of them? I do want to install Debian...

2) At the end of your modifications to the '.xinitrc' file, you show:

CODE
else
rxvt &
fi


Did you mean to delete the line 'blackbox' after 'rxvt &' ?? If not, does it still go after the line 'rxvt &' and then 'fi' ??

Thanks for your help!

Just don't want to mess things up.... rolleyes.gif

Mark

QUOTE(Meanie @ May 2 2005, 08:15 AM)

*



you are right, that's not the one, but you can find it here http://zaurus.spy.org/feeds/naorou/

as for the rest, blackbox is meant to remain there. if you install xqt-startup-scripts_0.0.3_all.ipk then you need to do those modifications, alternatively, xqt-debian-scripts_0.1_arm.ipk is meant as a replacement for xqt-startup-scripts_0.0.3_all.ipk

with xqt-debian-scripts_0.1_arm.ipk you don't need to modify .xinitrc and startx-wrapper

I think I need to clean up that section a bit to make it a bit clearer.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 2 2005, 05:38 PM
Post #19





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for clarifying, Meanie!

Haven't been able to get X/Qt going yet today.....so hopefully this info
will do the trick...

Thanks,

Mark

QUOTE(Meanie @ May 2 2005, 05:34 PM)
It's in http://sourceforge.jp/projects/xqt

you are right, that's not the one, but you can find it here http://zaurus.spy.org/feeds/naorou/

as for the rest, blackbox is meant to remain there. if you install xqt-startup-scripts_0.0.3_all.ipk then you need to do those modifications, alternatively, xqt-debian-scripts_0.1_arm.ipk is meant as a replacement for xqt-startup-scripts_0.0.3_all.ipk

with xqt-debian-scripts_0.1_arm.ipk you don't need to modify .xinitrc and startx-wrapper

I think I need to clean up that section a bit to make it a bit clearer.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 2 2005, 07:33 PM
Post #20





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



OK, deinstalled and reinstalled again (for the 5th time today....) and still no go....even with the latest info from Meanie.... sad.gif

When I click on StartX icon it just crashes....

Tried opening it in Console...and get the following messages:
CODE
/opt/QtPalmtop/bin/Xqt: error while loading shared libraries: libfreetype.so.6:
cannot load shared object file: No such file or directory
xinit: No such file or directory (errno 2): Unable to connect to X server
xinit: No such process (errno 3): Server errror.


Any suggestions?????

Thanks!

Mark
Go to the top of the page
 
+Quote Post
Meanie
post May 3 2005, 12:00 AM
Post #21





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ArchiMark @ May 3 2005, 01:33 PM)
OK, deinstalled and reinstalled again (for the 5th time today....) and still no go....even with the latest info from Meanie.... sad.gif

When I click on StartX icon it just crashes....

Tried opening it in Console...and get the following messages:
CODE
/opt/QtPalmtop/bin/Xqt: error while loading shared libraries: libfreetype.so.6:
cannot load shared object file: No such file or directory
xinit: No such file or directory (errno 2): Unable to connect to X server
xinit: No such process (errno 3): Server errror.


Any suggestions?????

Thanks!

Mark
*



This means that it is missing the freetype [freetype_2.1.5-1_arm.ipk] package. Try installing it and see if it works. Strangely, I did not have to install that package to run Debian and Firefox ( but it is needed for Minimo)
Go to the top of the page
 
+Quote Post
ArchiMark
post May 3 2005, 05:59 AM
Post #22





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for your help, Meanie.

OK, installed freetype. Now, here's what happens:

A) If I click on 'StartX' icon, it doesn't open, just see that crash graphic on icon.

cool.gif If I use Konsole, and type at prompt 'startx', I now get the following messages, but X does open up:

CODE
qtApInit
Display size = 480 x 640
qtRandRRotate (270)
Create shadow Image: 480 x640
qtRandRInit ()
qtInitVisualShadowMasks 0000f000 000007e0 0000001f BPRGB 6 d 16 bpp 16
qtRandRInit ()
qtCreateDefColorMap - Deferring to fbCreateDefColorMap ()
qtFinishScreenInitFB - returning
qtScreenInit - returning
127.0.0.1 being added to access control list
failed to set locale, reverting to "C"
rxvt: error while loading shared libraries:
rxvt: undefined symbol: _Xsetlocale
BScreen:: BScreen: managing screen 0 using visual 0x21, depth 15
failed to set locale, reverting to "C"


Any ideas why X won't start from icon??

Any ideas about these error messages??

Does the locale error relate to not installing one of the locale files (included in other install instructions, but not Meanie's) ??

Again, I in option 'B' above, I did get X to open and if do 'fullscreen' I see what I think is the top of the rxvt window at the bottom of the display. At least I think it's just the top as I only see the title bar of the window, the rest of the display has that B&W grid look on it.

Thanks!

Mark


QUOTE(Meanie @ May 3 2005, 12:00 AM)
This means that it is missing the freetype [freetype_2.1.5-1_arm.ipk] package. Try installing it and see if it works. Strangely, I did not have to install that package to run Debian and Firefox ( but it is needed for Minimo)


This post has been edited by ArchiMark: May 3 2005, 03:33 PM
Go to the top of the page
 
+Quote Post
ArchiMark
post May 3 2005, 03:32 PM
Post #23





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Just tried opening up X again from QKonsole after commenting out 'Blackbox' in '.xinitrc' file....

Here's what I get in Konsole:

CODE
$startx
qtApInit
Display size = 480 x 640
qtRandRRotate (270)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
Create shadow Image: 480 x640
qtRandRInit ()
qtInitVisualShadowMasks 0000f000 000007e0 0000001f BPRGB 6 d 16 bpp 16
qtRandRInit ()
qtCreateDefColorMap - Deferring to fbCreateDefColorMap ()
qtFinishScreenInitFB - returning
qtScreenInit - returning
127.0.0.1 being added to access control list
waiting for X server to shut down


Any suggestions??

Thanks,

Mark
Go to the top of the page
 
+Quote Post
Meanie
post May 3 2005, 06:44 PM
Post #24





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ArchiMark @ May 4 2005, 09:32 AM)
Just tried opening up X again from QKonsole after commenting out 'Blackbox' in '.xinitrc' file....

Here's what I get in Konsole:

CODE
$startx
qtApInit
Display size = 480 x 640
qtRandRRotate (270)
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
Create shadow Image: 480 x640
qtRandRInit ()
qtInitVisualShadowMasks 0000f000 000007e0 0000001f BPRGB 6 d 16 bpp 16
qtRandRInit ()
qtCreateDefColorMap - Deferring to fbCreateDefColorMap ()
qtFinishScreenInitFB - returning
qtScreenInit - returning
127.0.0.1 being added to access control list
waiting for X server to shut down



Any suggestions??

Thanks,

Mark
*



well, you had it working before. leave blackbox in there. it is what is keeping x running, if you remove it, x will just finish. by default blackbox provides a very bare minimum taskbar at the bottom which is what you saw before. if you want something fancy, replace it with flushbox or fvwm, etc... or just use debian's icewm.
if you want to get rid of the locale errors, just install the eucjp locale
Go to the top of the page
 
+Quote Post
ArchiMark
post May 3 2005, 06:53 PM
Post #25





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks as always, Meanie for your help!

Yes, I had it working before...BUT per my earlier post, I have NOT been able to get X to start from clicking on icon, ONLY by typing 'startx' in Konsole....

Seems like something is wrong....

Anyway to fix this strange situation??

Thanks,

Mark

QUOTE(Meanie @ May 3 2005, 06:44 PM)
well, you had it working before. leave blackbox in there. it is what is keeping x running, if you remove it, x will just finish. by default blackbox provides a very bare minimum taskbar at the bottom which is what you saw before. if you want something fancy, replace it with flushbox or fvwm, etc... or just use debian's icewm.
if you want to get rid of the locale errors, just install the eucjp locale
Go to the top of the page
 
+Quote Post
Meanie
post May 4 2005, 03:34 AM
Post #26





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(ArchiMark @ May 4 2005, 12:53 PM)
Thanks as always, Meanie for your help!

Yes, I had it working before...BUT per my earlier post, I have NOT been able to get X to start from clicking on icon, ONLY by typing 'startx' in Konsole....

Seems like something is wrong....

Anyway to fix this strange situation??

Thanks,

Mark

QUOTE(Meanie @ May 3 2005, 06:44 PM)
well, you had it working before. leave blackbox in there. it is what is keeping x running, if you remove it, x will just finish. by default blackbox provides a very bare minimum taskbar at the bottom which is what you saw before. if you want something fancy, replace it with flushbox or fvwm, etc... or just use debian's icewm.
if you want to get rid of the locale errors, just install the eucjp locale

*



ok, you should have 2 icons, X/Qt Server and Start X
which one did you use? the X/Qt does not work, the Start X one does and it should be launching startx-wrapper if you check the startx.desktop file. Also make sure you are not running it as root.
Go to the top of the page
 
+Quote Post
ArchiMark
post May 4 2005, 06:13 AM
Post #27





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Yes, I have the 2 icons.

I used the Start X icon.

I am not running it as root.

Don't know what happened, but I just tried it again and a bit, it DID open it this time!

Thanks for ALL your help, Meanie!!!

Now onto re-installing Debian.... rolleyes.gif

Mark

QUOTE(Meanie @ May 4 2005, 04:34 AM)
ok, you should have 2 icons, X/Qt Server and Start X
which one did you use? the X/Qt does not work, the Start X one does and it should be launching startx-wrapper if you check the startx.desktop file. Also make sure you are not running it as root.
Go to the top of the page
 
+Quote Post
iamasmith
post May 4 2005, 06:37 AM
Post #28





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(ArchiMark @ May 4 2005, 02:13 PM)
Yes, I have the 2 icons.

I used the Start X icon.

I am not running it as root.

Don't know what happened, but I just tried it again and a bit, it DID open it this time!

Thanks for ALL your help, Meanie!!!

Now onto re-installing Debian.... rolleyes.gif

Mark

QUOTE(Meanie @ May 4 2005, 04:34 AM)
ok, you should have 2 icons, X/Qt Server and Start X
which one did you use? the X/Qt does not work, the Start X one does and it should be launching startx-wrapper if you check the startx.desktop file. Also make sure you are not running it as root.

*



ArchiMark, if you followed the PocketWorkstation/XQT instructions on the debian Wiki you are running as root. The startup script calls su -c to issue the chroot, this leaves you logged in as root whilst the environment is running.

For some reason though, the environment still seems to have the idea that the ~ path is /home/zaurus and the instructions assume that your home is /home/root (as in the passwd file).

If you get back to where you were then issue the following command from a terminal window (from the Debian environment)...

ln -s /root /home/zaurus

Then try setting your theme. Themes are not being saved in your example because the theme manager couldn't find your home path to save the settings.

- Andy
Go to the top of the page
 
+Quote Post
ArchiMark
post May 4 2005, 07:19 AM
Post #29





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Thanks for your help with this, Andy!

Was driving me nuts!

Mark

QUOTE(iamasmith @ May 4 2005, 07:37 AM)
QUOTE(ArchiMark @ May 4 2005, 02:13 PM)
Yes, I have the 2 icons.

I used the Start X icon.

I am not running it as root.

Don't know what happened, but I just tried it again and a bit, it DID open it this time!

Thanks for ALL your help, Meanie!!!

Now onto re-installing Debian.... rolleyes.gif

Mark

QUOTE(Meanie @ May 4 2005, 04:34 AM)
ok, you should have 2 icons, X/Qt Server and Start X
which one did you use? the X/Qt does not work, the Start X one does and it should be launching startx-wrapper if you check the startx.desktop file. Also make sure you are not running it as root.

*



ArchiMark, if you followed the PocketWorkstation/XQT instructions on the debian Wiki you are running as root. The startup script calls su -c to issue the chroot, this leaves you logged in as root whilst the environment is running.

For some reason though, the environment still seems to have the idea that the ~ path is /home/zaurus and the instructions assume that your home is /home/root (as in the passwd file).

If you get back to where you were then issue the following command from a terminal window (from the Debian environment)...

ln -s /root /home/zaurus

Then try setting your theme. Themes are not being saved in your example because the theme manager couldn't find your home path to save the settings.

- Andy
*

Go to the top of the page
 
+Quote Post
iamasmith
post May 4 2005, 08:22 AM
Post #30





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Actually I think I have found the better answer (if you have sudo installed, as you would with Cacko3K).

In the Qtopia envonment /home/zaurus/.xinitrc should contain...
CODE
#!/bin/sh
export LANG=en_US
export DISPLAY=:0.0

# default: use anthy
#export XMODIFIERS=@im=uim-anthy

# start uim-xim
if [ -x /opt/QtPalmtop/bin/uim-xim ]; then
   exec /opt/QtPalmtop/bin/uim-xim &
fi

if [ -f "${HOME}/.xmodmaprc" ]; then
       xmodmap ~/.xmodmaprc
fi
export HOME=/home/root
sudo chroot `cat /etc/debroot` /startd


Also if you are having keymap problems then one thing that's going to get in the way is KeyHelper, for some reason it works well now with standard XQT but as soon as you go debian it fails.

To avoid this issue if you have KeyHelper installed (or are using Cacko3K and it's built in) edit your /opt/QtPalmtop/bin/startx file add at the top...

khctl disable

and at the bottom...

khctl enable

Finally you probably want to create your .xmodmaprc in /home/zaurus (in the Qtopia environment) that looks like this...

CODE
keycode 69 = comma slash
keycode 70 = period question
keycode 142 = braceleft
keycode 143 = braceright
keycode 22 = minus grave


This will get the the comma, slash, period and question marks available.
Fn + O = {
Fn + P = }
Shift + - = `
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 05:20 AM