OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Japanese Input In Debian
ShiroiKuma
post May 1 2005, 09:32 AM
Post #1





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



Is anyone using Japanese input in debian under XQt?

I can't figure out how to make it work.

I apt-get installed anthy and uim-xim, but shift-space doesn't switch to Japanese input...

What do I need to do?
Go to the top of the page
 
+Quote Post
ShiroiKuma
post May 5 2005, 08:25 AM
Post #2





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



To answer my own question after having figured it out. If anyone needs it, this is what I did to get it working:

Install anthy, uim, and prime:
CODE
apt-get install anthy uim uim-xim prime


I had previously installed also anthy and uim compiled for XQt for the Zaurus and it was conflicting with the debian versions, so make sure to uninstall anthy and uim-xim if you had it installed on the Zaurus.

Then to get Japanese input running when in debian, add the following line to your ~/.xinitrc config file:
CODE
export XMODIFIERS=@im=uim


Then to start Japanese input running the Prime predictive input software:
CODE
uim-xim --engine=prime &


Then to switch to Japanese input you hit shift-space and you can enter text.

Prime is a predictive text input, similar to QPOBox, and you can use it also to enter text predictively in English. It gives you options based on what you entered before and facilitaties typing...

For this there is the following problem: anthy when activated with shift-space sends then the Japanese wide space, known as zenkaku supeesu, instead of the regular Western half-character size space, hankaku supeesu.

To fix this, edit the /usr/share/uim/japanese.scm file once in debian. Find the lines that read:
CODE
(define ja-direct-rule
  '((" " " ")
    ))

In the middle line the first space between the quotation marks is the regular English one, the second one is the Japanese wide space. Change this line to:
CODE
  '((" " " ")

So that both spaces between the quotation marks are the hankaku spaces.

Now when you enter the text using Prime, it will send the regular English space between the words, when you hit space, and not the zenkaku Japanese space.

Don't know of any other way to let you then select the zenkaku space if you need it though.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 09:48 PM