OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Guylhem Rom: First Qtopia 1.5 Release
guylhem
post May 7 2005, 06:50 PM
Post #1





Group: Members
Posts: 577
Joined: 17-March 04
Member No.: 2,365



Hello

The first "end user ready" release is being uploaded. It features a nice GUI and should work out of the box (no command line special knowledge should be necessary)

Get it on: http://externe.net/zaurus/guylhem-rom/

The only bugs I could find (and honnestly, they are not serious drawbacks) are:
- some remaining keyboard remapping (power/record are used like a jogdial, but should also be able to start applications - they can't yet)
- the network application refuses to add new interfaces. So I replaced the usual netsetup by a different one I compiled and I created a "Get online" icon, which can be used to create a new connection, before using the network application (that's the only if you really want to use the old one called netsetup.old). I have no idea why it doesn't work :-( Trolltech version works fine, Sharp doesn't. Any help would be welcome

If you feel like giving a try, your feedback would be very welcome. What you get :
- a polished qtopia 1.5 rom loaded with applications
- a cleaned filesystem (no symlinks everywhere)
- 24 Mb free to add your own applications (I doubt you'll need them - it's *loaded* with applications, basically every app I use is there, PIM, Hancom, Opera, etc etc.)

What's new since last version :
- added qtopia 1.5 interface
- made sure it worked well
- fixed the zoom/systemtime bugs reported in the standalone qtopia packages.

What's missing :
- special modules used by special card. If you have such a card, please tell me or adf so we can compile your missing module for you

To install it, simply restore the nandbackup. That's all. On reboot, you may see jffs2 errors - that's normal. It's just very verbose. You are presented with a login: if you log in, qtopia won't start. Press home twice to open another console. Press userkey/light to move between consoles. You must log out of every shell so Qtopia may start 30 seconds later. However the keyboard may not be usable if you didn't return to the first console. So if you want to use qtopia, simply don't log in.

Anyway, let's start the beta test ! I'm also preparing a dedicated feed for the ROM. If you have a .ipk that works fine and you think should be interesting to other people, please send me a URL where I can download it and add it to the feed.

If you think some application should be included by default, please tell me too. I'd like to create a "different" rom, very user oriented. Everything should be simple and work out of the box - the apps. I did choose tend to do that.

Guylhem
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
ken
post May 9 2005, 02:32 PM
Post #2





Group: Members
Posts: 274
Joined: 17-October 04
Member No.: 5,063



Bug List (Qtopia GUI):
------------------------------------------------------------
1 - unable to change the Time Zone to other than what's listed. a subsequent reboot then allows the new timezone to show up
2 - SD card not detected (Kingston 512M SD)
3 - note - all your connections/WEP keys etc are listed
4 - new wireless connections with a 128 bit WEP key unable to connect
5 - new wired connections aren't working (shows up, but can't connect)
6 - sharp PIM information is gone (no biggie, just didnt expect it)
7 - removing-inserting CF cards multiple times(ethernet, then modem) caused the Z to hang
8 - creating a new modem connection file complains "Can't create ppp setup file"

most of my data/ipks/etc is on my SD so I was unable to test anything else. On the bright side, it does appear to be snappier. I notice that there are quite a number of useful items on the list.

Observed boot errors:
-----------------------------------------------------------
blkmtd: error: missing `device' name
...
IrCOMM protecol (Dag Brattli)
cramfs: wrong magic
FAT: bogus logical sector size 45147
Eep. Child "ascii-xfr" (ino #1312) of dir ino #1301 doesn't exist!
(it complains zknights.desktop, codepages, p80211.o, QtEmbedded-0.spec, LAN.conf, VPN.conf PAN.conf, DialUp.conf, IRDA.conf, PPPoEW.conf, libpan.so, f, l)
(it also has quite a number of Inode #xxxx was a directory with children - removing those too...)
(then says a bunch of Cannot remove child "xxx", ino #4895, because it doesn't exist (zknights.desktop, ascii-xfr, codepages, QtEmbedded-0.spec, LAN.conf, VPN.conf, PAN.conf, DialUp.conf, IRDA.conf, PPPoEW.conf, libpan.so, f, l, p80211.o)
...
modeprobe: Can't locate module usb_ohci_tc6393
...
pxa_sd_stopclock: clock stop time out. (retries 2x10 times) then gives up
VFS: Can't find ext2 filesystem on dev mmcd(60,1).


Comments:
-----------------------------------------------------------
I suspect a number of those errors are because it can't find the SD card. I also observed that the SD card drivers loaded up just prior to the login prompt. I tried keeping the SD card in, and inserting it after it boots, but no icon for the SD card shows up at the bottom.

Creating a modem connection via the @ Tab, "Get Online" works
Creating a wired/wireless connection via the @ Tab, "Get Online" doesn't connect

rebooting to the console, SD card in.

When I remove the SD card:
pxa_sd_wait_response: card removed (cmd=12)
pxa_sd_wait_response: card removed (cmd=12)
pxa_sd_wait_id_response: card removed (cmd=12)
pxa_sd_wait_id_response: card removed (cmd=12)

When I reinsert the SD card:
pxa_sd_stopclock: clock stop time out. (retry count x) x = total of 10 times
give up!![SD]-clustsize = 4000
mmcda: mmcda1
mmcda:mmcda1
VFS: Can't find ext2 filesystem on dev mmcd(60,1).
mmcda: mmcda1
mmcda:mmcda1
VFS: Can't find ext2 filesystem on dev mmcd(60,1).

(I think it's because it thinks the SD card is ext2 rather than the default fat?)

note: If I drop down to the console, and su, then change the /etc/fstab entry to fat, I'm able to do a mount, but it won't unmount automatically. It will however allow me to read the sd, and the sd icon appears.

sharp's default fstab entres are as follows:

/dev/mtdblock2 / jffs2 ro,noatime 1 1
/dev/mtdblock3 /home jffs2 defaults,noatime 1 2
none /dev/shm tmpfs size=1m,noauto 0 0
/dev/mmcda1 /mnt/card auto noauto,owner 0 0
none /dev/pts devpts gid=5,mode=620 0 0

changing the /dev/mmcda1 line to match sharp's default one allows me to type in:
mount /dev/mmcda1 (upon which the SD card now shows up properly). The SD card icon will unmount properly if the card is pulled out, but I have to drop down to the console and mount it manually whenever I reinsert it (unfortunately, the GUI software install program only shows "Internal Flash" as the only location I can install anything to (the SD or CF card doesn't show up).
Go to the top of the page
 
+Quote Post
adf
post May 9 2005, 08:05 PM
Post #3





Group: Members
Posts: 2,821
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572



You could just mount the sd card manually, or edit fstab and/or mtab

Things seem to install just fine. Loaded the camera software (and module) kino2, advanced fm, some libs wellenreiter, multimodal (couldn't find a 755 ipk and was too lazy to strip it)browser XQT (which runs very nicely from internal flash) qtopia mamory applet, the ffpe kernel etc.
can't find my belkin irk ipk though...(re did my sytem a few weeks ago..I seem to have kepth the targus version.


a question, though.
how does one set the processor speed from commandline?

also I can see the need for a few scripts eventually.(would you like tmp on cf or sd? etc) and maybe the inclusion of swapd in the basic part of the rom? (with a yes/no on boot or installaion)
Go to the top of the page
 
+Quote Post

Posts in this topic
guylhem   Guylhem Rom: First Qtopia 1.5 Release   May 7 2005, 06:50 PM
adf   Getting it now this should be excellent. XQT com...   May 7 2005, 11:03 PM
adf   killer splash screen tree explorer? or advancedfm...   May 7 2005, 11:35 PM
eddiectc   Great rom! Just tried, very usable! Now p...   May 8 2005, 03:25 AM
guylhem   Regarding the splash screen - believe it or not bu...   May 8 2005, 05:07 AM
eddiectc   the link to get the opera 7.5 http://www14.softwar...   May 9 2005, 03:46 AM
rip   what a fuck...ing time it should took you for such...   May 8 2005, 12:27 PM
adf   a small issue. when trying to install packages, s...   May 8 2005, 01:28 PM
guylhem   Hello rip- it tooks a long long time. A grand tot...   May 8 2005, 02:58 PM
adf   fixed both easily. thnx. gott play around with th...   May 8 2005, 04:55 PM
rip   QUOTE(guylhem @ May 8 2005, 10:58 PM)adf - re...   May 10 2005, 04:21 AM
adf   QUOTE(rip @ May 10 2005, 12:21 PM)QUOTE(guylh...   May 10 2005, 07:39 AM
adf   I can click on the battery f i am in qtopia. If n...   May 10 2005, 07:55 AM
rip   it's simple, really. just su and do mkdir /mnt...   May 10 2005, 11:01 AM
adf   [quote=rip,May 10 2005, 07:01 PM] it's simple,...   May 10 2005, 12:50 PM
hbo   QUOTE(adf @ May 10 2005, 12:50 PM)0 .0 it...   May 12 2005, 12:19 PM
adf   QUOTE(hbo @ May 12 2005, 08:19 PM)QUOTE(adf ...   May 12 2005, 12:48 PM
hbo   QUOTE(adf @ May 12 2005, 12:48 PM)QUOTE(hbo ...   May 12 2005, 06:08 PM
ken   Guylhem, When you have a chance, could you post t...   May 12 2005, 07:00 PM
adf   hmmm.... ok If you want an os on the microdrive, ...   May 12 2005, 07:38 PM
adf   I heard back for Klauss W. on the keymap thing. he...   May 12 2005, 09:11 PM
adf   QUOTE(adf @ May 13 2005, 05:11 AM)I heard bac...   May 12 2005, 09:16 PM
hbo   QUOTE(adf @ May 12 2005, 09:16 PM)[btw so far...   May 12 2005, 09:30 PM
adf   except.... Qtopia 2.1 is based on what I think is ...   May 12 2005, 09:35 PM
hbo   It should be doable. I wonder what start/stop daem...   May 12 2005, 09:59 PM
adf   lmao.... I was wondering that too. I guess we try...   May 12 2005, 10:23 PM
hbo   On my collie I have OZ 3.5.3/Opie 1.2 and nxclient...   May 12 2005, 10:39 PM
hbo   Last one for tonight. So I was wrong about it de...   May 12 2005, 10:45 PM
adf   can we get the source? I hadn't looked. It co...   May 12 2005, 10:55 PM
hbo   QUOTE(adf @ May 12 2005, 07:38 PM)hmmm.... ok...   May 12 2005, 09:14 PM
gfdsa   opera_sl-5x00-7.30.9965_arm.ipk installs cleanly, ...   May 9 2005, 05:32 AM
kahm   QUOTE(gfdsa @ May 9 2005, 07:32 AM)opera_sl-5...   May 9 2005, 10:27 AM
systemparadox   WOW! A ROM for a 6k? I must be dreaming. Well,...   May 9 2005, 07:16 AM
rip   done straight forward, all stuff works, wifi also ...   May 9 2005, 09:16 AM
rip   pb i think, i cant install anything to sd or cf, i...   May 9 2005, 11:22 AM
ken   Guylhem, Thought I'd clean up your README fil...   May 9 2005, 12:20 PM
ken   Bug List (Qtopia GUI): ---------------------------...   May 9 2005, 02:32 PM
adf   You could just mount the sd card manually, or edit...   May 9 2005, 08:05 PM
gab74   i'm testing the rom...and things works well......   May 10 2005, 12:05 AM
guylhem   ken, Thanks a lot for the readme. I'll use it...   May 10 2005, 12:06 AM
ken   >for me if I can't find a play to have both...   May 10 2005, 02:00 AM
gfdsa   very good job guylhem, tried yesterday, without me...   May 10 2005, 01:05 AM
rip   wep key 40 bits entered and surfing ok, qtopia de...   May 10 2005, 02:30 AM
ken   I suppose I could compare the network settings tha...   May 10 2005, 03:19 AM
rip   another little pb, the file browser after a reboot...   May 10 2005, 04:11 AM
gfdsa   no unicode fonts btw, had to copy files from Qtopi...   May 10 2005, 07:47 AM
rip   i appologize for my incompetence, but witch /tmp h...   May 11 2005, 05:26 AM
gfdsa   add/remove applet ? how to get there? i have all ...   May 11 2005, 05:51 AM
rip   well, sorry, windows typology rests.... icon name...   May 11 2005, 07:02 AM
adf   if you are in a console in qtopia there is, effect...   May 11 2005, 07:14 AM
adf   IRK. the "a" key on my ir keyboard does...   May 11 2005, 01:55 PM
adf   QUOTE(adf @ May 11 2005, 09:55 PM)IRK. the ...   May 11 2005, 01:57 PM
guylhem   installating in other places besides internal flas...   May 11 2005, 05:52 PM
ken   >installating in other places besides internal ...   May 11 2005, 06:16 PM
adf   I had wondered about the usb thing after I posted ...   May 11 2005, 06:27 PM
adf   doing a fastffpe kernel with the usb fix btw? and...   May 11 2005, 08:42 PM
guylhem   Hello ken : if ipkg.conf doesn't help, I...   May 12 2005, 06:31 AM
adf   QUOTE(guylhem @ May 12 2005, 02:31 PM)Hello ...   May 12 2005, 07:40 AM
rip   this quick post to ask if its not a good idea to i...   May 12 2005, 07:38 AM
gfdsa   speaking of multiple guis, one of the ideas that i...   May 12 2005, 08:27 AM
adf   absolutely. i'd love to see this quingy workin...   May 12 2005, 08:54 AM
gfdsa   thats the idea, adf, i did not advance lately, my ...   May 12 2005, 10:35 AM
bear426   Will this work on the SLC 3000? If it does, and s...   May 12 2005, 12:45 PM
guylhem   adf - I don't need 2.95 toolchain - already go...   May 12 2005, 11:29 PM
adf   I'll have to look again, lmy last "soluti...   May 13 2005, 07:44 AM
hbo   I reflashed this evening with the 0.9 release. As...   May 13 2005, 05:12 PM
adf   home key to open a new terminal. maybe you should...   May 13 2005, 09:16 PM
hbo   QUOTE(adf @ May 13 2005, 09:16 PM)maybe you s...   May 13 2005, 10:32 PM
ken   QUOTE(hbo @ May 13 2005, 03:12 PM)Is there a ...   May 13 2005, 09:21 PM
guylhem   A wiki is ready on externe.net/zaurus/faq. It...   May 14 2005, 05:54 AM
hbo   QUOTE(guylhem @ May 14 2005, 05:54 AM)A wiki ...   May 14 2005, 10:54 AM
guylhem   Please do ! That's the purpose of the wiki...   May 14 2005, 11:02 AM
adf   another reason for an install script or two imho. ...   May 14 2005, 11:22 AM
hbo   QUOTE(guylhem @ May 14 2005, 11:02 AM)Please ...   May 14 2005, 03:11 PM
ken   QUOTE(hbo @ May 14 2005, 01:11 PM)I created a...   May 14 2005, 04:48 PM
hbo   QUOTE(ken @ May 14 2005, 04:48 PM)I'm sur...   May 14 2005, 05:39 PM
adf   ultimately, I agree. a choice of guis, and the fle...   May 14 2005, 05:48 PM
hbo   QUOTE(adf @ May 14 2005, 05:48 PM)ultimately,...   May 14 2005, 06:34 PM
ken   QUOTE(adf @ May 14 2005, 05:48 PM)ultimately,...   May 14 2005, 08:03 PM
hbo   QUOTE(ken @ May 14 2005, 08:03 PM)QUOTE(adf ...   May 14 2005, 09:08 PM
adf   nah... Guylhem is doing great stuff with the defa...   May 14 2005, 09:02 PM
hbo   QUOTE(adf @ May 14 2005, 09:02 PM)... My fir...   May 14 2005, 09:20 PM
adf   actually, i tend to do 600l configs a bit differen...   May 14 2005, 11:10 PM
hbo   Got it regarding the relationship of this ROM to O...   May 14 2005, 11:29 PM
hbo   Well, I got to remember how to recover from uninst...   May 15 2005, 12:26 AM
guylhem   adf, to swap 125 and 30 you need to edit the sourc...   May 14 2005, 11:05 AM
guylhem   I fixed /tmp ipkg problems using /home/tmp in /etc...   May 14 2005, 11:55 AM
adf   QUOTE(guylhem @ May 14 2005, 07:55 PM)Regardi...   May 14 2005, 11:58 AM
adf   QUOTE(adf @ May 14 2005, 07:58 PM)QUOTE(guylh...   May 14 2005, 12:02 PM
ken   QUOTE(guylhem @ May 14 2005, 09:55 AM)I fixed...   May 14 2005, 02:00 PM
hbo   QUOTE(ken @ May 14 2005, 02:00 PM)QUOTE(guylh...   May 14 2005, 03:22 PM
hbo   I'm thinking about a flexible base system on t...   May 14 2005, 03:27 PM
guylhem   Hello Regarding the keymap, I tried to match as c...   May 15 2005, 05:29 AM
CoreDump   QUOTEAnyway I'm open. Please tell me how you t...   May 15 2005, 06:14 AM
guylhem   QUOTE(CoreDump @ May 15 2005, 06:14 AM)QUOTEA...   May 15 2005, 09:04 AM
adf   you have mail ( I think)   May 15 2005, 09:29 AM
hbo   QUOTE(guylhem @ May 15 2005, 09:04 AM)QUOTE(C...   May 15 2005, 10:50 AM
hbo   QUOTE(guylhem @ May 15 2005, 05:29 AM)So if y...   May 15 2005, 07:33 AM
Mickeyl   [deleted]   May 15 2005, 05:50 AM
guylhem   Honnestly, there's no best way I know. Breakin...   May 15 2005, 08:47 AM
2 Pages V   1 2 >


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 07:53 PM