OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Firewall-settings For Os X Internetsharing Via Usb, can't browse WWW with Z over USB/TCP-IP
elwood151
post Jun 12 2005, 12:02 AM
Post #1





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



Hi,

I'm trying to connect my Zaurus SL5500 (Sharp ROM 3.13 + Cacko Kernel patch) to the WWW and for the first step I want to use the USB/TCP-IP connection.

My Powerbook is connected via WLAN to our DSL router, I have internet sharing enabled on the PB and the Z can ping IP-numbers and urls like www.avm.de successfully.

However, the Z can only load a web page in Opera, if I disable the firewall on the PowerBook (OS 10.3.9).
I don't want to disable it completely - does anybody know how I have to configure the firewall for getting Opera on the Z working?

Best regards

Martin
Go to the top of the page
 
+Quote Post
2 Pages V   1 2 >  
Start new topic
Replies (1 - 14)
jfv
post Jun 12 2005, 05:46 AM
Post #2





Group: Members
Posts: 438
Joined: 24-June 03
Member No.: 202



You probably need to open port 80 on your powerbook's firewall. Open
System Preferences-> Sharing
On the "Services" tab (the first one), enable personal web sharing. This is for OS X.2, I don't know if it works on later versions.

Felipe
Go to the top of the page
 
+Quote Post
elwood151
post Jun 13 2005, 11:49 AM
Post #3





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



QUOTE(jfv @ Jun 12 2005, 01:46 PM)
You probably need to open port 80 on your powerbook's firewall. Open
System Preferences->  Sharing
On the "Services" tab (the first one), enable personal web sharing. This is for OS X.2, I don't know if it works on later versions.

Felipe
*


Thanks! Now I can browse web pages on the Z with the Firewall enabled.

Bye,

Martin
Go to the top of the page
 
+Quote Post
qwerty
post Jul 7 2005, 08:07 AM
Post #4





Group: Members
Posts: 13
Joined: 7-July 05
From: Chicago
Member No.: 7,553



Hi,
I'm trying this too, but haven't gotten as far.
I installed the USB ethernet driver, gave my Z and my mac manual IPs (192.168.129.xxx). I can ssh back and forth between the two, but the Z can't find the internet (ping attempts give: address unreachable). I turned on internet sharing (of regular ethernet, to usb ethernet adapter) and my firewall is allowing port 80.
I've been hunting around and I think I might need to turn on ip forwarding on the z. (I found a page describing setting up a pppd on the usb and setting up a NAT using the iptables command which appearantly my Z doesn't have yet.)

The Z has OpenZaurus (really minimal, the person i bought it from flashed it) and the mac has 10.3 and is connected to a DSL modem.



QUOTE(elwood151 @ Jun 12 2005, 03:02 AM)
Hi,

I'm trying to connect my Zaurus SL5500 (Sharp ROM 3.13 + Cacko Kernel patch) to the WWW and for the first step I want to use the USB/TCP-IP connection.

My Powerbook is connected via WLAN to our DSL router, I have internet sharing enabled on the PB and the Z can ping IP-numbers and urls like www.avm.de successfully.

However, the Z can only load a web page in Opera, if I disable the firewall on the PowerBook (OS 10.3.9).
I don't want to disable it completely - does anybody know how I have to configure the firewall for getting Opera on the Z working?

Best regards

Martin
*

Go to the top of the page
 
+Quote Post
elwood151
post Jul 10 2005, 08:51 PM
Post #5





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



QUOTE(qwerty @ Jul 7 2005, 04:07 PM)
Hi,
I'm trying this too, but haven't gotten as far.
I installed the USB ethernet driver, gave my Z and my mac manual IPs (192.168.129.xxx).  I can ssh back and forth between the two, but the Z can't find the internet (ping attempts give: address unreachable).  I turned on internet sharing (of regular ethernet, to usb ethernet adapter) and my firewall is allowing port 80.
I've been hunting around and I think I might need to turn on ip forwarding on the z. (I found a page describing setting up a pppd on the usb and setting up a NAT using the iptables command which appearantly my Z doesn't have yet.)

The Z has OpenZaurus (really minimal, the person i bought it from flashed it) and the mac has 10.3 and is connected to a DSL modem.


Hi qwerty,

I never tried OpenZaurus yet, so I'm not sure if it works the same way as the SharpROM concerning networking...

Try the following:

If the Zaurus and the Mac are connected and are able to ping each other,
open a terminal on the Z and type:

sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1

Then you should be able to ping a server on the web from the Z
(ping www.google.com ...)

Please try and give me feedback, if you were successful, and then we'll attack further steps. (I have some urgent work to do at the moment and for some weeks did not try to get further with my Z, so my memories what I tried and what helped for whatt aren't really "fresh" ;-( )

Best regards,

Martin
Go to the top of the page
 
+Quote Post
qwerty
post Jul 13 2005, 07:36 AM
Post #6





Group: Members
Posts: 13
Joined: 7-July 05
From: Chicago
Member No.: 7,553



thanks martin. I used those two commands and now the zaurus can ping other IPs. however, i can't ping names. I suppose i need to tell it where to find a dns server. My ethernet connection does not list a DNS in that TCP/IP pane.
Go to the top of the page
 
+Quote Post
elwood151
post Jul 13 2005, 11:56 AM
Post #7





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



QUOTE(qwerty @ Jul 13 2005, 03:36 PM)
thanks martin.  I used those two commands and now the zaurus can ping other IPs.  however, i can't ping names.  I suppose i need to tell it where to find a dns server.  My ethernet connection does not list a DNS in that TCP/IP pane.
*


What I had to do in my SharpROM was adding in the file
/etc/resolv.conf

the line
nameserver 192.168.2.1

(with the IP-address of your router)

Hope that helps

Best regards

Martin
Go to the top of the page
 
+Quote Post
freizugheit
post Jul 14 2005, 07:43 AM
Post #8





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
Go to the top of the page
 
+Quote Post
qwerty
post Jul 14 2005, 02:04 PM
Post #9





Group: Members
Posts: 13
Joined: 7-July 05
From: Chicago
Member No.: 7,553



thanks. I figured out su, although i'm running in root right now anyways (eep!).

How do I find my ISP's name server? DHCP isn't showing me a dns address in my mac's control panel.



QUOTE(freizugheit @ Jul 14 2005, 10:43 AM)
QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
*

Go to the top of the page
 
+Quote Post
freizugheit
post Jul 15 2005, 08:39 AM
Post #10





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



whois ispdomain
Go to the top of the page
 
+Quote Post
qwerty
post Jul 17 2005, 08:22 PM
Post #11





Group: Members
Posts: 13
Joined: 7-July 05
From: Chicago
Member No.: 7,553



thanks for being patient with my questions...still need more help...

so I got the IP for ns1.ameritech.net and added that as the first DNS. now "ns1.ameritech.net" seems to be the only address that I can ping by name. pinging any IP still works. tried a few other nameservers, but same problem.
what should /etc/resolv.conf look like at the end of the day?

This seems more like a general "using the internet" issue, than a zaurus problem, but hopefully someone can point me along.
Go to the top of the page
 
+Quote Post
samxiao
post Jul 20 2005, 12:12 PM
Post #12





Group: Members
Posts: 260
Joined: 7-March 04
From: Toronto
Member No.: 2,200



QUOTE(qwerty @ Jul 14 2005, 05:04 PM)
thanks.  I figured out su, although i'm running in root right now anyways (eep!).

How do I find my ISP's name server?  DHCP isn't showing me a dns address in my mac's control panel.



QUOTE(freizugheit @ Jul 14 2005, 10:43 AM)
QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
*


*




try do that on your Mac terminal
QUOTE
$ cat /etc/resolv.conf
Go to the top of the page
 
+Quote Post
samxiao
post Jul 20 2005, 12:28 PM
Post #13





Group: Members
Posts: 260
Joined: 7-March 04
From: Toronto
Member No.: 2,200



where do i put those codes so everytime i reboot my Z, it will run them?


QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1
Go to the top of the page
 
+Quote Post
qwerty
post Jul 20 2005, 01:08 PM
Post #14





Group: Members
Posts: 13
Joined: 7-July 05
From: Chicago
Member No.: 7,553



/etc/resolv.conf on the mac (which can do all the web stuff fine) looks something like this (im at work right now):

domain no_domain_set.invalid
nameserver 192.168.0.1
nameserver 192.168.0.0


------------
EDIT: So, I think I fixed it. I added:
nameserver 192.168.0.1 to the /etc/resolv.conf file on the zaurus. thank you everyone.
Go to the top of the page
 
+Quote Post
sabes
post Feb 16 2006, 03:09 PM
Post #15





Group: Members
Posts: 1
Joined: 16-February 06
Member No.: 9,154



I'm having a similar problem connecting my Nokia 770 via apple airport extreme to mac mini -- any ideas on the ports that should be open? nokia is clueless about this -- very pc-centric.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 11:51 AM