OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> C1000, Annoying Rotation Problem, ...probably user error...
JohnX
post Jun 20 2005, 10:59 AM
Post #1





Group: Members
Posts: 126
Joined: 4-May 05
From: Lynnwood, WA, US
Member No.: 7,070



I have OZ 3.5.3 flashed on my C1000. I'm very happy with it overall (much better than Sharp's ROM). I just have one nagging issue (which I suspect I caused):
Somehow I've managed to end up with the screen rotation 90° off from the screen rotation. For example: When I hit 'right' apps in Opie act like I hit 'up.' When I hit 'up' they act like I hit 'left.' Everything works correctly in a terminal (not a terminal window, but VT 1). So if someone can tell me how Opie keeps track of screen rotation in relation to keyboard orientation I would be eternally greatful. I don't need a step-by-step explanation. I'm perfectly happy to RTFM...I just couldn't find the FM in this case. wink.gif

-John
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
jam13
post Jun 24 2005, 02:12 PM
Post #2





Group: Members
Posts: 20
Joined: 20-June 05
Member No.: 7,393



QUOTE(JohnX @ Jun 20 2005, 07:59 PM)
I have OZ 3.5.3 flashed on my C1000.  I'm very happy with it overall (much better than Sharp's ROM).  I just have one nagging issue (which I suspect I caused):
Somehow I've managed to end up with the screen rotation 90° off from the screen rotation.  For example: When I hit 'right' apps in Opie act like I hit 'up.'  When I hit 'up' they act like I hit 'left.'  Everything works correctly in a terminal (not a terminal window, but VT 1).  So if someone can tell me how Opie keeps track of screen rotation in relation to keyboard orientation I would be eternally greatful.  I don't need a step-by-step explanation.  I'm perfectly happy to RTFM...I just couldn't find the FM in this case. wink.gif


If you are referring to the cursor pad being out by 90deg when the screen is in landscape, this is fixed by the latest version of the qt/e libs from the OZ feed (libqte2).

You might also want to update the kernel to the latest snapshot. This fixes the problems with certain keys (particularly the function key) not working. You'll get a warning when booting up, but it seems to work fine.

Both are located at:

http://www.openzaurus.org/official/unstable/3.5.3/upgrades/

--
Jamie
Go to the top of the page
 
+Quote Post

Posts in this topic
JohnX   C1000, Annoying Rotation Problem   Jun 20 2005, 10:59 AM
JohnX   OK, I just reflashed and I still have this problem...   Jun 24 2005, 11:55 AM
jam13   QUOTE(JohnX @ Jun 20 2005, 07:59 PM)I have OZ...   Jun 24 2005, 02:12 PM
JohnX   Thank you!   Jun 24 2005, 02:20 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd November 2014 - 08:41 AM