OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

5 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> Irk - Pockettop Keyboard, Mentioned in another thread.
samac
post Jul 3 2005, 06:51 AM
Post #1





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



QUOTE
root@acpzaurus:~# ipkg install irk
Nothing to be done
An error ocurred, return value: 4.
Collected errors:
Cannot find package irk.
Check the spelling or perhaps run 'ipkg update'

I copied this from another thread, as there was no answer evident.

Has anyone else come across this. The package is in the OPIE feed, but it will not work either from the package manager or from the command line.

I would welcome your suggestions.

Samac
Go to the top of the page
 
+Quote Post
samac
post Jul 7 2005, 06:25 AM
Post #2





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



It will not even download from the site.

Help, would be appreciated.

Samac
Go to the top of the page
 
+Quote Post
grog
post Jul 7 2005, 09:03 AM
Post #3





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



I use the irk-zaurus package from the ZUG feed on my 5600 without problems. HTH
Go to the top of the page
 
+Quote Post
samac
post Jul 7 2005, 02:40 PM
Post #4





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



QUOTE(grog @ Jul 7 2005, 05:03 PM)
I use the irk-zaurus package from the ZUG feed on my 5600 without problems. HTH
*

Thank you I will try that one.

Samac
Go to the top of the page
 
+Quote Post
samac
post Jul 8 2005, 03:23 AM
Post #5





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



QUOTE(samac @ Jul 7 2005, 10:40 PM)
QUOTE(grog @ Jul 7 2005, 05:03 PM)
I use the irk-zaurus package from the ZUG feed on my 5600 without problems. HTH
*

Thank you I will try that one.

Samac
*


I now have irk-zaurus_0.11.0_arm.ipk installed, but nothing else is happening, no configuration program, no ability to select keyboard.

I know that it is probably something really simple, but I cannot figure out what I have done wrong.

Samac
Go to the top of the page
 
+Quote Post
grog
post Jul 8 2005, 07:22 AM
Post #6





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



IIRC I had to reboot to get it to work. After that, an IRK entry with a kangaroo icon appeared in the input selection list (lower left corner, where you select keyboard, handwriting, etc). Assuming you get that far, then select IRK, hit the kangaroo & select Settings to set your Z type. Then just hit the 'on' radio button, line up the keyboard & it works. HTH
Go to the top of the page
 
+Quote Post
samac
post Jul 8 2005, 09:09 AM
Post #7





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



QUOTE(grog @ Jul 8 2005, 03:22 PM)
IIRC I had to reboot to get it to work. After that, an IRK entry with a kangaroo icon appeared in the input selection list (lower left corner, where you select keyboard, handwriting, etc). Assuming you get that far, then select IRK, hit the kangaroo & select Settings to set your Z type. Then just hit the 'on' radio button, line up the keyboard & it works. HTH
*

OK is that iirc or lirc, if it is iirc you will have to help again as I cannot find it on any feed.

Many thanks again

Samac
Go to the top of the page
 
+Quote Post
grog
post Jul 8 2005, 09:17 AM
Post #8





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(samac @ Jul 8 2005, 11:09 AM)
QUOTE(grog @ Jul 8 2005, 03:22 PM)
IIRC I had to reboot to get it to work.
*

OK is that iirc or lirc, if it is iirc you will have to help again as I cannot find it on any feed.
*

I apologize for throwing in acronyms. That's not a package name. IIRC = If I Remember Correctly. I should learn that not everybody is as skilled at mangling the english language as I am smile.gif.

So just try rebooting & see if that helps.
OAO (Over And Out)
Go to the top of the page
 
+Quote Post
samac
post Jul 8 2005, 10:02 AM
Post #9





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



Re-booting didn't help, and I am just as capable of mangling the English language. (Note that I used a contraction.) smile.gif

Samac
Go to the top of the page
 
+Quote Post
grog
post Jul 10 2005, 05:08 PM
Post #10





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



I'm afraid that's all I did & it worked. Sorry I can't be more help. Maybe somebody else will key in? (HELLO THERE!!) good luck.
Go to the top of the page
 
+Quote Post
acpkendo
post Jul 11 2005, 06:53 AM
Post #11





Group: Members
Posts: 169
Joined: 15-March 04
Member No.: 2,327



Do not use the ipk from the ZUG feed on OZ--none of the packages from external sites I've used have worked on 3.5.3.

The solution had something to do with strange dependency errors and/or the naming of the packages--Mickeyl commented that ipkg was too smart for its own good. The solution is as follows:

1) download the ipk to the Z (sorry, can't help you as to why it won't download--maybe try downloading to a desktop and transferring)

2) disable all feeds in /etc/ipkg.conf or via the package manager (you needn't erase them, just disable).

3) run ipkg update (or update via the package manager)

4) install the local copy of IRK (ipkg install ./irk-blahblah_0.11.0-r0_arm.ipk, or via the package manager). With no other dependencies in the database, it should install cleanly.

5) reboot (you can probably just restart Opie, but I haven't had a lot of luck with that).

6) re-enable all the feeds in /etc/ipkg.conf or the package manager

7) update
Go to the top of the page
 
+Quote Post
samac
post Jul 11 2005, 10:17 AM
Post #12





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



Hi acpkendo

That seemed to install the package OK, I say seemed because on reboot I got a black screen of death.

Ho hum, not to worry, I will fix it later.

Samac
Go to the top of the page
 
+Quote Post
samac
post Jul 14 2005, 01:08 PM
Post #13





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



I have tried several times to install this package, either to / or sd, and each time I get a black screen. This is easily fixed by ssh'ing in and removing irk.

Could the problem be Hentges 3.5.3 in conjuction with the r21 kernel?

If anyone is running this combination with irk, please let me know.

Samac
Go to the top of the page
 
+Quote Post
acpkendo
post Jul 15 2005, 12:08 PM
Post #14





Group: Members
Posts: 169
Joined: 15-March 04
Member No.: 2,327



This is a problem with the IRK.conf file, that I thought was fixed in the current version. In any case, the easiest way is to drop out of Opie, install it from the command line, and then copy the /etc/skel/IRK.conf file (I think that's the location) to ~/Settings/

Then you should be golden.
Go to the top of the page
 
+Quote Post
samac
post Jul 15 2005, 01:04 PM
Post #15





Group: Members
Posts: 124
Joined: 5-December 04
Member No.: 5,774



QUOTE(acpkendo @ Jul 15 2005, 08:08 PM)
This is a problem with the IRK.conf file, that I thought was fixed in the current version.  In any case, the easiest way is to drop out of Opie, install it from the command line, and then copy the /etc/skel/IRK.conf file (I think that's the location) to ~/Settings/

Then you should be golden.
*

OK I found IRK.conf in /etc

There was a folder called IRK.conf in ~/Settings/ and it was linked to /media/card/home/root/Settings/IRK.conf/

I deleted the folders, copied /etc/IRK.conf to /media/card/home/root/Settings/IRK.conf then
ln -s /media/....../IRK.conf ~/Settings/IRK.conf

Rebooted and I now have a fully working infra-red keyboard.

Many, Many, Many Thanks.

Samac smile.gif
Go to the top of the page
 
+Quote Post

5 Pages V   1 2 3 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 02:23 AM