OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Blackdown J2se On Zaurus Sl-c3000, Not found: libjava.so
post Jul 14 2005, 06:22 AM
Post #1

Group: Members
Posts: 1,001
Joined: 28-April 05
From: Germany
Member No.: 7,027

Did anyone try this already?

I downloaded an IPK package which has been designed for the iPaq (from http://www.tml.tkk.fi/~jsantala/feed/ ).

It could not be installed to the SL-C300 with ipkg install, because ipkg tried to install files on on eof the read-only file systems. So I disassembled the package manually with tar.

What I got was mainly a directory

./j2re1.3.1/bin and

Calling ./j2re1.3.1/bin/java I got
"Error: Can't find libjava.so".

libjava.so is in ./j2re1.3.1/lib/armv4l/libjava.so.

So I linked it to /usr/lib and called ldconfig. but still the same error.

Could anyone please guide me what to do in order to make blackdown J2SE work on the SL-C3000?


Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st May 2018 - 01:17 AM