OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Blackdown J2se On Zaurus Sl-c3000, Not found: libjava.so
daniel3000
post Jul 14 2005, 06:22 AM
Post #1





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



Did anyone try this already?

I downloaded an IPK package which has been designed for the iPaq (from http://www.tml.tkk.fi/~jsantala/feed/ ).

It could not be installed to the SL-C300 with ipkg install, because ipkg tried to install files on on eof the read-only file systems. So I disassembled the package manually with tar.

What I got was mainly a directory

./j2re1.3.1/bin and
./j2re1.3.1/lib

Calling ./j2re1.3.1/bin/java I got
"Error: Can't find libjava.so".

libjava.so is in ./j2re1.3.1/lib/armv4l/libjava.so.

So I linked it to /usr/lib and called ldconfig. but still the same error.

Could anyone please guide me what to do in order to make blackdown J2SE work on the SL-C3000?

Thanks

daniel
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Meanie
post Jul 15 2005, 04:06 AM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



The java wrapper script needs some hacking to get it to work.

see http://www.users.on.net/~hluc/myZaurus/custom.html#java
Go to the top of the page
 
+Quote Post
daniel3000
post Jul 15 2005, 06:24 AM
Post #3





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



QUOTE(Meanie @ Jul 15 2005, 02:06 PM)
The java wrapper script needs some hacking to get it to work.

see http://www.users.on.net/~hluc/myZaurus/custom.html#java
*


Hi Meanie,

tried it per your instructions, unfortunately still some problems. Java won't start.

What i did:

Using the blackdown-jre_1.3.1-RC1_arm.ipk:
Installing with ipkg didn't work, since it wanted to install to some read-only places.

* So I untarred the ipk and the data.tar.gz and got a j2re1.3.1 directory with bin and lib in it. Started from there.

* Copied the j2re1.3.1 to /usr/local (i.e. /hdd2/usr/local).

* Used your instructions:
# ln -s /usr/local/j2re1.3.1/bin/java /usr/bin/java
# ln -s /usr/local/j2re1.3.1/bin/armv4l /usr/local/j2re1.3.1/bin/armv5tel
# ln -s /usr/local/j2re1.3.1/lib/armv4l /usr/local/j2re1.3.1/lib/armv5tel
# ln -s /usr/lib/libstdc++-3-libc6.1-2-2.10.0.so /usr/lib/libstdc++-libc6.2-2.so.3

Had to do a chmod a+x /usr/local/j2re1.3.1/bin/java in addition.

Now, starting "java", I get the following errors:

/usr/bin/java: /bin/realpath: not found
(where can I get this tool?)

grep: /lib/jvm.cfg: NO such file or directory
(where does this file come from normally?)

java was not found in /bin/armv5tel/native_threads/java
(not even /bin/armv5tel exists - why does it think it should be there?)

Thanks for all further hints!

daniel
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th July 2014 - 11:17 AM