OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Gmail Thru Qtmail Using Stunnel, How-to
nilch
post Aug 8 2005, 08:44 AM
Post #1





Group: Members
Posts: 668
Joined: 3-December 03
From: US
Member No.: 1,034



At last after a lot of googling, OE Forum posts and the help frm there and generally trial-and error methods I have been able to get this seemingly simple thing up and running.

So for those who are trying to figure out the steps in details (that was what was missing from the posts here - no particulars)...

1) Install Stunnel from the ipk available (at Killefiz for example)

2) Since this installation doesn't seem to create a Stunnel directory and the corresponding stunnel.conf file anywhere create it manually
a) create /etc/stunnel directory
cool.gif create stunnel.conf file inisde the /etc/stunnel directory (use VI and QZed)

the stunnel.conf file contents as I have it now...
###################
client = yes
debug=debug

# Configure the secured POP3 services
[pop3s]
accept = 127.0.0.1:110
connect=pop.gmail.com:995
###################


3) Edit the /etc/inietd.conf file and add a line to enable pop thru stunnel

pop3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/stunnel /etc/stunnel/stunnel.conf -r pop.gmail.com:995 -c

This is to make the tcpd service accept and connect thru stunnel (located in /usr/sbin) and make stunnel use the stunnel.conf file in /etc/stunnel with switches -r -c (maybe this is redundandant since the connect IP and port is already defined in stunnel.conf. I havent yet tried it without the -r switch.

After making the change to inetd.conf file restart the inetd service from the terminal
> su
> killall -hup inetd

4) Setup the gmail account in QtMail
The Incoming details are as
-----------------------------------
Choose account type : POP3
Username : whatever@gmail.com
Password : ******** (use your password here)
Server : 127.0.0.1
Port : 110


Now after connecting , and starting QtMail, I am able to receive all my Gmail emails on my Zaurus as pop mail.
Note : Gmail must already be configued to have POP mail service enabled (go to settings in Gmail)

I still haven't tried the outgoing mail using the smtp.gmail.com server at port 465, but at least I have incoming working.

Thanks to all who helped in the forums and at least gave helpful pointers.
Hope this helps and please correct me anyone if I am using redundant switches or settings anywhere...

EDIT : I need to add that on the default Sharp ROM, you also need to install openssl for stunnel to work. Thanks to a much later post by inode0, I remembered that openssl is also a requirement. Since I had it installed already from previously, I missed that. Thanks to inode0 for the helpful pointer.
Go to the top of the page
 
+Quote Post

Posts in this topic
nilch   Gmail Thru Qtmail Using Stunnel   Aug 8 2005, 08:44 AM
bam   cool, wonder if it'll work with KopieMail. BTW...   Aug 8 2005, 12:22 PM
inode0   QUOTE(bam @ Aug 8 2005, 08:22 PM)cool, wonder...   Aug 15 2005, 07:46 PM
inode0   QUOTE(nilch @ Aug 8 2005, 04:44 PM)3) Edit th...   Aug 9 2005, 08:27 AM
bam   QUOTE(inode0 @ Aug 9 2005, 08:27 AM)QUOTE(nil...   Aug 11 2005, 12:16 AM
inode0   QUOTE(bam @ Aug 11 2005, 08:16 AM)so how abou...   Aug 11 2005, 09:41 AM
bam   thats it trying this for kopimail.....will come ba...   Aug 9 2005, 12:26 PM
nilch   Thanks for the SMTP section... Good news - now th...   Aug 11 2005, 11:50 AM
bam   has anyone got this to work with kopi? Followed th...   Aug 11 2005, 12:31 PM
inode0   QUOTE(bam @ Aug 11 2005, 08:31 PM)has anyone ...   Aug 11 2005, 12:37 PM
bam   how do I do that? I am a n00b, big time.   Aug 11 2005, 08:04 PM
inode0   QUOTE(bam @ Aug 12 2005, 04:04 AM)how do I do...   Aug 12 2005, 07:42 AM
bam   i dont even think its running, can you point me to...   Aug 12 2005, 11:29 AM
inode0   QUOTE(bam @ Aug 12 2005, 07:29 PM)i dont even...   Aug 12 2005, 12:01 PM
nilch   Are you trying to run Stunnel as a daemon or as a ...   Aug 12 2005, 12:26 PM
bam   I would like to run it as a daemon so the command ...   Aug 12 2005, 06:04 PM
inode0   QUOTE(bam @ Aug 13 2005, 02:04 AM)I would lik...   Aug 12 2005, 09:32 PM
nilch   The -l switch expects a program name after it... y...   Aug 13 2005, 10:11 AM
bam   cool i will try it   Aug 15 2005, 09:55 PM
bam   folder initialization error 5...seems to not work,...   Aug 16 2005, 11:24 AM
inode0   QUOTE(bam @ Aug 16 2005, 07:24 PM)folder init...   Aug 16 2005, 11:33 AM
bam   yup working great, a little slow, but I am in no r...   Aug 16 2005, 12:08 PM
inode0   QUOTE(bam @ Aug 16 2005, 08:08 PM)yup working...   Aug 16 2005, 12:14 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th September 2014 - 08:02 PM