OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Opera 7.55 On Hentges Oz3.5.3 64-0 Opie, Installing Opera 7.55
Snappy
post Aug 9 2005, 07:55 AM
Post #1





Group: Members
Posts: 793
Joined: 28-November 04
From: NM, US, sometimes Asia
Member No.: 5,633



Hi all,

I've searched and searched but cannot find a definitive guide to installing Opera 7.55 on Hentges rom OZ3.5.3 Opie 64-0 on SD.

After installation, there is no Opera icon and when I try running the binary directly from file manager, the taskbar just briefly shows the Opera icon and disappears.

Please help! sad.gif
Go to the top of the page
 
+Quote Post
Greg2
post Aug 9 2005, 09:42 AM
Post #2





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(Snappy @ Aug 9 2005, 11:55 AM)
I've searched and searched but cannot find a definitive guide to installing Opera 7.55 on Hentges rom OZ3.5.3 Opie 64-0 on SD.

Instructions for SD-card installation-
D/L the opera ipk from the second post of mine here:
http://www.oesf.org/forums/index.php?showtopic=10612&st=30

Copy it to your CF-card and open a terminal:
CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.6079_arm.ipk
cd
ipkg-link mount /media/card
exit

Go to the Settings tab, click "Reload Icons"
Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.
Surf the web.

Please note that because of the 3.5.3sharp-compat-libs you may need to click on the opera icon twice to open or close the browser.

Greg
Go to the top of the page
 
+Quote Post
Snappy
post Aug 9 2005, 10:39 AM
Post #3





Group: Members
Posts: 793
Joined: 28-November 04
From: NM, US, sometimes Asia
Member No.: 5,633



thanks for the fast reply! biggrin.gif ... trying now ... wink.gif

EDIT: Somehow the installation goes through, but the icon is still not there. btw, my file is opera_arm.ipk, from data.tar.gz. Is that right?

I'll retry from the link you point me again ... unsure.gif

EDIT: Woopie! It works! Thanks Greg!! biggrin.gif

Sent from Opera 7.55.6079 on OZ 3.5.3 opie
Go to the top of the page
 
+Quote Post
tombraider
post Aug 10 2005, 05:25 AM
Post #4





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



QUOTE(Greg2 @ Aug 9 2005, 05:42 PM)
QUOTE(Snappy @ Aug 9 2005, 11:55 AM)
I've searched and searched but cannot find a definitive guide to installing Opera 7.55 on Hentges rom OZ3.5.3 Opie 64-0 on SD.

Instructions for SD-card installation-
D/L the opera ipk from the second post of mine here:
http://www.oesf.org/forums/index.php?showtopic=10612&st=30

Copy it to your CF-card and open a terminal:
CODE
cd /media/cf
ipkg -d sd --force-depends install opera_7.55.6079_arm.ipk
cd
ipkg-link mount /media/card
exit

Go to the Settings tab, click "Reload Icons"
Go to the Settings tab, click on Libraries, List, Applications, Opera Browser and click okay.
Surf the web.

Please note that because of the 3.5.3sharp-compat-libs you may need to click on the opera icon twice to open or close the browser.

Greg
*



Greg,
Thanks, that is the first time I have been able to install a semi-working Opera on OZ.

One problem, with which maybe you can help, the icon which switches from column to regular view doesn't really work, but that doesn't bother me as much as the "expand" icon to the right of it not enlarging the font. The icon appears to just "widen" the size of the screen view WITHOUT enlarging the font.

Now, I figure this may be because the fonts for Opera which have a size range from very small to very large are not installed in Opie but ARE present in the Sharp ROM. Would you have any insight into what those fonts or ipks might be and how I could install them onto my OZ Zaurus??

I need big print for my old eyes. cool.gif And that's one of the features I LOVED about the Sharp ROM Opera.
Go to the top of the page
 
+Quote Post
Greg2
post Aug 10 2005, 06:33 AM
Post #5





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(tombraider @ Aug 10 2005, 09:25 AM)
Would you have any insight into what those fonts or ipks might be and how I could install them onto my OZ Zaurus??

I need big print for my old eyes.  cool.gif 

Your not that much older than me... I'm typing this now wearing my trifocals. smile.gif

By default the opera.ini uses helvetica fonts... just install the qte-font-helvetica-large ipk from the opie feed. This will give you a larger font all the time, if that's not large enough let me know and I will play with some fonts to see what I get.

Greg
Go to the top of the page
 
+Quote Post
Yasen
post Sep 9 2005, 05:38 AM
Post #6





Group: Members
Posts: 107
Joined: 27-June 03
From: Sofia, Bulgaria, Europe
Member No.: 217



Has anybody tryed this on poodle?
Go to the top of the page
 
+Quote Post
Greg2
post Sep 9 2005, 06:28 AM
Post #7





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(Yasen @ Sep 9 2005, 09:38 AM)
Has anybody tryed this on poodle?

Yes it works on the poodle.
Go to the top of the page
 
+Quote Post
EdbO
post Nov 1 2005, 02:06 PM
Post #8





Group: Members
Posts: 31
Joined: 19-November 04
From: None
Member No.: 5,530



I installed Opera, but I got an error
CODE
opera: libvxm.so: cannot open shared object file: No such file or directory

I search the board and googled around but cannot find something about this. Which package am I missing?

I'm using Oz/Opie 3.5.4-RC1 on Collie
Go to the top of the page
 
+Quote Post
Greg2
post Nov 2 2005, 02:26 PM
Post #9





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(EdbO @ Nov 1 2005, 05:06 PM)
I installed Opera, but I got an error
CODE
opera: libvxm.so: cannot open shared object file: No such file or directory

I search the board and googled around but cannot find something about this. Which package am I missing?

I'm using Oz/Opie 3.5.4-RC1 on Collie
*

That is part of the voice package included with the 'multimodal.ipk' and is not used with OZ... so you can disregard that error.

You will howerver have to install some fonts for opera to start properly with OZ3.5.4-rc.
I use qte-font-helvetica-large from the opie feed and have no problems... you may however use a smaller helvetica font if your eyes are better then mine. smile.gif

Please note that this (the one linked in this thread) opera ipk was built for OZ3.5.2 which used no packages directory. If you (or anyone) are still having problems because of this... just ask and I will build you a new ipk for 3.5.4.

Greg
Go to the top of the page
 
+Quote Post
EdbO
post Nov 3 2005, 03:32 AM
Post #10





Group: Members
Posts: 31
Joined: 19-November 04
From: None
Member No.: 5,530



Thanks for the repy, but I got this error and next opera gives me a segfault sad.gif I thought that this was related to the libvxm.so file.

If you have the time, please create an opera-package for Oz/Opie 3.5.4.
Go to the top of the page
 
+Quote Post
Greg2
post Nov 3 2005, 09:07 AM
Post #11





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(EdbO @ Nov 3 2005, 06:32 AM)
If you have the time, please create an opera-package for Oz/Opie 3.5.4.

Here it is... please follow the instructions:
http://www.oesf.org/forums/index.php?showtopic=15885&hl=

Greg
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 04:02 AM