OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> C860 Nand Backup To Sd?
oldhat
post Aug 15 2005, 07:35 PM
Post #1





Group: Members
Posts: 17
Joined: 11-June 05
Member No.: 7,324



Story goes like this... I've been reading all the pages I could find (like http://www.oesf.org/index.php?title=C860_Customizations) on creating a nand backup of a C860 and everything points to requiring a CF card. So, trying to get the most for my $$ I pick up a 512MB Kingston Elite Pro, and it appears that it was a bad choice as the backup process just stops with a 'Can not initialize CF', darn.

Well, on a guess I took out the CF, but put in my 1GB Kingston Elite SD card and tried the nand backup again, and it went to the SD card just fine. Is this supposed to work? I don't want to brick the unit trying a restore from the SD so I thought asking might be a good idea...

Thanks!
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 7)
TRIsoft
post Aug 16 2005, 12:14 AM
Post #2





Group: Members
Posts: 332
Joined: 6-June 04
From: Hannover, Germany
Member No.: 3,587



Hi oldhat,

compressed story:
The SL-C series are able to perform NAND backup or
restore operations with CF or SD cards.

The service menu is _very_ fussy with the cards and
normally CF cards are easier in handling compared to
the SD type. But if it's better for you to use the SD
card, you're free to do this.

///TRIsoft

Marc Stephan
Go to the top of the page
 
+Quote Post
Stubear
post Aug 16 2005, 06:21 AM
Post #3





Group: Members
Posts: 1,164
Joined: 17-December 03
From: Melbourne, AUSTRALIA
Member No.: 1,219



Make sure your CF is formatted FAT (FAT16) and not FAT32, not sure if anyone is doing this but the Zaurus NAND backup/restore can't read from FAT32.

I've personally done NAND backup and restore from SD on the C760, C860 and C1000 models.

To get the zaurus to use the SD card, the CF card must not be in the unit. If it is present the zaurus will try to use it first and if anything is wrong then cancel the backup/restore.

One of my CF cards must be freshly formatted to work with the NAND backup/restore, if there is anything on the card I get a format error everytime - which lead me to discover that you can NAND backup from SD wink.gif As Marc says the service menu is very fussy about the card (both CF and SD)

Stu
Go to the top of the page
 
+Quote Post
oldhat
post Aug 16 2005, 08:11 PM
Post #4





Group: Members
Posts: 17
Joined: 11-June 05
Member No.: 7,324



Thanks to all! To be 'safe' I picked up a cheap CF and that worked fine for a CF backup. The Kingston Elite SD card seems to be working great as well. Thanks again!
Go to the top of the page
 
+Quote Post
mmhere123456
post Aug 26 2005, 10:09 PM
Post #5





Group: Members
Posts: 11
Joined: 26-August 05
Member No.: 7,954



I tried to backup to a 2GB CF card (branded "PQI" picked up from Fry's), but it didn't work.

So then (under the Zaurus SL-C3100 command line), wiped the partition table with sfdisk, remade a FAT16 type partition (id 6), and did "mkdosfs -v -F 16". The Zaurus still refused to back up to this card.

So I ended up using an SD card instead, which worked fine.

Could someone please post the proper sequence to "clean format" a CF card using the Zaurus itself, so that the NAND Flash backup will work? I suppose I could also format the CF card from my windoze machine...
Go to the top of the page
 
+Quote Post
zedkatuf2
post Aug 13 2006, 05:41 PM
Post #6





Group: Members
Posts: 155
Joined: 6-March 05
Member No.: 6,578



QUOTE(mmhere123456 @ Aug 27 2005, 07:09 AM)
I tried to backup to a 2GB CF card (branded "PQI" picked up from Fry's), but it didn't work.

So then (under the Zaurus SL-C3100 command line), wiped the partition table with sfdisk, remade a FAT16 type partition (id 6), and did "mkdosfs -v -F 16".  The Zaurus still refused to back up to this card.

So I ended up using an SD card instead, which worked fine.

Could someone please post the proper sequence to "clean format" a CF card using the Zaurus itself, so that the NAND Flash backup will work?  I suppose I could also format the CF card from my windoze machine...
*


I confirm too this issue! I've spent the last 90 minutes trying to do a NAND restore & used severl different CF cards without success.

As I write, my 3200 is NAND restoring from a PQI 1Gbyte SD card that I formatted as per the above instructions...I was getting worried that I'd got myself a very expensive brick!!!!

zedkatuf
Go to the top of the page
 
+Quote Post
Meanie
post Aug 13 2006, 06:03 PM
Post #7





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



I think the NAND backup/restore and even the flashing feature does not like cards > 1GB for both CF and SD cards. Never had problems with the smaller cards so I use the small cards for flashing and nand backup while using the large ones for storage. I actually store several nand images on my 4GB SD card, but I copy it to a smaller 256MB card when I want to restore a NAND image.
Go to the top of the page
 
+Quote Post
zedkatuf2
post Aug 14 2006, 12:45 AM
Post #8





Group: Members
Posts: 155
Joined: 6-March 05
Member No.: 6,578



QUOTE(Meanie @ Aug 14 2006, 03:03 AM)
I think the NAND backup/restore and even the flashing feature does not like cards > 1GB for both CF and SD cards. Never had problems with the smaller cards so I use the small cards for flashing and nand backup while using the large ones for storage. I actually store several nand images on my 4GB SD card, but I copy it to a smaller 256MB card when I want to restore a NAND image.
*


..it worked (thankfully!) with the PQI 1gbyte SD card.

NAND restore didin't want to work on a freshly-refatted (16) 256mbyte card..perhaps it didn't like the make.

Prior to using a 3200, I had similar re-flashing problems with my collie until I tried a Sandisk CF card - this, sadly, is too small (only 48mbytes!!) for a NAND restore for my 3200.

Cheers,

zedkatuf
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 02:58 PM