OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Bluetooth Problem On Henntges Oz 3.5.3, Getting Bluetooth started on OZ
Marty
post Aug 28 2005, 12:52 PM
Post #1





Group: Members
Posts: 44
Joined: 11-May 04
Member No.: 3,200



I have Hentges OZ 3.5.3 and Cardfs up and running on my Z.
Now how do I get bluetooth started on OZ 3.5.3 ?

I have an LSE038 Bluecard which is recognised as soon as I put it into the Z.
However the light never goes on.
The network bnep0 cant be started.
I've tried sdp tool browse but nothing happens.

Card Details

cardctl ident

socket 0:
product info : "WSS" , "LSE039"
manfid: 0x0264, 0x0008
funtion: 6 (network)
Socket 1:
no product info available


I've checked bluetooth.conf - here's the driver for my card.

device "bluecard_cs"
class "bluetooth" module "bluecard_cs"

card "LSE039 Bluetooth PC Card"
version "wss","LSE039"
bind "bluecard_cs"

I assume bluecard_cs is part of the bluetooth module - I dont see it as an opie or oz module -can someone confirm this?

Help please!
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
HeavyWeaponDude
post Sep 7 2005, 03:50 PM
Post #2





Group: Members
Posts: 37
Joined: 29-June 05
Member No.: 7,484



Would you please help me reach your same result?

I've managed to install correctly a Billionton card at kernel level.
It is correctly recognized, and if i use

CODE
setserial /dev/ttyS3 baud_base 921600
modprobe hci_uart
hciattach /dev/ttyS3 billionton
hciconfig hci0 up


the cards go up and running. I've just tried to make some "hcitool scan" with other bt peripherals around, just to test, and everything is fine.

But if i try to run:
/etc/init.d/bluetooth start

I got this error:
Starting Bluetooth subsystem: hcid sdpd Can't open HIDP control socket: No such file or directory
hidd rfcomm.

And nothing works.
I would like to make at least /etc/init.d/bluetooth start (and stop) to work.
Otherwise, being unable to stoppping the service, every time I extract the card I need to reboot the Z to make it work again.

Thanks for any help!
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 01:29 AM