OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> Bluetooth Problem On Henntges Oz 3.5.3, Getting Bluetooth started on OZ
Marty
post Sep 14 2005, 02:05 PM
Post #16





Group: Members
Posts: 44
Joined: 11-May 04
Member No.: 3,200



The only thing I altered in /etc/initid/bluetoth was that I commented out the references to HIDD which was causing the same sort of error message that you saw appeared on my z when I ran "/etc/init.d/bluetooth start".
Once I did that the error message went away.

I then found that when I came out of a suspend and ran "/etc/etc/init.d/bluetooth start" the light on the card flashed but... my dial up script would'nt work.
However if I ran "/etc/init.d/bluetooth stop" then "/etc/init.d/bluetooth start" then everything would work just fine.

I've tried modprobeing the bluecard_cs driver in the past but didnt see much happening. I found the rmmod insmod of the driver to do something (at least it told me the bluecard_cs driver was already loaded.)
I know your card uses a different driver than mine but it looks like its not being loaded properly
Maybe you should try that approach instead of modprobe. (see script)
Sorry I wish I could be more help but I'am not an expert on bluetooth.
Go to the top of the page
 
+Quote Post
HeavyWeaponDude
post Sep 18 2005, 03:51 PM
Post #17





Group: Members
Posts: 37
Joined: 29-June 05
Member No.: 7,484



Uhm...
Following your suggestions I'm going somewhere. smile.gif
It is not much pratical right now, but still it works, more or less.

I've wrote a little script:

CODE
#!/bin/sh
modprobe hci_uart
sleep 1
setserial /dev/ttyS3 baud_base 921600
hciattach /dev/ttyS3 billionton
hciconfig hci0 up
/etc/init.d/bluetooth start


It basically does what /etc/init.d/bluetooth alone didn't do: setup my card and then startup the bluetooth services. Of course I too have commented out the references to HIDD in /etc/init.d/bluetooth.

However, even if when i run it everything seems to work well ("hciconfig -a" shows the device, and "hcitool -scan" gives the proper results), I get the following message just after running it:

BCSP initialization time out

Making some test, I found that is due to the "hciconfig hci0 up" being in the script.
If I remove it from there and run it manually, I don't get the message.
I've tried also to put some sleep time between "hciattach" and "hciconfig" in the script, but still I get the message. Any hint on this?

I can remove the card running /etc/init.d/bluetooth stop. When I re-insert it I should re-run my script. When I suspend, I have to resume the card manually, by "cardctl resume 0".

At least this way, I've to run just one command upon starting/stopping the bluetooth.
Thanks for any help so far.


***little update***

The card is somewhat unreliable. Sometimes, upon insertion, the led doesn't blink.
Even if "cardctl status" shows the card as being active, it is not.
Doing "cardctl suspend 0", waiting a couple of seconds, and then "cardctl resume 0",
makes it up. Then the script works well, and doesn't give that "BCSP initialization time out" error message.
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th July 2014 - 06:37 PM