OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Mobile Gmaps On The Zaurus, How to get it working?
eji
post Oct 18 2005, 12:49 PM
Post #1





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



I know my 6000 has J2ME on it. And "MGMaps runs on devices that support CLDC 1.0 and MIDP 1.0 or later." So how do I get it to run the Google Maps program Mobile GMaps?

There are .jar and .jad files here: http://wap.mgmaps.com/

What the heck do I do with these files?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
eji
post Feb 6 2006, 04:54 AM
Post #2





Group: Members
Posts: 233
Joined: 29-November 04
From: Germany
Member No.: 5,659



I hope you're not asking as a means of getting advice. I honestly have no clue what I'm doing... I'm only figuring things out from following directions and trial and error.

Anyway, after putting mgmaps.jar, mgmaps.jad, and the above files in the same directory, and then cd'ing to them in the terminal, I used a variation of Meanie's command line entry as su:

#evm -classpath ./me4se.jar:./midpx.jar:./mgmaps.jar

Needless to say, really, it didn't work. I got a promising pause and then an error saying "Qt/Embedded data not valid for user 0" (or something along those lines). I tried adjusting the permissions of the files several different ways but no luck.

On the other hand, I've got lots of J2ME game applets (available here) running, so I must be doing something right.
Go to the top of the page
 
+Quote Post
ken
post Feb 6 2006, 05:13 AM
Post #3





Group: Members
Posts: 274
Joined: 17-October 04
Member No.: 5,063



QUOTE(eji @ Feb 6 2006, 02:54 AM)
Needless to say, really, it didn't work. I got a promising pause and then an error saying "Qt/Embedded data not valid for user 0" (or something along those lines). I tried adjusting the permissions of the files several different ways but no luck.


faintly familiar. user 0 == root I think. Been a while since I last touched that stuff. Try another user, zaurus? I don't recall. Will try to play with that stuff later in the week.
Go to the top of the page
 
+Quote Post
damiandixon
post Mar 16 2006, 12:20 AM
Post #4





Group: Members
Posts: 4
Joined: 3-September 04
Member No.: 4,457



I've got the MIDlet running but am unable to download any maps.

javax.microedition.io.ConnextionNotFoundException is occuring saying that the requested protocol does not exist.

Any ideas?

Thanks
Damian
Go to the top of the page
 
+Quote Post
damiandixon
post Mar 17 2006, 12:24 AM
Post #5





Group: Members
Posts: 4
Joined: 3-September 04
Member No.: 4,457



It appears that JavaME does not require the socket protocol to be implemented.

I reverse engineered the java class responsible and it is relying on a load of properties to find the protocol class to load. The use of properties is something I have not done before.

We may need to copy more classes over from midp-2_0-src-linux-i686.zip, and we may need to use more of classes as well. The dev-tip looks more promising with regards to the ME io classes. However the low level socket implementation is in C code.

Additionally I appear to be missing libkke.so (Sharp ROM - C860).

If I have time I will have a look at using the Blackdown J2SE as this is closer to what I need in anycase and probably has more functionality implemented.


By the way what I am looking for is a half way decent map & routing application on the Zaurus (GPS input would be handy though it is fairly easy to read and decode).

Using map data from Google (or one of the other free sources) is ideal as PocketStreets, Garmin, TomTom etc all use closed formats.

I have looked at a number of free map projects but they are rather limited in source material for the UK.

Has anyone come across descriptions of the data format for PocketStreets or TomTom (I have found a document describing part of the Garmin format).


Regards
Damian

QUOTE(damiandixon @ Mar 16 2006, 08:20 AM)
I've got the MIDlet running but am unable to download any maps.

javax.microedition.io.ConnextionNotFoundException is occuring saying that the requested protocol does not exist.

Any ideas?

Thanks
Damian
*
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 15th September 2014 - 08:59 PM