OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Pdaxrom & Mac Connection Issues, Any satisfactory solution so far?
ZDevil
post Oct 19 2005, 10:34 PM
Post #1





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



After setting up pdaXrom (RC11) on my C1000 for a couple of weeks, I begin to look into the synchronization and connection between pdaXrom and OS X 10.4 seriously. Previously I tried dhns' ZMacSync & AJzaurusUSB packages and they worked great with Sharp ROM. However that solution is for Sharp ROM only, and there seems to be no plan for other systems, like pdaXrom. sad.gif

Ping from both my C1000 & iBook failed, not to mention samba, telnet and ftp (just reporting host unreachable). Maybe due to my ignorance of networking but that's what I can do for the moment.

Using memory card mode in the USB setting in X works with glitches, as the card will get mounted multiple times (usually around 7 or 8) on OS X 10.4, although this problem is already less serious than on Sharp ROM before applying the AJzaurusUSB driver (which can get to almost 50 mountings!) .

So it seems the USB drivers in OS X fails to recognize Zaurus (running X) properly.

I think I have searched through this forums and the FAQs and googled quite a lot and all the solutions apply to Sharp ROM only.

How is the experience of other Mac users here who also run X on your Zaurii?

Or is there/ will there be any solution in pdaXrom?

Many many many thanks! smile.gif

zdevil
Go to the top of the page
 
+Quote Post
ZDevil
post Oct 20 2005, 06:20 AM
Post #2





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Oops. Perhaps I should've posted this in the "Mac Issues" forum. Could the moderator kindly move this thread to there please? Sorry for the trouble.
Go to the top of the page
 
+Quote Post
dhns
post Oct 21 2005, 12:18 AM
Post #3





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(ZDevil @ Oct 20 2005, 07:34 AM)
After setting up pdaXrom (RC11) on my C1000 for a couple of weeks, I begin to look into the synchronization and connection between pdaXrom and OS X 10.4 seriously.  Previously I tried dhns' ZMacSync & AJzaurusUSB packages and they worked great with Sharp ROM.  However that solution is for Sharp ROM only, and there seems to be no plan for other systems, like pdaXrom.  sad.gif 

Hm,
there seem to be several issues.

1) basic IP over USB connection
2) logical connection, e.g. telnet, X11
3) sync

1) I have never worked with pdaXrom, so I can't tell much about the IP over USB support of that ROM. If they have not changed too much from the Sharp ROM, this should be very similar. Does the device show up in the Mac System Profiler's USB interfaces listing? How does it identify itself there?

2) if 1) would work, 2) should work without trouble. I have used the X11 system in both directions with X/Qt on a Sharp ROM. You can use the Mac as a "large display" or the Z as a "remote display".

3) That is less an issue of the ROM but the PIM databases and data formats.

Unfortunately, there is no real standard out there. The original Sharps did use XML. The current models use a database called DTM. OpenZaurus uses something else. And for pdaXrom I think you can install whichever PIM system you find for X11/Linux.

That is the reason why I focus on DTM/SharpROM (it is still complex enough): because it makes the Z work out of the box (giving immediate value). And the visionary project is QuantumSTEP which tries to make the database compatible with the formats on the Mac - so you will never loose information by syncing.

-- hns
Go to the top of the page
 
+Quote Post
zeigerpuppy
post Nov 6 2006, 04:15 PM
Post #4





Group: Members
Posts: 109
Joined: 23-December 05
Member No.: 8,778



I am also having problems with Mac OSX 10.4 USB access since switching to pdaxrom beta 3.
I was previously using Cacko on my 3100.

The USB storage mode mounts and keeps mounting lots of instances of the drive... I had never let it finish but will test to see if there is a particular number. Good to know that removing the AJBUSB driver may help this problem.

I think that the lan connection works but I usually use a wifi connection which works perfectly for both SSH and SAMBA access.

I have no problem with mounting the USB storage on Windows.

Anyone know why the Mac would be trying to mount so many instances?
PS: I also tried Mac OSX 10.3 and it doesn't mount the USB storage at all!
Go to the top of the page
 
+Quote Post
daniel3000
post Nov 7 2006, 01:09 AM
Post #5





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



I always use a WLAN connection and Samba to access Zaurus storage from other computers.
Not tried a Mac yet, but I will soon, as I am about to order a macbook.
Since WLAN and Samba are standards in all systems (Linux, Windows, Mac OS) this should be the best solution. I don't trust USB-storage too much, especially across OSes.

Another advantage of Samba: You can have access to multiple drives of the Zaurus at one time. USBstorage only allws to access on e drive at a time.
Also the drive you access from outside should be blocked for the Zaurus. Not so with Samba.

NFS would be another alternative. MacOS should be able to use it without problems. Maybe Windows does have problems, not sure.

daniel
Go to the top of the page
 
+Quote Post
zeigerpuppy
post Nov 7 2006, 04:50 AM
Post #6





Group: Members
Posts: 109
Joined: 23-December 05
Member No.: 8,778



QUOTE(daniel3000 @ Nov 7 2006, 01:09 AM)
I always use a WLAN connection and Samba to access Zaurus storage from other computers.
Not tried a Mac yet, but I will soon, as I am about to order a macbook.
Since WLAN and Samba are standards in all systems (Linux, Windows, Mac OS) this should be the best solution. I don't trust USB-storage too much, especially across OSes.

Another advantage of Samba: You can have access to multiple drives of the Zaurus at one time. USBstorage only allws to access on e drive at a time.
Also the drive you access from outside should be blocked for the Zaurus. Not so with Samba.

NFS would be another alternative. MacOS should be able to use it without problems. Maybe Windows does have problems, not sure.

daniel
*


True, but the advantage of a simple USB connection is that you can plug in to almost any computer, even at an internet cafe and transfer files without needing to know anything about the network or have administrator access. I guess I should be happy that it still works on Windows, considering these are more likely to be in the internet cafes. Still, it's a bug which I'm sure can be fixed
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 08:34 PM