OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> 1.0rc4 Wireless Setup, Wifi tips and troubleshooting.
post Oct 30 2005, 08:32 AM
Post #1

Group: Members
Posts: 19
Joined: 17-October 04
Member No.: 5,065

I have added a new script to the ones provided by Guylhem in 1.0rc4 (just added wep stuff to net.wifi.local).

This one is to connect to a WEP enabled network.


1) Download and unpack attached script (net.wifi.wep)
2) Change network setup on lines 3 to 24
3) On the Zaurus' console become root:
su <enter>
When asked for password, press <enter>.
4) Copy the file to the Zaurus' /usr/local/bin/
i.e. cp /mnt/cf/net.wifi.wep /usr/local/bin
5) Define script perms:
chown root:qpe /usr/local/bin/net.wifi.wep
chmod 0755 /usr/local/bin/net.wifi.wep



You can edit /etc/resolv.conf to match the DNS servers provided by your ISP. Some may find that name resolution is faster that way

I have checked this setup just after a fresh NAND restore so I hope everyone is able to connect this time wink.gif.

FIX: Sometimes wep keys do not get loaded by wlanctl-ng. Waiting a little bit more and setting up WEP keys after bringing up the network interface makes a big difference.

I have updated the attached script.

This post has been edited by orodriguez: Oct 30 2005, 01:51 PM
Attached File(s)
Attached File  net_wifi_wep_fixed.zip ( 926bytes ) Number of downloads: 238
Go to the top of the page
+Quote Post
Start new topic
post Nov 25 2005, 12:48 AM
Post #2

Group: Admin
Posts: 3,535
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149


your wep setup script worked for me; I did the hack to set the chosen wep key to number 0. I also had to hack /etc/resolv.conf too. I usually have to run the script twice, it reports no such device the first time. Maybe it would be best to write a simply loop with timeout to wait for the device to appear?

And finally, because of my fascist security, I created the proxy config file using hluc's info on his 3100. Basically, you create a file called
with the proxy settings in it - I can post the file if people wish. The presence of the file is used automatically by Opera, you don't need to restart it. As far as I know from my Cacko/860 use, netfront also dynamically tracks this file.
Go to the top of the page
+Quote Post
post Dec 21 2005, 10:10 AM
Post #3

Group: Members
Posts: 2,808
Joined: 13-September 04
From: Wasilla Ak.
Member No.: 4,572

I tried with my simple, open network (mac address locking only--and the z's mac address is on the list),
no luck.
played with editing net.wifi.local
no luck

a shame-- now that I have 3100 tp play with pdaxrom, I was hoping to switch my 6000 to guylhem rom.

I guess its back to popping a better kernel into sharprom.... as was the rage a year ago
Go to the top of the page
+Quote Post
post Dec 21 2005, 10:32 AM
Post #4

Group: Members
Posts: 141
Joined: 5-July 05
From: Tucson, AZ
Member No.: 7,538

QUOTE(adf @ Dec 21 2005, 01:10 PM)
I guess its back to popping a better kernel into sharprom....  as was the rage a year ago

Do you mean using guylhem's kernal and the Default sharp rom? How does this work? Do you still get the over/under clocking abiltiy and the nice keyboard mappings?

Does he have the kernel sperate, the same one that is in the 1.0RC4 ROM???
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th June 2018 - 11:42 AM