OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

9 Pages V  « < 7 8 9  
Reply to this topicStart new topic
> X/qt Preconfigured With Apps, running off cramfs images
freebird
post May 17 2006, 03:12 AM
Post #121





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(xamindar @ May 17 2006, 09:44 AM)
abiword gives me
CODE
abiword

(abiword:4673): GdkPixbuf-WARNING **: Error loading XPM image loader: Image type 'xpm' is not supported

(abiword:4673): Gtk-CRITICAL **: gtk_icon_set_new_from_pixbuf: assertion `pixbuf != NULL' failed

(abiword:4673): Gtk-CRITICAL **: gtk_icon_factory_add: assertion `icon_set != NULL' failed

(abiword:4673): Gtk-CRITICAL **: gtk_icon_set_unref: assertion `icon_set != NULL' failed
Aborted
bash-3.00#

*

Xaminder try typing this on the console
CODE
#su
#ln -sf /opt/QtPalmtop/lib/gtk-2.0 /usr/lib/gtk-2.0
#gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

freebird
Go to the top of the page
 
+Quote Post
freebird
post May 17 2006, 01:58 PM
Post #122





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(Meanie @ May 16 2006, 10:33 PM)
?????
why didnt you use the install/setup scripts?
all you problems is because you didnt run the setup scripts
installing to SD and CF is exactly the same (except for speed of those devices). what are  you trying to accomplish?

xamindar: i could reproduce the crash with gaim 1.5, but with gaim 2.0 it works fine on my machine. does it work for other people? did you reinstall or just replace the images?
you can replace the images and not run the install script but you have to run each of the setup script from the mounted images
*


Ok Meanie
have removed my ext2 CF
flashed my Z with cakco1.23 light
formatted the user partition
installed visudo
copied pdaXqtrom-install.sh, pdaXqtrom-apps.cramfs pdaXqtrom-base.cramfs to my fat16 sd card
typed
CODE
./pdaXqtrom-install.sh

started testing the mounted cramfs
i had the same warnings as when installed on the ext2 CF abiword, gnumeric.. not working
typed
CODE
#su
#ln -sf /opt/QtPalmtop/lib/gtk-2.0 /usr/lib/gtk-2.0
#gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

then abiword, gnumeric works
but stardict and planner still not working
and i have the same warning too
for planner:
CODE
#xlauncher planner
launching planner - please wait a moment....
(planner:2269): Gtk-WARNING **: Error loading icon from file '/usr/share/pixmaps/gnome-planner.png':
Couldn't recognize the image file format for file '/usr/share/pixmaps/gnome-planner.png'
(planner:2269): Gtk-CRITICAL **: gtk_icon_set_new_from_pixbuf: assertion 'pixbuf !=NULL ' failed

for stardict:
i had a a blank square in the middle of the screen and these warning on the terminal
CODE
#xlauncher stardict
launching startdict - please wait a momoent....
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'pixbuf !=NULL' failed
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'pixbuf !=NULL' failed
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_draw_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

and finally
for gaim:
i had same segfault warnings as Xamindar

cheers smile.gif
freebird
Go to the top of the page
 
+Quote Post
Meanie
post May 17 2006, 06:09 PM
Post #123





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(freebird @ May 18 2006, 07:58 AM)
QUOTE(Meanie @ May 16 2006, 10:33 PM)

?????
why didnt you use the install/setup scripts?
all you problems is because you didnt run the setup scripts
installing to SD and CF is exactly the same (except for speed of those devices). what are  you trying to accomplish?

xamindar: i could reproduce the crash with gaim 1.5, but with gaim 2.0 it works fine on my machine. does it work for other people? did you reinstall or just replace the images?
you can replace the images and not run the install script but you have to run each of the setup script from the mounted images
*


Ok Meanie
have removed my ext2 CF
flashed my Z with cakco1.23 light
formatted the user partition
installed visudo
copied pdaXqtrom-install.sh, pdaXqtrom-apps.cramfs pdaXqtrom-base.cramfs to my fat16 sd card
typed
CODE
./pdaXqtrom-install.sh

started testing the mounted cramfs
i had the same warnings as when installed on the ext2 CF abiword, gnumeric.. not working
typed
CODE
#su
#ln -sf /opt/QtPalmtop/lib/gtk-2.0 /usr/lib/gtk-2.0
#gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

then abiword, gnumeric works
but stardict and planner still not working
and i have the same warning too
for planner:
CODE
#xlauncher planner
launching planner - please wait a moment....
(planner:2269): Gtk-WARNING **: Error loading icon from file '/usr/share/pixmaps/gnome-planner.png':
Couldn't recognize the image file format for file '/usr/share/pixmaps/gnome-planner.png'
(planner:2269): Gtk-CRITICAL **: gtk_icon_set_new_from_pixbuf: assertion 'pixbuf !=NULL ' failed

for stardict:
i had a a blank square in the middle of the screen and these warning on the terminal
CODE
#xlauncher stardict
launching startdict - please wait a momoent....
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion 'pixbuf !=NULL' failed
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion 'pixbuf !=NULL' failed
(startdict:2717): Gdk-pixbuf-CRITICAL **: gdk_draw_pixbuf: assertion 'GDK_IS_PIXBUF (pixbuf)' failed

and finally
for gaim:
i had same segfault warnings as Xamindar

cheers smile.gif
freebird
*



what does

CODE
ls -la /opt/QtPalmtop/lib/libpng*

show?

also. what is inside /etc/gtk-2.0/gdk-pixbuf.loaders ?

running gdk-pixbuf-query-loaders should not give you any errors unless you are missing some libraries.


what does

CODE
gaim --version

say?

can you run gaim with debug enabled, ie


CODE
gaim --debug
Go to the top of the page
 
+Quote Post
xamindar
post May 17 2006, 10:27 PM
Post #124





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



[quote=freebird,May 17 2006, 03:12 AM]Xaminder try typing this on the console
CODE
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so is unloadable: undefined symbol: serv_set_away
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/docklet.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/extplacement.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaim-remote.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaim-remote.so is unloadable: undefined symbol: away_messages
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaimrc.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gestures.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/history.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/iconaway.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/idle.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so is unloadable: undefined symbol: gaim_escape_html
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libirc.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libjabber.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libmsn.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so is unloadable: undefined symbol: gaim_escape_html
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnovell.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/liboscar.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libsimple.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libyahoo.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libzephyr.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/notify.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/psychic.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/relnot.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/spellchk.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl-gnutls.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl-nss.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/statenotify.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ticker.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/timestamp.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/timestamp_format.so
util: Reading file accounts.xml from directory /home/zaurus/.gaim
util: Reading file status.xml from directory /home/zaurus/.gaim
stun: using server
stun: using server
sound: Initializing sound output drivers.
util: Reading file blist.xml from directory /home/zaurus/.gaim
util: File /home/zaurus/.gaim/blist.xml does not exist (this is not necessarily an error)
prefs: Reading /home/zaurus/.gaim/prefs.xml
prefs: Finished reading /home/zaurus/.gaim/prefs.xml
prefs: removing pref /plugins/core/autorecon/hide_connected_error
prefs: removing pref /plugins/core/autorecon/hide_connecting_error
prefs: removing pref /plugins/core/autorecon/restore_state
prefs: removing pref /plugins/core/autorecon
pounce: Error reading pounces: Failed to open file '/home/zaurus/.gaim/pounces.xml': No such file or directory
Session Management: No SESSION_MANAGER found, aborting.
Gaim has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the gaim
developers by reporting a bug at
http://gaim.sourceforge.net/bug.php

Please make sure to specify what you were doing at the time
and post the backtrace from the core file.  If you do not know
how to get the backtrace, please read the instructions at
http://gaim.sourceforge.net/gdb.php

If you need further assistance, please IM either SeanEgn or
LSchiere (via AIM).  Contact information for Sean and Luke
on other protocols is at
http://gaim.sourceforge.net/contactinfo.php


Also, if I try to run gaim as root I get the following and it doesn't even load:
CODE
gaim: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot load shared object file: No such file or directory


I hope this stuff helps in any way.
Go to the top of the page
 
+Quote Post
freebird
post May 18 2006, 04:41 AM
Post #125





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(Meanie @ May 18 2006, 02:09 AM)
what does

CODE
ls -la /opt/QtPalmtop/lib/libpng*

show?

also. what is inside  /etc/gtk-2.0/gdk-pixbuf.loaders ?

running gdk-pixbuf-query-loaders should not give you any errors unless you are missing some libraries.


what does

CODE
gaim --version

say?

can you run gaim with debug enabled, ie


CODE
gaim --debug

*


here you are

ls -la /opt/QtPalmtop/lib/libpng* output:
CODE
lrwxrwxrwx    1 root     root           47 May 17 17:55 /opt/QtPalmtop/lib/libpng.so -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libpng.so
lrwxrwxrwx    1 root     qpe            15 May 17 17:21 /opt/QtPalmtop/lib/libpng.so.2 -> libqte.so.2.3.2
lrwxrwxrwx    1 root     qpe            15 May 17 17:21 /opt/QtPalmtop/lib/libpng.so.2.1.0.9 -> libqte.so.2.3.2
lrwxrwxrwx    1 root     root           49 May 17 17:55 /opt/QtPalmtop/lib/libpng.so.3 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libpng.so.3
lrwxrwxrwx    1 root     root           55 May 17 17:55 /opt/QtPalmtop/lib/libpng.so.3.1.2.7 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libpng.so.3.1.2.7
lrwxrwxrwx    1 root     qpe            15 May 17 17:21 /opt/QtPalmtop/lib/libpng12.so -> libqte.so.2.3.2
lrwxrwxrwx    1 root     qpe            15 May 17 17:21 /opt/QtPalmtop/lib/libpng12.so.0 -> libqte.so.2.3.2
lrwxrwxrwx    1 root     qpe            15 May 17 17:21 /opt/QtPalmtop/lib/libpng12.so.0.1.2.5 -> libqte.so.2.3.2
lrwxrwxrwx    1 root     root           57 May 17 17:55 /opt/QtPalmtop/lib/libpng12.so.0.1.2.7 -> /mnt/pdaXqtrom-base/opt/QtPalmtop/lib/libpng12.so.0.1.2.7


what is inside /etc/gtk-2.0/gdk-pixbuf.loaders:
CODE
# GdkPixbuf Image Loader Modules file
# Automatically generated file, do not edit
# Created by gdk-pixbuf-query-loaders from gtk+-2.6.2
#
# LoaderDir = /opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders
#
"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-ani.so"
"ani" 4 "gtk20" "The ANI image format"
"application/x-navi-animation" ""
"ani" ""
"RIFF    ACON" "    xxxx    " 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-bmp.so"
"bmp" 4 "gtk20" "The BMP image format"
"image/bmp" "image/x-bmp" "image/x-MS-bmp" ""
"bmp" ""
"BM" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-gif.so"
"gif" 4 "gtk20" "The GIF image format"
"image/gif" ""
"gif" ""
"GIF8" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-ico.so"
"ico" 5 "gtk20" "The ICO image format"
"image/x-icon" ""
"ico" "cur" ""
"  \001   " "zz znz" 100
"  \002   " "zz znz" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-jpeg.so"
"jpeg" 5 "gtk20" "The JPEG image format"
"image/jpeg" ""
"jpeg" "jpe" "jpg" ""
"\377\330" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-pcx.so"
"pcx" 4 "gtk20" "The PCX image format"
"image/x-pcx" ""
"pcx" ""
"\n \001" "" 100
"\n\002\001" "" 100
"\n\003\001" "" 100
"\n\004\001" "" 100
"\n\005\001" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-pnm.so"
"pnm" 4 "gtk20" "The PNM/PBM/PGM/PPM image format family"
"image/x-portable-anymap" "image/x-portable-bitmap" "image/x-portable-graymap" "image/x-portable-pixmap" ""
"pnm" "pbm" "pgm" "ppm" ""
"P1" "" 100
"P2" "" 100
"P3" "" 100
"P4" "" 100
"P5" "" 100
"P6" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-ras.so"
"ras" 4 "gtk20" "The Sun raster image format"
"image/x-cmu-raster" "image/x-sun-raster" ""
"ras" ""
"Y\246j\225" "" 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-tga.so"
"tga" 4 "gtk20" "The Targa image format"
"image/x-tga" ""
"tga" "targa" ""
" \001\001" "x  " 100
" \001\t" "x  " 100
"  \002" "xz " 99
"  \003" "xz " 100
"  \n" "xz " 100
"  \013" "xz " 100

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-wbmp.so"
"wbmp" 4 "gtk20" "The WBMP image format"
"image/vnd.wap.wbmp" ""
"wbmp" ""
" " "z" 1

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-xbm.so"
"xbm" 4 "gtk20" "The XBM image format"
"image/x-xbitmap" ""
"xbm" ""
"#define " "" 100
"/*" "" 50

"/opt/QtPalmtop/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-xpm.so"
"xpm" 4 "gtk20" "The XPM image format"
"image/x-xpixmap" ""
"xpm" ""
"/* XPM */" "" 100

the gaim version is: Gaim 2.0.0beta3
gaim --debug output is:
CODE
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so is unloadable: undefined symbol: serv_set_away
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/autorecon.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/docklet.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/extplacement.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaim-remote.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaim-remote.so is unloadable: undefined symbol: away_messages
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gaimrc.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/gestures.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/history.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/iconaway.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/idle.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so is unloadable: undefined symbol: gaim_escape_html
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libgg.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libirc.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libjabber.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libmsn.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so is unloadable: undefined symbol: gaim_escape_html
plugins: /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnapster.so is unloadable: ABI version mismatch 1.5.x (need 2.0.x)
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libnovell.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/liboscar.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libsimple.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libyahoo.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/libzephyr.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/notify.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/psychic.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/relnot.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/spellchk.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl-gnutls.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl-nss.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ssl.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/statenotify.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/ticker.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/timestamp.so
plugins: probing /home/system/var/mnt/pdaXqtrom-apps/usr/lib/gaim/timestamp_format.so
util: Reading file accounts.xml from directory /home/zaurus/.gaim
util: File /home/zaurus/.gaim/accounts.xml does not exist (this is not necessarily an error)
util: Reading file status.xml from directory /home/zaurus/.gaim
util: File /home/zaurus/.gaim/status.xml does not exist (this is not necessarily an error)
stun: using server
stun: using server
sound: Initializing sound output drivers.
Gtk: gtk_icon_set_new_from_pixbuf: assertion `pixbuf != NULL' failed


Also here is screenshot of ROX with icons displaying problem
Attached File(s)
Attached File  roxscreen.jpg ( 152.03K ) Number of downloads: 111
 
Go to the top of the page
 
+Quote Post
Meanie
post May 18 2006, 04:50 AM
Post #126





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



ok, that explains it.

for some reason your libpng is linked to libqte? how did that happen?
and because of that anything that needs to read png files will fail.

just remove them all and rerun the setup script, ie

CODE
rm /opt/QtPalmtop/libpng*
rm /etc/gtk-2.0/gdk-pixbuf.loaders
Go to the top of the page
 
+Quote Post
freebird
post May 18 2006, 07:06 AM
Post #127





Group: Members
Posts: 104
Joined: 27-October 04
Member No.: 5,242



QUOTE(Meanie @ May 18 2006, 12:50 PM)
ok, that explains it.

for some reason your libpng is linked to libqte? how did that happen?
and because of that anything that needs to read png files will fail.

just remove them all and rerun the setup script, ie

CODE
rm /opt/QtPalmtop/lib/libpng*
rm /etc/gtk-2.0/gdk-pixbuf.loaders

*



AND BINGO ! biggrin.gif

All problems have gone
tested planner, gaim, and Rox
every thing is OK now
Thanks Meanie wink.gif
Go to the top of the page
 
+Quote Post
xamindar
post May 18 2006, 09:42 AM
Post #128





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Dang, I tried that and gaim still segfaults when I try to add an account. sad.gif

Can I provide anything that may help?
Go to the top of the page
 
+Quote Post
Cresho
post May 18 2006, 11:56 AM
Post #129





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



i get a freetype error. older version and needs a newer version. This happens when launching game.
Go to the top of the page
 
+Quote Post
Meanie
post May 18 2006, 06:49 PM
Post #130





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Cresho @ May 19 2006, 05:56 AM)
i get a freetype error.  older version and needs a newer version.  This happens when launching game.
*


uninstall your old version of freetype
Go to the top of the page
 
+Quote Post
Thirrouard
post May 22 2006, 03:23 PM
Post #131





Group: Members
Posts: 9
Joined: 2-February 06
Member No.: 9,052



Hi Meanie smile.gif
In addition to my questions on the other topic, I just wanted to talk about the speed:
it take me 20 seconde to launch firefox, but its version 0.9 btw...
still have problem to launch Firefox 1.5... I'm rebooting my Z to see if it do change anything tongue.gif
Go to the top of the page
 
+Quote Post
Thirrouard
post May 22 2006, 04:08 PM
Post #132





Group: Members
Posts: 9
Joined: 2-February 06
Member No.: 9,052



realy tired lol
Go to the top of the page
 
+Quote Post
xamindar
post May 23 2006, 05:30 PM
Post #133





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Did we give up on gaim?
Go to the top of the page
 
+Quote Post
xamindar
post Jun 2 2006, 07:08 PM
Post #134





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Just a little followup. I have reflashed my Zaurus back to the japanese rom. Gaim still crashes for me when I try to add an account. However, I copied my .gaim folder from my linux machine over to the zaurus and bypassed the account add screen. So now it works (as long as I don't have to add an account).
Go to the top of the page
 
+Quote Post
Meanie
post Jun 3 2006, 10:50 PM
Post #135





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(xamindar @ Jun 3 2006, 01:08 PM)
Just a little followup.  I have reflashed my Zaurus back to the japanese rom.  Gaim still crashes for me when I try to add an account.  However, I copied my .gaim folder from my linux machine over to the zaurus and bypassed the account add screen.  So now it works (as long as I don't have to add an account).
*


well, that's good then smile.gif maybe this problem will be fixed in the next gaim beta but at least we have something useable till then
Go to the top of the page
 
+Quote Post

9 Pages V  « < 7 8 9
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th July 2014 - 03:15 AM